FedoraForum.org

FedoraForum.org (http://forums.fedoraforum.org/index.php)
-   Hardware & Laptops (http://forums.fedoraforum.org/forumdisplay.php?f=8)
-   -   Nvidia Mx-440 graphics card problem (http://forums.fedoraforum.org/showthread.php?t=193832)

Artic 9th July 2008 01:11 AM

Nvidia Mx-440 graphics card problem
 
Hello. I am new here so please if this is not in the right place I'm sorry.

I have recently installed Fedora 9 and I tried to install my graphics card. I searched in the Fedora Faq and in other websites and they all had the same steps:

su -

yum install kmod-nvidia

init 3

nvidia-config-display enable

reboot

The problem is when I reboot then it starts in text mode. I tried doing init 5 but when it is about to start it freezes. It freezes in some point where its about to start "Anacron" (don't know if that is the name, sorry)

I have to reboot, log as root and yum remove kmod-nvidia, then it starts normally.

I'm sorry for some mistake there may be but my english is not very good.
Probably I didn't gave enough information, so, anything you think that helps solving my problem just ask.


Thanks in advance.

Artic

Firewing1 9th July 2008 01:26 AM

Unfortunately your card is considered a legacy GPU so you have to use the 96xx driver - See here for more information. Before you install the 96xx driver though you'll have to remove the "regular" nvidia one since they're incompatible:
Code:

su -
rpm -e --allmatches xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs kmod-nvidia

There's just one package that I can't remove unless I know more information, to save time this script will auto-remove it:
Code:

rpm -qa --qf '%{NAME}\n' | grep ^kmod-nvidia | while read line;do rpm -e "$line";done
Now you're ready to install the 96xx driver.
Firewing1

leigh123linux 9th July 2008 01:32 AM

Quote:

Originally Posted by Firewing1
Unfortunately your card is considered a legacy GPU so you have to use the 96xx driver - See here for more information. Before you install the 96xx driver though you'll have to remove the "regular" nvidia one since they're incompatible:
Code:

su -
rpm -e --allmatches xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs kmod-nvidia

There's just one package that I can't remove unless I know more information, to save time this script will auto-remove it:
Code:

rpm -qa --qf '%{NAME}\n' | grep ^kmod-nvidia | while read line;do rpm -e "$line";done
Now you're ready to install the 96xx driver.
Firewing1


What is the point of installing the 96xx driver in F9 ? as it doesn't work with the F9 xorg server !

Firewing1 9th July 2008 03:01 AM

Shoot, I had forgotten about that...

You'll also have to downgrade X - Leigh has a guide for doing this with fglrx / the ATI drivers, but if you skip the ATI part it will work fine for nVidia too.
Firewing1

Artic 9th July 2008 02:38 PM

Thanks for the help. Right now I'm not at home, but I'll try it later.

Thanks a lot

Artic 10th July 2008 12:57 AM

Hi. sorry to bother again.

I followed Leigh's guide to downgrade X and right now im at the part where it says to install the driver.
I have to install the 96xx driver right?

When i type this
Quote:

yum install kmod-nvidia-96xx xorg-x11-drv-nvidia-96xx
I get this message:

Quote:

No package kmod-nvidia-96xx available.
No package xorg-x11-drv-nvidia-96xx available.
Nothing to do
I followed every step including the 2 ones Firewing1 said.

If you could help me i would be very gratefull

Thanks

Hlingler 10th July 2008 02:02 AM

Hello:

Yes, you still need the legacy 96xx NVidia driver.

Please post:
> Results of: yum repolist
> Contents of file (or attach copy to post): /etc/yum.repos.d/livna.repo

V

Firewing1 10th July 2008 05:42 AM

Because the driver isn't ready to work out-of-the-box with Fedora 9 yet it's kept out of the main Livna repository - You'll need to enable livna-testing like this:
Code:

yum --enablerepo=livna-testing install kmod-nvidia-96xx
Note that if you switch kernels a lot, you may be interested in akmod-nvidia-96xx. It's identical to kmod-nvidia-96xx, however it also installs the development tools required to build a new kmod. When a kernel is run that you don't have a kmod for, the akmod system generates and installs a new corresponding kmod-nvidia-96xx package. The kmod and akmod packages are compatible, so you can install them together at once like this:
Code:

yum --enablerepo=livna-testing install kmod-nvidia-96xx akmod-nvidia-96xx
Firewing1

Artic 10th July 2008 04:47 PM

Thanks for both answers. I'll try later when i get home.

skurdekar 10th July 2008 08:31 PM

Hi,
I am in the same boat (using an even older Mx 200 card). In addition I am trying to use dual monitors (my second card is an onboard intel card) I am running into issues after I installed 96xx rpms from atrpms. I get errors saying that DRI cannot be started and glx cannot be enabled because of version problems between my driver and the kernel. I will try to install the way it is suggested in this thread and repost if I have issues.

thanks

JohnVV 10th July 2008 09:09 PM

hi skurdekar you are using atrpms and not lvina
for fedora 8
http://www.mjmwired.net/resources/mj...ra-f8.html#yum
http://www.mjmwired.net/resources/mj...f8.html#nvidia
fedora 9 --unsupported for Mx 200 card

Artic 10th July 2008 09:13 PM

Quote:

[root@localhost ~]# yum repolist
Loaded plugins: priorities, refresh-packagekit
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated enabled
fedora Fedora 9 - i386 enabled
fedora8-main Fedora 8 - i386 enabled
fedora8-updates Fedora 8 - i386 - Updates enabled
livna Livna for Fedora Core 9 - i386 - Base enabled
updates Fedora 9 - i386 - Updates enabled
Quote:

[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/
failovermethod=priority
#mirrorlist=http://rpm.livna.org/mirrorlist-7
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

[livna-debuginfo]
name=Livna for Fedora Core $releasever - $basearch - Debug
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/debug/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/debug/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/debug/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/debug/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/debug/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/debug/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1

[livna-source]
name=Livna for Fedora Core $releasever - $basearch - Source
baseurl=
http://rpm.livna.org/fedora/$releasever/SRPMS/
http://livna.cat.pdx.edu/fedora/$releasever/SRPMS/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/SRPMS/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/SRPMS/
http://mirror.atrpms.net/livna/fedora/$releasever/SRPMS/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/SRPMS/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1
Firewing1 I used the first command of your last post here and then i tried to install again and still says:
No package kmod-nvidia-96xx available.
No package xorg-x11-drv-nvidia-96xx available.
Nothing to do

Thanks for your help

Artic

skurdekar 10th July 2008 09:14 PM

I get the following error.
Loading /usr/lib/xorg/modules/drivers//nvidia-96.43.05_drv.so
dlopen: /usr/lib/xorg/modules/drivers//nvidia-96.43.05_drv.so: undefined symbol: AllocateScreenPrivateIndex
(EE) Failed to load /usr/lib/xorg/modules/drivers//nvidia-96.43.05_drv.so
(II) UnloadModule: "nvidia-96.43.05"
(EE) Failed to load module "nvidia-96.43.05" (loader failed, 7)

I guess this is just not supported yet?

JohnVV 10th July 2008 11:25 PM

hi Artic first seeing as the legacy nvidia drivers ARE not supported in 9 they will NOT be in the livna 9 repo use the fedora 8 livna repo for the driver
-----
and skurdekar did you remove the old WRONG version driver first
depending on what it was ???( WHAT was it from atrpms that you installed )
you may NEED to remove it first
http://www.mjmwired.net/resources/mj...f8.html#nvidia
Quote:

I guess this is just not supported yet?
your old card is supported just fine in fedora 8

Artic 10th July 2008 11:50 PM

Hi JohnVV thanks for your help.

May i ask you to (if you can, of course) write how do I do that?
I'm still new to linux. Started about 2 weeks ago.

Thanks. Artic


All times are GMT +1. The time now is 04:20 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.