Fedora Linux Support Community & Resources Center
  #1  
Old 18th April 2006, 01:09 AM
cruiseoveride Offline
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 644
Question Monodevelop

Does anyone have the time to eplain how to get monodevelop running on Fedora, i got the rpm from monodevelop website
Code:
 monodevelop-0.10-0.novell.noarch.rpm 
 rpm -Uvh monodevelop-0.10-0.novell.noarch.rpm
error: Failed dependencies:
        ikvm is needed by monodevelop-0.10-0.novell.noarch
        mono(Boo.Lang) = 1.0.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(Boo.Lang.CodeDom) = 1.0.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(Boo.Lang.Compiler) = 1.0.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(Boo.Lang.Interpreter) = 1.0.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(Boo.Lang.Parser) = 1.0.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(ByteFX.Data) = 0.7.6.1 is needed by monodevelop-0.10-0.novell.noarch
        mono(Mono.Data.SybaseClient) = 1.0.5000.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(Npgsql) = 1.0.5000.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(System.Data.OracleClient) = 1.0.5000.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(gconf-sharp) = 2.4.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(gdk-sharp) = 2.4.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(glade-sharp) = 2.4.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(glib-sharp) = 2.4.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(gnome-sharp) = 2.4.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(gnome-vfs-sharp) = 2.4.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(gtk-sharp) = 2.4.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(gtkhtml-sharp) = 2.4.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(gtksourceview-sharp) = 1.0.0.2 is needed by monodevelop-0.10-0.novell.noarch
        mono(monodoc) = 1.0.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(nunit.core) = 2.2.0.0 is needed by monodevelop-0.10-0.novell.noarch
        mono(pango-sharp) = 2.4.0.0 is needed by monodevelop-0.10-0.novell.noarch
But were do i get all these files to resolve the deps? Im s confused
__________________
Registered Linux User no. 335484 :cool:
An RHCE guy, and wannabe RHCA :cool:
--------------------------------------------------------
Get Counted at http://counter.li.org/
---------------------------------------------------------------------------------------------------------------------------------------------------------
AMD X3 710, ASUS M4N78-Pro, Visiontek ATi HD4870, Corsair 2GB Dual Channel Kit, 6x500Gb Western Digital Disks LVM2+RAID5
Reply With Quote
  #2  
Old 18th April 2006, 05:35 AM
Jman Offline
Registered User
 
Join Date: Mar 2004
Location: Minnesota, USA
Age: 28
Posts: 7,909
You ask your favorite Extras packager to have a look at the Fedora package. It's still a work in progress.

You can try to "yum localinstall" it but I'm doubtful that will work.
Reply With Quote
  #3  
Old 18th April 2006, 06:50 AM
cruiseoveride Offline
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 644
I didnt understand a word you said
__________________
Registered Linux User no. 335484 :cool:
An RHCE guy, and wannabe RHCA :cool:
--------------------------------------------------------
Get Counted at http://counter.li.org/
---------------------------------------------------------------------------------------------------------------------------------------------------------
AMD X3 710, ASUS M4N78-Pro, Visiontek ATi HD4870, Corsair 2GB Dual Channel Kit, 6x500Gb Western Digital Disks LVM2+RAID5
Reply With Quote
  #4  
Old 18th April 2006, 06:23 PM
dann Offline
Registered User
 
Join Date: Mar 2005
Posts: 71
I tried the localinstall method with the novell rpm on FC5 (it was under the FC4 section). There are still some missing packages out there. Until then, I'll stick with Visual Studio .NET


# yum localinstall monodevelop-0.10-0.novell.noarch.rpm
Loading "installonlyn" plugin
Setting up Local Package Process
Examining monodevelop-0.10-0.novell.noarch.rpm: monodevelop - 0.10-0.novell.noarch
Marking monodevelop-0.10-0.novell.noarch.rpm to be installed
Setting up repositories
livna [1/5]
livna 100% |=========================| 951 B 00:00
core [2/5]
core 100% |=========================| 1.1 kB 00:00
updates [3/5]
updates 100% |=========================| 951 B 00:00
freshrpms [4/5]
freshrpms 100% |=========================| 951 B 00:00
extras [5/5]
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package monodevelop.noarch 0:0.10-0.novell set to be updated
--> Running transaction check
--> Processing Dependency: mono(nunit.core) = 2.2.0.0 for package: monodevelop
--> Processing Dependency: mono(glib-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gdk-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gconf-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Compiler) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(gnome-vfs-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gtkhtml-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(System.Data.OracleClient) = 1.0.5000.0 for package: monodevelop
--> Processing Dependency: ikvm for package: monodevelop
--> Processing Dependency: mono(Boo.Lang) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.CodeDom) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Mono.Data.SybaseClient) = 1.0.5000.0 for package: monodevelop
--> Processing Dependency: mono(pango-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gtk-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Npgsql) = 1.0.5000.0 for package: monodevelop
--> Processing Dependency: mono(ByteFX.Data) = 0.7.6.1 for package: monodevelop
--> Processing Dependency: mono(gnome-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gecko-sharp) = 2.0.0.0 for package: monodevelop
--> Processing Dependency: mono-basic for package: monodevelop
--> Processing Dependency: mono(gtksourceview-sharp) = 1.0.0.2 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Parser) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Interpreter) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(glade-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(monodoc) = 1.0.0.0 for package: monodevelop
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for mono-nunit to pack into transaction set.
mono-nunit-1.1.13.4-2.i38 100% |=========================| 6.1 kB 00:00
---> Package mono-nunit.i386 0:1.1.13.4-2 set to be updated
---> Downloading header for ikvm to pack into transaction set.
ikvm-0.22-4.fc5.i386.rpm 100% |=========================| 4.2 kB 00:00
---> Package ikvm.i386 0:0.22-4.fc5 set to be updated
---> Downloading header for mono-basic to pack into transaction set.
mono-basic-1.1.13.4-2.i38 100% |=========================| 5.1 kB 00:00
---> Package mono-basic.i386 0:1.1.13.4-2 set to be updated
---> Downloading header for mono-data-oracle to pack into transaction set.
mono-data-oracle-1.1.13.4 100% |=========================| 5.0 kB 00:00
---> Package mono-data-oracle.i386 0:1.1.13.4-2 set to be updated
---> Downloading header for mono-data-sybase to pack into transaction set.
mono-data-sybase-1.1.13.4 100% |=========================| 5.1 kB 00:00
---> Package mono-data-sybase.i386 0:1.1.13.4-2 set to be updated
---> Downloading header for bytefx-data-mysql to pack into transaction set.
bytefx-data-mysql-1.1.13. 100% |=========================| 5.2 kB 00:00
---> Package bytefx-data-mysql.i386 0:1.1.13.4-2 set to be updated
---> Downloading header for gecko-sharp2 to pack into transaction set.
gecko-sharp2-0.11-6.i386. 100% |=========================| 4.1 kB 00:00
---> Package gecko-sharp2.i386 0:0.11-6 set to be updated
---> Downloading header for mono-data-postgresql to pack into transaction set.
mono-data-postgresql-1.1. 100% |=========================| 4.7 kB 00:00
---> Package mono-data-postgresql.i386 0:1.1.13.4-2 set to be updated
--> Running transaction check
--> Processing Dependency: mozilla for package: gecko-sharp2
--> Processing Dependency: mono(glib-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gconf-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(gdk-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(pango-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(monodoc) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Parser) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.CodeDom) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Interpreter) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(glade-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gnome-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Compiler) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(gtk-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gnome-vfs-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gtkhtml-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gtksourceview-sharp) = 1.0.0.2 for package: monodevelop
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for mozilla to pack into transaction set.
mozilla-1.7.12-5.i386.rpm 100% |=========================| 88 kB 00:00
---> Package mozilla.i386 37:1.7.12-5 set to be updated
--> Running transaction check
--> Processing Dependency: mono(glib-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gconf-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(gdk-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(pango-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(monodoc) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Parser) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.CodeDom) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Interpreter) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(glade-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gnome-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Compiler) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(gtk-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gnome-vfs-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gtkhtml-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gtksourceview-sharp) = 1.0.0.2 for package: monodevelop
--> Finished Dependency Resolution
Error: Missing Dependency: mono(glib-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gdk-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gconf-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(Boo.Lang.Compiler) = 1.0.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gnome-vfs-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gtkhtml-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(Boo.Lang) = 1.0.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(Boo.Lang.CodeDom) = 1.0.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(pango-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gtk-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gnome-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gtksourceview-sharp) = 1.0.0.2 is needed by package monodevelop
Error: Missing Dependency: mono(Boo.Lang.Parser) = 1.0.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(Boo.Lang.Interpreter) = 1.0.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(glade-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(monodoc) = 1.0.0.0 is needed by package monodevelop
Reply With Quote
  #5  
Old 18th April 2006, 06:25 PM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 23
Posts: 9,224
Is it in the Extras?
Code:
yum install monodevelop
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #6  
Old 18th April 2006, 06:42 PM
cruiseoveride Offline
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 644
nope, not in the great extras repos
Code:
[root@localhost rpms]# yum localinstall monodevelop-0.10-0.novell.noarch.rpm
Loading "installonlyn" plugin
Setting up Local Package Process
Examining monodevelop-0.10-0.novell.noarch.rpm: monodevelop - 0.10-0.novell.noarch
Marking monodevelop-0.10-0.novell.noarch.rpm to be installed
Setting up repositories
atrpms                                                               [1/14]
dries                                                                [2/14]
livna                                                                [3/14]
bmpx-development                                                     [4/14]
bmpx-source                                                          [5/14]
extras                                                               [6/14]
gst-0.10-apps                                                        [7/14]
bmpx                                                                 [8/14]
updates                                                              [9/14]
core                                                                 [10/14]
freshrpms                                                            [11/14]
gst-0.10-deps                                                        [12/14]
bmpx-debuginfo                                                       [13/14]
gst-0.10-gst                                                         [14/14]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package monodevelop.noarch 0:0.10-0.novell set to be updated
--> Running transaction check
--> Processing Dependency: mono(nunit.core) = 2.2.0.0 for package: monodevelop
--> Processing Dependency: mono(glib-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(System.Data.OracleClient) = 1.0.5000.0 for package: monodevelop
--> Processing Dependency: ikvm for package: monodevelop
--> Processing Dependency: mono(Boo.Lang) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(gdk-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(pango-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Npgsql) = 1.0.5000.0 for package: monodevelop
--> Processing Dependency: mono(Mono.Data.SybaseClient) = 1.0.5000.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Parser) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.CodeDom) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(ByteFX.Data) = 0.7.6.1 for package: monodevelop
--> Processing Dependency: mono(gconf-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Interpreter) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(glade-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gnome-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Compiler) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(gtk-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gnome-vfs-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gtkhtml-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gtksourceview-sharp) = 1.0.0.2 for package: monodevelop
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package mono-nunit.i386 0:1.1.13.4-2 set to be updated
---> Package ikvm.i386 0:0.22-4.fc5 set to be updated
---> Package mono-data-oracle.i386 0:1.1.13.4-2 set to be updated
---> Package mono-data-sybase.i386 0:1.1.13.4-2 set to be updated
---> Package bytefx-data-mysql.i386 0:1.1.13.4-2 set to be updated
---> Package mono-data-postgresql.i386 0:1.1.13.4-2 set to be updated
--> Running transaction check
--> Processing Dependency: mono(glib-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gconf-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(gdk-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(pango-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Parser) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.CodeDom) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Interpreter) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(glade-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gnome-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(Boo.Lang.Compiler) = 1.0.0.0 for package: monodevelop
--> Processing Dependency: mono(gtk-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gnome-vfs-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gtkhtml-sharp) = 2.4.0.0 for package: monodevelop
--> Processing Dependency: mono(gtksourceview-sharp) = 1.0.0.2 for package: monodevelop
--> Finished Dependency Resolution
Error: Missing Dependency: mono(glib-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(Boo.Lang) = 1.0.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gdk-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(pango-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(Boo.Lang.Parser) = 1.0.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(Boo.Lang.CodeDom) = 1.0.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gconf-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(Boo.Lang.Interpreter) = 1.0.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(glade-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gnome-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(Boo.Lang.Compiler) = 1.0.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gtk-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gnome-vfs-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gtkhtml-sharp) = 2.4.0.0 is needed by package monodevelop
Error: Missing Dependency: mono(gtksourceview-sharp) = 1.0.0.2 is needed by package monodevelop
[root@localhost rpms]#
So are u telling me no one knows how to get monodevelop working on FC5, are we expected to used gedit?
__________________
Registered Linux User no. 335484 :cool:
An RHCE guy, and wannabe RHCA :cool:
--------------------------------------------------------
Get Counted at http://counter.li.org/
---------------------------------------------------------------------------------------------------------------------------------------------------------
AMD X3 710, ASUS M4N78-Pro, Visiontek ATi HD4870, Corsair 2GB Dual Channel Kit, 6x500Gb Western Digital Disks LVM2+RAID5
Reply With Quote
  #7  
Old 19th April 2006, 05:25 AM
Jman Offline
Registered User
 
Join Date: Mar 2004
Location: Minnesota, USA
Age: 28
Posts: 7,909
We're saying there isn't a released rpm yet.

You can use any text editor you like, though granted monodevelop would be nicest for mono apps...
Reply With Quote
  #8  
Old 19th April 2006, 11:14 AM
questron Offline
Registered User
 
Join Date: Sep 2004
Location: Mayen
Age: 33
Posts: 12
I've followed the request-thread for monodevelop (https://bugzilla.redhat.com/bugzilla....cgi?id=178904 ) a while, it looks like the rpm is on its way. Be patient for a few more days, before you really start to use gedit...

Greetings,
Chris
Reply With Quote
  #9  
Old 29th April 2006, 05:33 PM
rshendershot Offline
Registered User
 
Join Date: Jun 2005
Posts: 28
mono frustration

Quote:
Originally Posted by questron
I've followed the request-thread for monodevelop (https://bugzilla.redhat.com/bugzilla....cgi?id=178904 ) a while, it looks like the rpm is on its way. Be patient for a few more days, before you really start to use gedit...
Meanwhile, you can install from the source they're working with.

http://lists.ximian.com/pipermail/mo...il/018237.html
Reply With Quote
  #10  
Old 30th April 2006, 04:31 AM
trex Offline
Registered User
 
Join Date: Apr 2006
Location: Morden, Manitoba, Canada
Age: 51
Posts: 1
Quote:
Meanwhile, you can install from the source they're working with.

http://lists.ximian.com/pipermail/m...ril/018237.html
As per your posting, I made a few small changes to the instructions and include them below:

I've taken Paul's instructions and modified them slightly as the source RPMs that he mentioned had all changed names since the time he entered his post. To be sure you have the correct versions, goto http://www.smmp.salford.ac.uk/packages before proceeding with the wget statements to make sure the files needed have not changed names again.

For me, I had to change the path to the generated RPMs to rpmbuild/RPMS/i386/* instead of what Paul indicated (I added "/RPMS" after the "rpmbuild").

Otherwise his instructions worked flawlessly, thanks muchly.

su
yum -y install fedora-rpmdevtools
exit
fedora-buildrpmtree
wget http://www.smmp.salford.ac.uk/packag...2013-4.src.rpm
wget http://www.smmp.salford.ac.uk/packag...-2.0-6.src.rpm
wget http://www.smmp.salford.ac.uk/packag...0.22-6.src.rpm
wget http://www.smmp.salford.ac.uk/packag...1.14-3.src.rpm
wget http://www.smmp.salford.ac.uk/packag...0.12-3.src.rpm
wget http://www.smmp.salford.ac.uk/packag...0.10-8.src.rpm
wget http://www.smmp.salford.ac.uk/packag...1.13-4.src.rpm
wget http://www.smmp.salford.ac.uk/packag...1.13-2.src.rpm
rpm -ihv *.src.rpm
rpmbuild -ba rpmbuild/SPECS/boo.spec
rpmbuild -ba rpmbuild/SPECS/gtksourceview-sharp.spec
su
rpm -ihv rpmbuild/RPMS/noarch/*
rpm -ihv rpmbuild/RPMS/i386/*
exit
rpmbuild -ba rpmbuild/SPECS/ikvm.spec
su
rpm -ihv rpmbuild/RPMS/i386/ikvm*
exit

(you'll need to do this after each package being built - change ikvm for
the name of the package)

rpmbuild -ba rpmbuild/SPECS/monodoc.spec
rpmbuild -ba rpmbuild/SPECS/mono-debugger.spec
rpmbuild -ba rpmbuild/SPECS/monodevelop.spec

If you want to server ASP.NET files via Apache

rpmbuild -ba rpmbuild/SPECS/xsp.spec
rpmbuild -ba rpmbuild/SPECS/mod_mono.spec

If the build process stops and says you need a particular package,

yum -y install <package-name>
Reply With Quote
  #11  
Old 30th April 2006, 04:56 AM
rshendershot Offline
Registered User
 
Join Date: Jun 2005
Posts: 28
I also had to add /RPMS to the path. The user in the rpm install defaulting to root threw me at first too. fedora-buildrpmtree will create a sandbox under your ~/ (home) so I just did this as my normal login user. For those who might not read the original posting, this is not yet working for 64 bit. It should work on X86 platforms though. Using my 2.8GHz P4 the entire thing took maybe half an hour.
Reply With Quote
  #12  
Old 2nd May 2006, 04:20 AM
msumurph Offline
Registered User
 
Join Date: Jul 2005
Posts: 18
Found this on the Mono-list but have not installed the packages yet.

http://lists.ximian.com/pipermail/mo...il/031484.html

After I try them I'll post back.
Reply With Quote
  #13  
Old 2nd May 2006, 02:12 PM
msumurph Offline
Registered User
 
Join Date: Jul 2005
Posts: 18
I have a working Monodevelop using the RPMS provided here:
http://www.all-the-johnsons.co.uk/mono/rpms.html (read this message first http://lists.ximian.com/pipermail/m...ril/031484.html).

First I installed gecko-sharp2 and mono-nunit via yum, then using rpm -Uvh I installed:

gtksourceview-sharp-2.0 (apparently needs --force also)
monodoc
monodevelop

This monodoc package does not appear to provide the mono documentation, but the IDE is working.
Reply With Quote
  #14  
Old 23rd May 2006, 12:18 PM
Rtsbasic Offline
Registered User
 
Join Date: May 2006
Posts: 13
I refer you to the following quote (post 13). Following these instructions I now have a fully functional Monodevelop installed and working

Quote:
Originally Posted by msumurph
I have a working Monodevelop using the RPMS provided here:
http://www.all-the-johnsons.co.uk/mono/rpms.html (read this message first http://lists.ximian.com/pipermail/m...ril/031484.html).

First I installed gecko-sharp2 and mono-nunit via yum, then using rpm -Uvh I installed:

gtksourceview-sharp-2.0 (apparently needs --force also)
monodoc
monodevelop

This monodoc package does not appear to provide the mono documentation, but the IDE is working.
Reply With Quote
  #15  
Old 2nd May 2006, 05:56 PM
msumurph Offline
Registered User
 
Join Date: Jul 2005
Posts: 18
I was mistaken about the Monodoc browser. It is now built into Monodevelop. Nice feature!
Reply With Quote
Reply

Tags
monodevelop

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MonoDevelop ShivaS Alpha - Beta (Fedora 9 Only) 4 15th June 2008 01:44 PM
MonoDevelop HayZam Using Fedora 2 19th September 2007 06:38 PM
Monodevelop jjesurun Using Fedora 4 4th September 2007 08:40 PM
help monodevelop ronin1982 Programming & Packaging 16 29th November 2006 03:44 PM
Monodevelop rcassick Using Fedora 7 29th July 2006 10:57 PM


Current GMT-time: 21:39 (Thursday, 31-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat