Fedora Linux Support Community & Resources Center
  #1  
Old 28th November 2007, 03:24 PM
Alex Lang Offline
Registered User
 
Join Date: Sep 2005
Posts: 19
Fedora 8, Pulse Audio, 2 Audio Cards

I have a fresh install of Fedora 8. Audio was giving me fits. I've narrow down what I think the issue is and am requesting suggestions on how to resolve.

I have an AMD64 system with motherboard audio that I don't use. It is disabled in the BIOS. I have a SB Live! PCI card that is my primary audio. I have two issues:

1. PulseAudio insists on making the VIA_82XX device (the onboard device) the default audio device. I'll go into the Pulse Mixer and change the default but it doesn't persist across logins. Is there a way to make Pulse remember my choices and configurations from previous sessions.

2. It seems real odd to me that Pulse is using the via-82xx.so driver even when the motherboard audio is disabled. Since I'm just using the kernels from the distro, I finally just went in a deleted the via-82xx.so driver from /lib/modules, but that seems an unreasonable solution. It would seem to me that Pulse and the via-82xx driver should honor the fact that I've disabled the onboard audio from the bios and not even show it in the Pulse choices.

Note that I have gone into Admininistration->Sound Card Detection and made the SB Live! the primary audio card. Pulse still insisted that the VIA onboard audio was the default audio until I deleted the drivers.

Thanks,
Alex
Reply With Quote
  #2  
Old 2nd December 2007, 06:20 AM
sloik Offline
Registered User
 
Join Date: Dec 2007
Posts: 3
I'm having the same issue.

If anyone has a solution, please let me know. I've tried editing the pulseaudio file manually to no avail. I'm tired of my audio defaulting to my speakers instead of my headphones!
Reply With Quote
  #3  
Old 2nd December 2007, 06:34 AM
FriedChips Offline
Registered User
 
Join Date: Jul 2007
Location: Indiana USA
Posts: 1,715
try:
Code:
su
echo "blacklist via-82xx" >> /etc/modprobe.d/blacklist
of course that assumes that you have the same onboard as the OP

Hope that helps
__________________
The answer to all of lifes questions are buried somewhere in the Google search engine.

Code:
[Stephen@localhost ~]$ whatis this?
this?: nothing appropriate
Reply With Quote
  #4  
Old 2nd December 2007, 09:32 PM
sloik Offline
Registered User
 
Join Date: Dec 2007
Posts: 3
Well I still want the onboard audio enabled, I just don't want it set as the default.

I have my speakers hooked up to the onboard audio device, and my headphones hooked up to the Sound Blaster Audigy 2. I'd like my headphones to be set as the default device so I don't have error sounds blaring from my speakers at 12:00 AM :P

Thanks!

Edit:
This seems to be what I need. Has this been implemented yet? How can I get this working?

Last edited by sloik; 2nd December 2007 at 09:34 PM.
Reply With Quote
  #5  
Old 22nd January 2008, 07:38 AM
alarm9k Offline
Registered User
 
Join Date: Jan 2008
Location: Russia
Posts: 109
I don't know how to make it default (I also have 2 sound cards) but I do know how to make it remember it's settings between reboots/logins. Pulseaudio daemon won't save it's settings to ~/.pulse if just killed when exiting your login session. It will only save if you kill the daemon with pulseaudio -k command. So I had to add a 1-line script (/usr/bin/pulseaudio -k) to /etc/kde/shutdown directory. Now it works.

p.s. ok, not exactly 1-line:
#!/bin/sh
/usr/bin/pulseaudio -k

Last edited by alarm9k; 22nd January 2008 at 07:43 AM.
Reply With Quote
  #6  
Old 24th January 2008, 09:05 PM
sloik Offline
Registered User
 
Join Date: Dec 2007
Posts: 3
Thumbs up

Quote:
Originally Posted by alarm9k
I don't know how to make it default (I also have 2 sound cards) but I do know how to make it remember it's settings between reboots/logins....
This is exactly what I was looking for, thanks!
Reply With Quote
Reply

Tags
audio, cards, fedora, pulse

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multi User Sound Fedora 10 w/Pulse Audio? ottoguy Using Fedora 4 13th November 2009 09:13 AM
fedora 8 & pulse audio - nonroot users have no sound high Using Fedora 135 9th April 2009 02:25 AM
Pulse Audio relayer Installation, Upgrades and Live Media 0 13th March 2009 08:40 PM
F10 Bluetooth Audio + Pulse == pulse crashes. fwelland Hardware & Laptops 2 7th February 2009 01:07 PM
Pulse Audio Problems indelible Hardware & Laptops 1 16th December 2008 01:54 AM


Current GMT-time: 15:28 (Friday, 24-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Bellevue - Shanhetun - Sosnogorsk Instagram Photos