Fedora Linux Support Community & Resources Center
  #1  
Old 12th March 2008, 06:30 PM
mistergoodbytes Offline
Registered User
 
Join Date: Aug 2007
Posts: 42
Disabling auto-updates

I recently had to reboot and the autoupdater loaded at startup. My bad, I permitted the system to install its updates. I'll spend several months now learning how to clean up and cleaning up damage from this last batch of updates. Like I said, my fault, I never allowed Microsoft to autoupdate a system, why would I let Fedora?

My terribly important question first of all is containment. How do I permanently disable this package updater? In a word I want it GONE. No sense cleaning up if the next time the system crashes I have to do this again.

Second, can I roll back a version of a program? Pigdin now times out of some logins and will not log me into others. I know Pigdin is a package, so I'm guessing I can go get an older version and reinstall from scratch. Any idea where to find one?

Third how do I get rid of dead links to media? FC8 has never recognized my floppy drive properly but it now installed a dead link to the floppy on my desktop and I can't delete it.

How do I roll back screen savers? I once spent a couple of hours renaming the screen savers I did not like so the they wouldn't be recognized by the random screen saver module. Now the ones I wanted are gone and a random selection of system locking open GL ones replaced them.

How do you get SELinux not rolled anything, but as GONE as I want the autoupdater to be?

But again, my critical first step is making sure this does not happen again. How do I kill any and all update features?

Last edited by mistergoodbytes; 12th March 2008 at 06:38 PM.
Reply With Quote
  #2  
Old 12th March 2008, 06:48 PM
jrummy27 Offline
Registered User
 
Join Date: May 2007
Location: Raleigh, NC
Age: 30
Posts: 304
1) There should not be any autoupdates by default. The little icon up by the clock controlled by the yum-updatesd service will notify you when packages are available, but should not install anything unless you tell it to. If you want to disable this notification, you can do
Code:
# service yum-updatesd stop
# chkconfig yum-updatesd off
You could also go into /etc/yum.repos.d/* and set ENABLED=0 in all the config files, as well as all the repos in /etc/yum.conf. This will prevent you from being able to use yum for anything including installing new packages, so not recommended

2) Rolling back packages can be difficult. RPM and yum will complain if you try to install a version older than your current one. Typically the best way is to remove the currently installed version (yum remove <packagename>) and manually download the version you want and install it. However if other packages depend on the one you are removing, you would have to remove them as well. Then you'd have to go back and download and install the version of each of those packages that corresponds to the version of the package you are rolling back. If you haven't done much configuration of your system, you may want to consider just reinstalling and leaving it at the version you want.

3) You can probably get rid of the floppy mount in the Removable Media preferences. You can set what you want it to automount or skip. Skipping your floppy (probably /dev/fd0) should prevent this from happening.

4) No idea with the screensavers, why not just take it off random and pick the one you want?

Hope this all helps.
__________________
"Ooh, they have the internet on computers now" -Homer
Reply With Quote
  #3  
Old 12th March 2008, 06:55 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,141
Turn it off in System > Preferences > Personal > Sessions. Of course, it's not actually installing anything until you authorize it, but I still prefer 'yum update' or checking with yumex and selecting the packages involved.

'system-config-selinux' can turn off or change the status of SELinux.

If/when you want to rollback to a previous state, perform an rpm update with the --rollback option followed by a date/time specification. Some examples: rpm -Uhv --rollback '9:00 am', rpm -Uhv --rollback '4 hours ago', rpm -Uhv --rollback 'december 25'.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #4  
Old 12th March 2008, 07:10 PM
mistergoodbytes Offline
Registered User
 
Join Date: Aug 2007
Posts: 42
Is yum responsible for that update? Thanks, that should be enough info to make the bugger go away.

SELinux appears successfully disabled, but I'd still like it gone if possible.

OK to disabling the floppy entirely. Since it can't actually be accessed anyway, I can see taking it out of the hierarchy. I did manage to make it go away from the taskbar, but there's still a dead link on the desktop that wont go away.

As for the screen savers, the ones I used are gone. The entire list has changed.

Last edited by mistergoodbytes; 12th March 2008 at 07:21 PM.
Reply With Quote
  #5  
Old 12th March 2008, 06:57 PM
jrummy27 Offline
Registered User
 
Join Date: May 2007
Location: Raleigh, NC
Age: 30
Posts: 304
Quote:
If/when you want to rollback to a previous state, perform an rpm update with the --rollback option followed by a date/time specification. Some examples: rpm -Uhv --rollback '9:00 am', rpm -Uhv --rollback '4 hours ago', rpm -Uhv --rollback 'december 25'.
Wow I didn't realize you could do that. Pretty cool
__________________
"Ooh, they have the internet on computers now" -Homer
Reply With Quote
Reply

Tags
autoupdates, disabling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling auto log-off taterman Using Fedora 4 19th March 2007 05:03 AM
Disabling FC6 Auto Update James Jones Using Fedora 3 20th November 2006 02:46 AM


Current GMT-time: 22:09 (Sunday, 21-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat