Fedora Linux Support Community & Resources Center
  #1  
Old 21st March 2008, 04:03 PM
ivancat Offline
Registered User
 
Join Date: Dec 2007
Posts: 596
Question Compiz-fusion problem (Solved :) )

I have installed compiz fusion and ccsm.
So, I start ccsm (System>Prefs>Look'n'Feel>CompizConfig Settings Manager) and choose plugins I like (like motion blur for windows). Then I click 'Close' and nothing really happens. If I do not enable desktop effects the system runs just like there is no compiz-fusion if I enable desktop effects I get those default ones that come with gnome desktop (minimize anumation, some shadows and stuff like wobble for windows)

So, how can I make compiz-fusion with all its plugins work?
__________________
Ivan Cat (registered linux user #471784)
Linux Projects: constat | nconv
Fedora-related: Message In the Bottle

Last edited by ivancat; 23rd March 2008 at 01:03 PM.
Reply With Quote
  #2  
Old 21st March 2008, 05:13 PM
creeping death Offline
Registered User
 
Join Date: Feb 2008
Posts: 656
u have to goto to Applications>System tools and click on compiz fusion icon first.
when u go and click on compiz fusion icon in Applications>System tools of ur gnome bar a compiz fusion icon should appear beside the date and time.
right click compiz fusion and select window manager and window decorator as compiz and emerald...then click on reload window manager....if that does'nt work...try a reboot...
Reply With Quote
  #3  
Old 21st March 2008, 06:42 PM
ivancat Offline
Registered User
 
Join Date: Dec 2007
Posts: 596
unfortunately there is no compiz-fusion icon in my Applications>System

currently I have installed:
Code:
[cat@localhost ~]$ yum list compiz-fusion*
Installed Packages
compiz-fusion.i386                       0.6.0-12.fc8           installed       
compiz-fusion-extras.i386                0.6.0-1.fc8            installed       
compiz-fusion-extras-gnome.i386          0.6.0-1.fc8            installed       
compiz-fusion-gnome.i386                 0.6.0-12.fc8           installed   

[cat@localhost ~]$ yum list ccsm
Installed Packages
ccsm.noarch                              0.6.0-4.fc8            installed 

[cat@localhost bin]$ yum list emerald*
Installed Packages
emerald.i386                             0.5.2-2.fc8            installed  (+ themes here)
do I need anything else? and how do I finally start it
__________________
Ivan Cat (registered linux user #471784)
Linux Projects: constat | nconv
Fedora-related: Message In the Bottle
Reply With Quote
  #4  
Old 21st March 2008, 07:36 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,294
Quote:
Originally Posted by ivancat
I have installed compiz fusion and ccsm.
So, I start ccsm (System>Prefs>Look'n'Feel>CompizConfig Settings Manager) and choose plugins I like (like motion blur for windows). Then I click 'Close' and nothing really happens. If I do not enable desktop effects the system runs just like there is no compiz-fusion if I enable desktop effects I get those default ones that come with gnome desktop (minimize anumation, some shadows and stuff like wobble for windows)

So, how can I make compiz-fusion with all its plugins work?
Quote:
Originally Posted by ivancat
do I need anything else? and how do I finally start it
Yes: install the proprietary video drivers - you need DRI for Compiz.

V

EDIT: See this thread: http://forums.fedoraforum.org/showthread.php?t=173317
Quote:
Quote:
Compiz requires direct rendering to work

so don't bother posting saying compiz doesn't work unless you have direct rendering working .

To test

Code:

glxinfo |grep direct



The result should be

Code:

[root@localhost leigh]# glxinfo |grep direct direct rendering: Yes [root@localhost leigh]#

Last edited by Hlingler; 21st March 2008 at 07:40 PM.
Reply With Quote
  #5  
Old 21st March 2008, 07:56 PM
ivancat Offline
Registered User
 
Join Date: Dec 2007
Posts: 596
Hlingler, thanks for help. I have direct rendering

Also, I've finally made it work (all that's needed was to install fusion-icon and run it)

So looks like the problem is solved
__________________
Ivan Cat (registered linux user #471784)
Linux Projects: constat | nconv
Fedora-related: Message In the Bottle
Reply With Quote
  #6  
Old 22nd March 2008, 07:03 AM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,294
@ivancat:

Glad you got it all working. I naturally assumed from your last post on the other thread that you were using the 2D generic video drivers.

V
Reply With Quote
  #7  
Old 22nd March 2008, 11:39 AM
ivancat Offline
Registered User
 
Join Date: Dec 2007
Posts: 596
No, the drivers support 3d and composite graphics

One last thing, how do I make fusion-icon start up automatically when I log in?

edit: I've tried the way specified in the fedorafaq.org (Logout with "Save running applications" ticked but it does not work)
__________________
Ivan Cat (registered linux user #471784)
Linux Projects: constat | nconv
Fedora-related: Message In the Bottle

Last edited by ivancat; 22nd March 2008 at 12:47 PM.
Reply With Quote
  #8  
Old 22nd March 2008, 05:27 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,294
Quote:
Originally Posted by ivancat
No, the drivers support 3d and composite graphics

One last thing, how do I make fusion-icon start up automatically when I log in?

edit: I've tried the way specified in the fedorafaq.org (Logout with "Save running applications" ticked but it does not work)
Try: create a fusion-icon.desktop link in folder ~/.config/autostart:
Code:
mkdir ~/.config/autostart      <<== only if it does not already exist
gedit ~/.config/autostart/fusion-icon.desktop
Code:
[Desktop Entry]
Name=fusion-icon
Encoding=UTF-8
Version=1.0
Exec=fusion-icon
X-GNOME-Autostart-enabled=true
EDIT: Forgot to mention: when done, make the link executable: chmod +x ~/.config/autostart/fusion-icon.desktop.

Works for me....

V

P.S. If you want the latest compiz-fusion stuff, see that thread linked above.

Last edited by Hlingler; 23rd March 2008 at 04:37 AM.
Reply With Quote
  #9  
Old 23rd March 2008, 01:02 PM
ivancat Offline
Registered User
 
Join Date: Dec 2007
Posts: 596
Thanks, I've found another way to start up on log in

System > Preferences > Personal > Sessions > Add

Though your thingy works OK as well.

Thanks again and happy easter
__________________
Ivan Cat (registered linux user #471784)
Linux Projects: constat | nconv
Fedora-related: Message In the Bottle
Reply With Quote
Reply

Tags
compizfusion, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
compiz fusion problem taitos7 Using Fedora 13 30th November 2009 03:30 PM
Problem with installing compiz-fusion in kde cola Using Fedora 1 15th April 2009 08:41 PM
problem installing compiz-fusion suyashkmr Using Fedora 3 21st February 2009 04:43 PM
XFCE4 - compiz-fusion problem codenyx Installation, Upgrades and Live Media 0 18th September 2008 08:19 PM
Problem with ATI 1650 Pro + Compiz Fusion R3verseEngin33r Hardware & Laptops 2 23rd November 2007 04:19 PM


Current GMT-time: 15:52 (Tuesday, 30-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat