Fedora Linux Support Community & Resources Center
  #1  
Old 2nd June 2008, 11:53 AM
HuntrRose Offline
Registered User
 
Join Date: Jun 2008
Location: Bergen, Norway
Age: 34
Posts: 16
Acer Aspire 5720z and Fedora 9 wlan trouble

I have trouble getting the wlan up and running.
I find the card detected by lspci as atheros at245* (or something like that.. will post details from home later).
The specs from the vendor says it's an Intel 3945 a/b/g card.
F9 does not get any device for it by it self, only managed to get a device with compat-wireless drivers, and then only saw it in ifconfig and iwconfig, didn't get it to work though.

I'll post the details later and if there is any info needed by anyone that might be able to help, let me know what you need and I'll post it.
Reply With Quote
  #2  
Old 2nd June 2008, 05:45 PM
HuntrRose Offline
Registered User
 
Join Date: Jun 2008
Location: Bergen, Norway
Age: 34
Posts: 16
okay.. Filling out some info, and hoping someone comes up with some good ideas.

dmesg | grep ath result:
Quote:
ath5k_pci 0000:06:00.0: registered as 'phy0'
ath5k phy0: Device not yet supported.
device-mapper: multipath: version 1.0.5 loaded
lsmod | grep ath result:
Quote:
dm_multipath 18056 0
ath5k 105736 0
mac80211 185184 1 ath5k
cfg80211 24712 2 ath5k,mac80211
dm_mod 48980 9 dm_multipath,dm_snapshot,dm_zero,dm_mirror
and finally lspci | grep Atheros result:
Quote:
06:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
this last one confuses me abit, as the site I bought it from lists the wlan as Atheros AR5007EG WLAN 802.11a/b/g.
Then again, that is possibly me lacking the proper overview of wireless chipset names and such...

Anyway, I'd be gratefull for any tips you can send my way.

P.S. This is as of right now a clean fully updated install. I have tried Madwifi, compat-wireless, iwlwifi and some kernels linked to from the compat-wireless site. figured it was a good idea to clean up my previous attempts before going at it fresh.

Thanks in advance
Reply With Quote
  #3  
Old 3rd June 2008, 08:23 AM
HuntrRose Offline
Registered User
 
Join Date: Jun 2008
Location: Bergen, Norway
Age: 34
Posts: 16
Just read this: http://forums.fedoraforum.org/showthread.php?t=190615

wonder if that might be the case for me as well...

Tested ndiswrapper last night, managed my first total system freeze under linux *grins*

Think I'll do a clean install again after work to clean up the mess I made (can't be arsed cleaning it manually)
Reply With Quote
  #4  
Old 3rd June 2008, 01:40 PM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
If it's the AR5007EG you might try http://home.nyc.rr.com/computertaiju...less.html#5007
(for 32 bit systems)
Reply With Quote
  #5  
Old 4th June 2008, 07:11 AM
HuntrRose Offline
Registered User
 
Join Date: Jun 2008
Location: Bergen, Norway
Age: 34
Posts: 16
Got it working last night.

This is how I ended up doing it after some extensive research:
Quote:
$ svn co http://svn.madwifi.org/madwifi/trunk madwifi
$ wget http://people.freebsd.org/~sam/ath_hal-20080528.tgz
$ cd madwifi
$ mv hal hal.old
$ mkdir hal
$ tar xvf ../ath_hal-20080528.tgz
$ make install
$ depmod -ae
$ modprobe ath_pci
I did experience some trouble, but as I hadn't cleaned up my earlier attempts, that might have been the cause. It came up cleanly when I did a clean install. Hopefully it stays up and stable.

Anyway. Hope this helps others as well

Last edited by HuntrRose; 4th June 2008 at 07:12 AM. Reason: some tag trouble
Reply With Quote
  #6  
Old 6th June 2008, 04:58 PM
HuntrRose Offline
Registered User
 
Join Date: Jun 2008
Location: Bergen, Norway
Age: 34
Posts: 16
Ok, given the setup some testing, including heavy traffic and streaming. Only trouble comes with hibernation and sleeping.
So I'll deem it stable.
Reply With Quote
Reply

Tags
5720z, acer, aspire, fedora, trouble, wlan

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble installing Fedora 11 x86-64 on a Acer Aspire M1201. mysteron Installation, Upgrades and Live Media 4 12th June 2009 07:50 AM
Atheros AR5007EG on Acer Aspire 5720Z .. NOT WORKING :-( cdac1000 Servers & Networking 4 4th June 2008 07:17 AM
Problems with setting up WLAN on Acer Aspire 5024 zonkers Hardware & Laptops 7 22nd March 2007 03:53 PM
wlan trouble on acer aspire 3000 d97jerry Servers & Networking 3 20th September 2005 09:57 AM


Current GMT-time: 17:19 (Saturday, 23-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat