Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #1  
Old 7th December 2008, 10:25 PM
Silpheed2K Offline
Registered User
 
Join Date: Aug 2008
Posts: 585
Exclamation How to: Fix PulseAudio and primary audio issues with Fedora 10 (F10)

Well it's time for my contribution to this community with the new release of Fedora 10.. lots of people are having issues with the audio.

So lets start:

The quick and easy tutorial
... well... at least it worked for me...
(how easy may vary depending on user experience)

open a terminal and run the following command
Code:
su -c 'gedit /etc/pulse/default.pa'
and replace the line:
Quote:
load-module module-hal-detect
with:
Quote:
load-module module-hal-detect tsched=0
(of course save your changes and then move on to the next step)


Next run the following command:
Code:
su -c 'yum install pavucontrol pavumeter paman padevchooser paprefs alsa-plugins-pulseaudio gstreamer-plugins-pulse pulseaudio pulseaudio-core-libs pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-libs-zeroconf pulseaudio-module-gconf pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils xine-lib-pulseaudio xmms-pulse'
DO NOT RUN THE FOLLOWING COMMAND AS ROOT
next, Run this command
Code:
pulseaudio -k
and you're done... test out the audio and see how it works.

edit:
Also forgot to mention, be sure to have your audio settings under System > Preferences > Hardware > Sound
for "Sound Playback" (not sound capture) set to PulseAudio Sound Server.







Side Note:
If you're experiencing random lock ups and you're not doing anything sound related.. multiple things can cause your desktop to freeze up.. such as stressing your network or having your firewall configured improperly, so it may not be pulseaudio at all.
edit 2:
Important Update:
Some users have been complaining about a glitch in the software that dumps a message into their log files and causes random lock-ups.
If you experience random lock-ups or a message being dumped into certain log files, remove the tsched=0 term to enable timer-based scheduling, which makes the audio less CPU intensive;
the line should look like this afterwards:
Quote:
load-module module-hal-detect
However you may experience pop and stuttering audio glitches if you remove it. If in some rare case you do, put it back.
In other words, it's safe to remove tsched=0; everything else in the tutorial stays.
run the command
Code:
$ pulseaudio -k
after you get done editing the file (/etc/pulse/default.pa) then test the audio. (to edit just run the first command of the tutorial)

Last edited by Silpheed2K; 28th July 2009 at 10:41 PM.
  #2  
Old 7th December 2008, 10:40 PM
PatMcLJr Offline
Registered User
 
Join Date: Apr 2005
Location: earth
Posts: 1,183
Hey Slipheed2K
That seemed to cure the poping I was getting in dosbox!
Thanks!
Pat Jr.
__________________
x--x--x
http://www.gnu.org/philosophy/free-sw.html
Freedom is never Free.
Pat Jr.
  #3  
Old 7th December 2008, 10:44 PM
scottro Offline
Retired Community Manager -- Banned from Texas by popular demand.
 
Join Date: Sep 2007
Location: NYC
Posts: 8,142
I'll add a link to the 5 common problems as it's worked for at least one person.
  #4  
Old 8th December 2008, 01:33 PM
kovshenin Offline
Registered User
 
Join Date: Dec 2008
Location: Moscow, Russia
Posts: 40
Listen, this may sound stupid, but is this the case of audio multiple streaming? If I got my skype running and launch lastfm I get a Pulse audio error, and firefox won't give me sound unless skype and lastfm are closed.

Sorry. Thanks.
K.
  #5  
Old 8th December 2008, 01:51 PM
Silpheed2K Offline
Registered User
 
Join Date: Aug 2008
Posts: 585
Quote:
Originally Posted by kovshenin View Post
Listen, this may sound stupid, but is this the case of audio multiple streaming? If I got my skype running and launch lastfm I get a Pulse audio error, and firefox won't give me sound unless skype and lastfm are closed.

Sorry. Thanks.
K.
It isnt one specific case, as the title suggests it addresses mostly all of the audio issues, so follow the tutorial and you should be fine. (should fix your problem)
  #6  
Old 8th December 2008, 02:52 PM
kovshenin Offline
Registered User
 
Join Date: Dec 2008
Location: Moscow, Russia
Posts: 40
Quote:
Originally Posted by Silpheed2K View Post
It isnt one specific case, as the title suggests it addresses mostly all of the audio issues, so follow the tutorial and you should be fine. (should fix your problem)
Yes, that seems to have solved the problem. Thank you very much!
__________________
Running F11 on HP Pavilion dv2000
My Web Developer Blog
  #7  
Old 8th December 2008, 07:50 PM
ogetbilo Offline
RPMFusion Dev
 
Join Date: May 2004
Location: PA
Age: 35
Posts: 466
Excellent work!

Is this "pulseaudio -k" command permanent?
__________________
oget, the "Pulse against"

Thnigs that rule: Angelina, TKT, Linux, Supergravity, Alcohol...
  #8  
Old 8th December 2008, 10:44 PM
Silpheed2K Offline
Registered User
 
Join Date: Aug 2008
Posts: 585
Quote:
Originally Posted by ogetbilo View Post
Excellent work!

Is this "pulseaudio -k" command permanent?
you only need to use that command once... "pulseaudio -k" kills the current pulseaudio daemon and restarts it.
  #9  
Old 9th December 2008, 05:42 AM
agerardi Offline
Registered User
 
Join Date: Jun 2004
Location: Florida Panhandle
Posts: 17
Thumbs up

Thank you. Pulseaudio now working great in Gnome Fedora 10.
  #10  
Old 9th December 2008, 06:06 AM
NoEffex Offline
Registered User
 
Join Date: Oct 2008
Posts: 299
Sweet, works great now in all the various sounds apps.
__________________
Intel Core 2 Quad Q8400 CPU (2.66 GHz)
3gb RAM
500GB HD
Debian Lenny x86_64 & Windows 7 Ultimate x64
NVIDIA GeForce 9800 GTX+ Superclocked - Fattypack

Second(Server) PC:
512mb RAM
80gb TiVO HD(Lololol, took it from TiVO, old one broke)
PC-BSD 7.1.1 x86
Ossom router decked out with DD-WRT as a bridge providing net
Sign the Online Petition to bring Crysis 2 to Linux/Mac!
  #11  
Old 10th December 2008, 02:05 AM
bcearl Offline
Registered User
 
Join Date: Dec 2008
Posts: 2
This solution did not work for me...

I have an Audigy 2 ZS sound card like many others and it "just worked" in past releases of Fedora. I've tried everything suggested in the thread below and the only option that works is to install fc9 pulseaudio packages.

http://forums.fedoraforum.org/showthread.php?t=203708

Unfortunately, using the fc9 packages breaks stuff like the GNOME sounds, etc.

I've found that the only thing affected by fc10 pulseaudio is video playback (i.e. your weekly tv show download). Music is hardly affected (small pops once in a while), and stuff like GNOME sounds and flash sounds are fine.

Adding the tsched=0 option made my audio problems worse (GNOME would freeze when I'd try to watch a tv show). It's too bad because this option should theoretically make pulseaudio operate as it does in Fedora 9 (which worked).

Has anyone out there verified this solution works for an Audigy 2 ZS?

I'm thinking it might take until Fedora 11 before this is all straightened out... but I'm hoping not! Thanks!
  #12  
Old 11th December 2008, 12:41 AM
pigbellamy Offline
Registered User
 
Join Date: Dec 2008
Location: Manchester, England
Age: 28
Posts: 14
Excellent! I can now watch flash videos (like the ones on YouTube) without the sound skipping horrendously Kudos to you, sir
  #13  
Old 12th December 2008, 05:38 PM
actaea Offline
Registered User
 
Join Date: May 2008
Posts: 23
When I typed in "pulseaudio -k", the computer responded


I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us privileges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
W: main.c: High-priority scheduling enabled in configuration but not allowed bypolicy.


I presume this makes no difference. Or are there some steps I should take, like adding myself to the group pulse-rt?
  #14  
Old 2nd February 2009, 07:33 PM
f!R3Bl0od Offline
Registered User
 
Join Date: Jan 2009
Posts: 1
ha!

Quote:
Originally Posted by actaea View Post
When I typed in "pulseaudio -k", the computer responded


I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us privileges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
W: main.c: High-priority scheduling enabled in configuration but not allowed bypolicy.


I presume this makes no difference. Or are there some steps I should take, like adding myself to the group pulse-rt?
It seems we've got the same problem

Though I got rid of:

"E: main.c: Failed to kill daemon: No such file or directory"

-After selecting Default Server/Sink/Source to "Default" -By going to Applications > Sound & Video > PulseAudio Device Chooser, & then going to the PulseAudio applet, clicking on "Manager...", then on the "Server Information tab; clicking on "Connect" & running "pulseaudio -k" again...

Anyway; have you figured out how to get your sound working? Have you made any progress on this? -Hell, I have no clue!

---

If anybody is willing to explain/reference what "real-time scheduling" is, how to "acquire the appropriate PolicyKit privileges", "become a member of 'pulse-rt'", "increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits..." or better yet; what's the sound-rendering process from A-Z (how it's supposed to work, what pulseuadio does, etc), please do!

---

Running up-to-date Fedora 10 on GNOME...

Gateway model 4528MX Notebook
http://support.gateway.com/s/Mobile/.../4142sp3.shtml says I have:

Sound support: PC2001 compliant AC' 97 audio

PS.- Also; System > Preferences > Hardware > Sound, under the "Devices" tab; I clicked on "Test" for "Sound playback" (Set to PulseAudio Sound Server) after following all of the directions mentioned on this topic, BUT I get the following pop-up message:

"audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect: Connection refused" -WTF?

I've searched A LOT through the forum/google; no luck.
  #15  
Old 13th December 2008, 03:13 AM
Silpheed2K Offline
Registered User
 
Join Date: Aug 2008
Posts: 585
You're fine and you dont need to do anything else.
Closed Thread

Tags
audio, issues, pulse, pulseaudio, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 11: Complete guide to fix PulseAudio and video/audio VLC Media Player issues Silpheed2K Guides & Solutions (No Questions) 203 17th June 2012 04:17 PM
Bluetooth Audio with PulseAudio jtang613 Guides & Solutions (No Questions) 25 8th December 2009 04:34 AM
No sound after Pulseaudio update in Fedora 11 with M-Audio Delta 66 nils06 Using Fedora 13 5th November 2009 10:02 PM
pulseaudio multiple audio sources M4rc0 Using Fedora 9 2nd July 2009 06:25 AM
Primary audio device mgaleano Using Fedora 2 29th June 2005 12:44 AM


Current GMT-time: 18:40 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat