Fedora Linux Support Community & Resources Center
  #1  
Old 27th December 2008, 06:48 PM
Magice Offline
Registered User
 
Join Date: Jun 2007
Posts: 24
How to disable boot splash in Fedora 10

Hello everyone!
My Fedora box is having some trouble at booting up. The booting process stops somewhere (I guess) when it is starting daemons. However, the beautiful boot splash hides what is going on. How can I disable it and see the boot messages? By the way, since I installed only Fedora on that box (no Windows or whatever), so the thing skips GRUB totally. Is there anyway to let me manually start the daemons?
Thank you!
Reply With Quote
  #2  
Old 27th December 2008, 09:56 PM
Jake Offline
Registered User
 
Join Date: Oct 2008
Location: England, Lincolnshire
Posts: 1,576
well, you could hit Esc, this takes you to verbose (What you need). or tap the upkey untill you see grub and remove quiet and rhgb from the kernel line.

Also when you see the "press "i" to enter interactive startup" press "i" and it will let you choose what to start and what not to start.
__________________
Fedora user since FC6.
Linux user since 2003.
Registered Linux ID: #456478
OS: Fedora 16 x86_64
Reply With Quote
  #3  
Old 20th May 2009, 12:28 AM
David McCracken Offline
Registered User
 
Join Date: May 2009
Location: Aptos, California
Posts: 4
Even if you have just Fedora, grub still boots the kernel. It's just that your grub.conf (in /boot/grub) contains only one OS option and a timeout of 0. But you can still stop it. Just start pressing some innocuous key like up arrow before your BIOS launches grub. Grub will respond by showing you the one OS, Fedora. At that point, press 'e' to edit. Then arrow down to highlight the "kernel /vmlinuz..." line. Press 'e' again to edit this line. The changes you make at this time are temporary. Delete rhgb and quiet at the end of this line. Append confirm to the line. Press enter then 'b'. This may be the only way to get interactive boot with Fedora 10 because it has a startup script bug.
Reply With Quote
  #4  
Old 20th May 2009, 12:37 AM
Loki1950 Offline
Registered User
 
Join Date: Feb 2005
Location: Ottawa ,Canada
Posts: 443
I have been able to get interactive boot by spamming the "i" key before udev starts.

Enjoy the Choice
__________________
Enjoy the Choice:)
Q8200/Asus P5QDLDX/2G ram/500G HD f10/Evga 9800gt 512M
XP2500 Barton/AsusA7N8X Deluxe/768M RAM/6800gt 128M WinXPpro SP3 120 Gb ntft f10 80 Gb ext3
Reply With Quote
  #5  
Old 20th May 2009, 10:42 PM
klingoncowboy4 Offline
Registered User
 
Join Date: Aug 2008
Location: Alberta
Age: 25
Posts: 29
Given your problems there should be a warning icon (a triangle with an ! in it) in the GDM before you login. Clicking on that should load up a complete record in the format you are searching for of load so you can look for [FAILED]
Reply With Quote
  #6  
Old 20th May 2009, 11:08 PM
klingoncowboy4 Offline
Registered User
 
Join Date: Aug 2008
Location: Alberta
Age: 25
Posts: 29
btw is there a way to have it so that the splash screen is always disabled or do I need to manually redo thed delete rhgb and quiet for every kernal update
Reply With Quote
  #7  
Old 20th May 2009, 11:30 PM
ozjd Online
Registered User
 
Join Date: Feb 2008
Location: Sydney Australia
Age: 59
Posts: 2,371
Quote:
Originally Posted by klingoncowboy4 View Post
btw is there a way to have it so that the splash screen is always disabled or do I need to manually redo thed delete rhgb and quiet for every kernal update
You need to make the changes David listed above in /boot/grub/grub.conf.
Reply With Quote
  #8  
Old 21st May 2009, 07:30 AM
moniker117 Offline
Registered User
 
Join Date: Dec 2007
Location: Los Angeles, CA, USA
Posts: 25
Quote:
Originally Posted by klingoncowboy4 View Post
btw is there a way to have it so that the splash screen is always disabled or do I need to manually redo thed delete rhgb and quiet for every kernal update
I have edited my /boot/grub/grub.conf file and removed the rhgb parameter from the kernel and entries made by updated kernels seem to keep rhgb out. Therefore, I don't suspect you would have to remove it everytime there's a kernel update.
Reply With Quote
Reply

Tags
boot, disable, fedora, splash

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 11 boot splash doesn't load caracuri Using Fedora 2 24th June 2009 05:59 PM
How to disable splash screen prkos Using Fedora 8 16th July 2008 11:00 AM
Boot splash screen for fedora core 7? RHGB? Bootsplash? Gensplash? Splashy? podoboo Using Fedora 5 25th September 2007 11:56 PM
How to disable splash during booting? x4444 Using Fedora 2 26th November 2006 07:47 PM


Current GMT-time: 10:27 (Thursday, 02-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat