Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 2nd February 2012, 07:52 PM
Cygnia Offline
Registered User
 
Join Date: Oct 2004
Posts: 55
linuxfirefox
Broken Package(s) Prevents Update

Greetings, after trying to run yum update I get the following error message:

Error: Package: ffmpeg-libs-0.8.8-1.fc16.x86_64 (@rpmfusion-free-updates)
Requires: libvpx.so.0()(64bit)
Removing: libvpx-0.9.7.1-1.fc16.x86_64 (@anaconda-0)
libvpx.so.0()(64bit)
Updated By: libvpx-1.0.0-1.fc16.x86_64 (updates)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I haven't installed anything from outside the Fedora/RPMFusion repos, and in fact this is a pretty fresh installation from only a few weeks ago. I tried the second item above but it didn't help. I also tried yum clean all and yum distro-sync also with no change. I gather that doing the first item above only kicks the can down the road and I'll still have some sort of breakage somewhere. Any insights will be appreciated. Thanks in advance.
__________________
--
Bryce Hardy
Reply With Quote
  #2  
Old 2nd February 2012, 08:14 PM
sea Offline
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,291
linuxfedorafirefox
Re: Brozen Package(s) Prevents Update

Are you running F17 rawhide perhaps?
Because thats about exactly the same error message i gotten there.

A workaround could be to temporary (just for this usage) disable the repo with:
Code:
 sudo yum upgrade -y --disablerepo=rpmfusion* --skip-broken
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot

Last edited by sea; 2nd February 2012 at 10:26 PM. Reason: code fixed
Reply With Quote
  #3  
Old 2nd February 2012, 08:25 PM
Cygnia Offline
Registered User
 
Join Date: Oct 2004
Posts: 55
linuxfirefox
Re: Brozen Package(s) Prevents Update

Hi, thanks for the suggestion, but it didn't help. And no, I'm on totally stable and fully updated (until now) Fedora 16 Gnome 64bit. Here is the full output from doing your suggestion, but long story short disabling the repo doesn't seem to affect the fact of the breakage:

Quote:
[root@cygniapolis ~]# yum update --disablerepo=rpmfusion-free-updates
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: linux.mirrors.es.net
* rpmfusion-free: mirror.web-ster.com
* rpmfusion-nonfree: mirror.web-ster.com
* rpmfusion-nonfree-updates: mirror.web-ster.com
* updates: linux.mirrors.es.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package firefox.x86_64 0:9.0.1-1.fc16 will be updated
---> Package firefox.x86_64 0:10.0-1.fc16 will be an update
---> Package gpm-libs.x86_64 0:1.20.6-18.fc16 will be updated
---> Package gpm-libs.x86_64 0:1.20.6-21.fc16 will be an update
---> Package gstreamer-plugins-bad-free.x86_64 0:0.10.22-2.fc16.1 will be updated
---> Package gstreamer-plugins-bad-free.x86_64 0:0.10.22-2.fc16.2 will be an update
---> Package gstreamer-plugins-bad-free-extras.x86_64 0:0.10.22-2.fc16.1 will be updated
---> Package gstreamer-plugins-bad-free-extras.x86_64 0:0.10.22-2.fc16.2 will be an update
---> Package libvpx.x86_64 0:0.9.7.1-1.fc16 will be updated
--> Processing Dependency: libvpx.so.0()(64bit) for package: ffmpeg-libs-0.8.8-1.fc16.x86_64
---> Package libvpx.x86_64 0:1.0.0-1.fc16 will be an update
---> Package selinux-policy.noarch 0:3.10.0-74.fc16 will be updated
---> Package selinux-policy.noarch 0:3.10.0-75.fc16 will be an update
---> Package selinux-policy-targeted.noarch 0:3.10.0-74.fc16 will be updated
---> Package selinux-policy-targeted.noarch 0:3.10.0-75.fc16 will be an update
---> Package xulrunner.x86_64 0:9.0.1-1.fc16 will be updated
---> Package xulrunner.x86_64 0:10.0-1.fc16 will be an update
--> Finished Dependency Resolution
Error: Package: ffmpeg-libs-0.8.8-1.fc16.x86_64 (@rpmfusion-free-updates)
Requires: libvpx.so.0()(64bit)
Removing: libvpx-0.9.7.1-1.fc16.x86_64 (@anaconda-0)
libvpx.so.0()(64bit)
Updated By: libvpx-1.0.0-1.fc16.x86_64 (updates)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
I sure hope I can find the answer, because I'm anxious for the new Firefox 10...
__________________
--
Bryce Hardy
Reply With Quote
  #4  
Old 2nd February 2012, 08:48 PM
jpprade Offline
Registered User
 
Join Date: Nov 2007
Posts: 18
linuxfirefox
Re: Brozen Package(s) Prevents Update

Same problem here (in french):
Quote:
--> Traitement de la dépendance*: libvpx.so.0()(64bit) pour le paquet*: ffmpeg-libs-0.8.8-1.fc16.x86_64
--> Résolution des dépendances terminée
Erreur*: Paquet*: ffmpeg-libs-0.8.8-1.fc16.x86_64 (@rpmfusion-free-updates)
Requiert*: libvpx.so.0()(64bit)
Suppression *: libvpx-0.9.7.1-1.fc16.x86_64 (@anaconda-0)
libvpx.so.0()(64bit)
Mis à jour par*: libvpx-1.0.0-1.fc16.x86_64 (updates)
Non trouvé
I do not have any test / rawhide repository enabled (or never installed anything from them)
Reply With Quote
  #5  
Old 2nd February 2012, 09:05 PM
cooltd825 Offline
Registered User
 
Join Date: Jan 2008
Posts: 30
linuxfirefox
Re: Brozen Package(s) Prevents Update

identical problem here. I'm also using rpm-fusion, so I think it's safe to assume these dependency errors are because we're not "purely on Fedora Updates".

I'm also not Rawhide, so I'm not sure why it's trying to update libvpx to 1.0.0-1. I tried to install the RPM manually, which resulted in the same dependency error with ffmpeg-libs-0.8.8-1.fc16.x86_64.
Reply With Quote
  #6  
Old 2nd February 2012, 09:25 PM
GeekGirl1 Offline
Registered User
 
Join Date: May 2011
Location: Philadelphia, PA
Posts: 32
linuxfirefox
Re: Brozen Package(s) Prevents Update

Identical problem here, running FC16 64-bit. From one attempt:

Code:
Skipped (dependency problems):
  ffmpeg-libs.x86_64 0:0.8.8-1.fc16     firefox.x86_64 0:10.0-1.fc16       gstreamer-plugins-bad-free.x86_64 0:0.10.22-2.fc16.2    
  libvpx.x86_64 0:1.0.0-1.fc16          xulrunner.x86_64 0:10.0-1.fc16     xulrunner-devel.x86_64 0:10.0-1.fc16
And another:
Code:
--> Processing Dependency: libvpx.so.0()(64bit) for package: ffmpeg-libs-0.8.8-1.fc16.x86_64
--> Finished Dependency Resolution
Error: Package: ffmpeg-libs-0.8.8-1.fc16.x86_64 (@rpmfusion-free-updates)
           Requires: libvpx.so.0()(64bit)
           Removing: libvpx-0.9.7.1-1.fc16.x86_64 (@anaconda-0)
               libvpx.so.0()(64bit)
           Updated By: libvpx-1.0.0-1.fc16.x86_64 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
There is no problem to update Thunderbird.
Reply With Quote
  #7  
Old 2nd February 2012, 09:44 PM
willxhunt Offline
Registered User
 
Join Date: Dec 2011
Location: Chicago
Posts: 3
linuxopera
Re: Brozen Package(s) Prevents Update

Exact same issue. F16 Gnome 64 bit. Got my finger on the F5 if anyone has a fix, thank you greatly in advance : D
Reply With Quote
  #8  
Old 2nd February 2012, 09:49 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: Brozen Package(s) Prevents Update

I ran into the same issue, but I had installed some of my audio/video stuff from atrpms.

All I had to do was uninstall my libavcodec52 and if fixed the problem. rpmfusion seems to have put that into a ffmpeg-libs package and not much telling what else would be uninstalled if you remove that package.

rpmfusion should have their package updated within a day or so if you just want to wait and then update.
Reply With Quote
  #9  
Old 2nd February 2012, 10:01 PM
willxhunt Offline
Registered User
 
Join Date: Dec 2011
Location: Chicago
Posts: 3
linuxopera
Re: Brozen Package(s) Prevents Update

Glad that worked for you, but I don't seem to have libavcodec52 : /
thanks though : )
Reply With Quote
  #10  
Old 2nd February 2012, 10:12 PM
zardoz Offline
Registered User
 
Join Date: May 2007
Posts: 22
linuxchrome
Re: Brozen Package(s) Prevents Update

Simplest solution is to do something like

rpm -ivh libvpx-1.0.0-1.fc16.x86_64.rpm

This INSTALLs the new version instead of updating it.
You end up with both versions available and then yum update will work correctly for the other packages.

Sort out the mess later by doing a forced reupdate of the libvpx package once the dust has settled.

Z.
Reply With Quote
  #11  
Old 4th February 2012, 09:46 AM
zardoz Offline
Registered User
 
Join Date: May 2007
Posts: 22
linuxchrome
Cool Re: Brozen Package(s) Prevents Update

Quote:
Originally Posted by zardoz View Post
Simplest solution is to do something like

rpm -ivh libvpx-1.0.0-1.fc16.x86_64.rpm

This INSTALLs the new version instead of updating it.
You end up with both versions available and then yum update will work correctly for the other packages.

Sort out the mess later by doing a forced reupdate of the libvpx package once the dust has settled.

Z.
Once everything is sorted out with the packages that depend on libvpx.so.0 being updated, you finish by running

rpm -Uvh --force libvpx-1.0.0-1.fc16.x86_64.rpm

This will remove the older version very neatly and you will be back on track again.

Z.
Reply With Quote
  #12  
Old 2nd February 2012, 10:24 PM
sea Offline
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,291
linuxfedorafirefox
Re: Broken Package(s) Prevents Update

Ahh, should have added skip broken too

Code:
 sudo yum upgrade -y --disablerepo=rpmfusion* --skip-broken
Works like a charm too.

Code:
$  sudo yum upgrade -y --disablerepo=rpmfusion* --skip-broken
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package firefox.x86_64 0:9.0.1-1.fc16 will be updated
---> Package firefox.x86_64 0:10.0-1.fc16 will be an update
---> Package gstreamer-plugins-bad-free.x86_64 0:0.10.22-2.fc16.1 will be updated
---> Package gstreamer-plugins-bad-free.x86_64 0:0.10.22-2.fc16.2 will be an update
---> Package libvpx.x86_64 0:0.9.7.1-1.fc16 will be updated
--> Processing Dependency: libvpx.so.0()(64bit) for package: ffmpeg-libs-0.8.8-1.fc16.x86_64
---> Package libvpx.x86_64 0:1.0.0-1.fc16 will be an update
---> Package xulrunner.x86_64 0:9.0.1-1.fc16 will be updated
---> Package xulrunner.x86_64 0:10.0-1.fc16 will be an update
--> Running transaction check
---> Package libvpx.x86_64 0:0.9.7.1-1.fc16 will be updated
---> Package libvpx.x86_64 0:1.0.0-1.fc16 will be an update
--> Processing Dependency: libvpx.so.1()(64bit) for package: gstreamer-plugins-bad-free-0.10.22-2.fc16.2.x86_64
--> Processing Dependency: libvpx.so.1()(64bit) for package: xulrunner-10.0-1.fc16.x86_64
--> Running transaction check
---> Package firefox.x86_64 0:9.0.1-1.fc16 will be updated

Packages skipped because of dependency problems:
    firefox-10.0-1.fc16.x86_64 from updates
    gstreamer-plugins-bad-free-0.10.22-2.fc16.2.x86_64 from updates
    libvpx-1.0.0-1.fc16.x86_64 from updates
    xulrunner-10.0-1.fc16.x86_64 from updates
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot

Last edited by sea; 2nd February 2012 at 10:54 PM.
Reply With Quote
  #13  
Old 3rd February 2012, 12:33 AM
GeekGirl1 Offline
Registered User
 
Join Date: May 2011
Location: Philadelphia, PA
Posts: 32
linuxfirefox
Re: Broken Package(s) Prevents Update

Quote:
Originally Posted by sea View Post
Ahh, should have added skip broken too

Code:
 sudo yum upgrade -y --disablerepo=rpmfusion* --skip-broken
Works like a charm too.

Code:
Packages skipped because of dependency problems:
    firefox-10.0-1.fc16.x86_64 from updates
    gstreamer-plugins-bad-free-0.10.22-2.fc16.2.x86_64 from updates
    libvpx-1.0.0-1.fc16.x86_64 from updates
    xulrunner-10.0-1.fc16.x86_64 from updates
Nothing has been fixed (?).
Reply With Quote
  #14  
Old 3rd February 2012, 01:06 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: Broken Package(s) Prevents Update

actually, I found out why I didn't get the dependency conflict with ffmpeg-libs like shown above.

enable the rpmfusion-free-updates-testing repo and update ffmpeg-libs

There is a newer version in there.

Code:
[root@tower20 etc]# yum info ffmpeg-libs
Loaded plugins: etckeeper, langpacks, presto, refresh-packagekit
Installed Packages
Name        : ffmpeg-libs
Arch        : x86_64
Version     : 0.8.9
Release     : 1.fc16
Size        : 7.9 M
Repo        : installed
From repo   : rpmfusion-free-updates-testing
Summary     : Libraries for ffmpeg
URL         : http://ffmpeg.org/
License     : GPLv2+
Description : FFmpeg is a complete and free Internet live audio and video
            : broadcasting solution for Linux/Unix. It also includes a digital
            : VCR. It can encode in real time in many formats including MPEG1
            : audio and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and
            : flash. This package contains the libraries for ffmpeg
Code:
yum --enablerepo=rpmfusion-free-updates-testing update ffmpeg-libs

yum update
Reply With Quote
  #15  
Old 3rd February 2012, 01:26 AM
willxhunt Offline
Registered User
 
Join Date: Dec 2011
Location: Chicago
Posts: 3
linuxopera
Re: Broken Package(s) Prevents Update

that last one from DBelton worked

thank you greatly : D
Reply With Quote
Reply

Tags
brozen, packages, prevents, update

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Update Upsets Graphic Settings & Prevents Programs Running? Riff Gaffer Using Fedora 9 7th September 2010 07:50 AM
Today's Update Prevents F11 Boot westand Using Fedora 5 8th August 2009 07:46 PM
gstreamer-bad prevents update GoinEasy9 Using Fedora 13 3rd July 2009 01:12 PM
yum update broken due to updated ppp package rkl Using Fedora 0 12th July 2004 01:14 PM


Current GMT-time: 18:01 (Thursday, 21-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat