Fedora Linux Support Community & Resources Center
  #1  
Old 12th June 2012, 03:39 PM
juanfgs Offline
Registered User
 
Join Date: Mar 2008
Location: Entre Rios, Argentina
Posts: 166
linuxfirefox
KDE suddenly stopped working F17

All of a sudden kde started crashing at init, I just started systemsettings once (which crashed selecting appearance) and then some qt apps and every kde app refused to start (amarok, clementine, etc) segfaulting at the start.

Ksplash stops at the third icon, I can see that for a second appears the crash manager and then dissapears.

has anyone experienced this?

I already tried moviing the entire configuration folder, deleting cache files, rebooting, but it's strange I didn't do anything in the OS that could cause this.
__________________
I'm back... again...
Reply With Quote
  #2  
Old 12th June 2012, 03:47 PM
secipolla Offline
Registered User
 
Join Date: May 2011
Posts: 700
linuxfirefox
Re: KDE suddenly stopped working F17

Besides deleting ~/.kde (and maybe stuff in ~/.cache and ~/.local) you have to delete the settings it keeps in /var.
Reply With Quote
  #3  
Old 12th June 2012, 03:58 PM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,067
linuxfirefox
Re: KDE suddenly stopped working F17

Also deleting ~/.kde is really bad, that will wipe out all your mail (kmail puts the email under ~/.kde/share/apps/kmail/mail ) among other things. Better is to move ~/.kde to ~/.kde.save and the recover things like email as needed
Reply With Quote
  #4  
Old 13th June 2012, 12:48 PM
juanfgs Offline
Registered User
 
Join Date: Mar 2008
Location: Entre Rios, Argentina
Posts: 166
linuxfirefox
Re: KDE suddenly stopped working F17

Solved, the culprit seems to be the Nvidia propietary driver (version .53), as yesterday (magically) it stopped recognizing the EDID data from my monitor, supporting only 1024x768, after updating to the latest (.59) which STILL didn't recognize the EDID data and fiddling with modelines and xorg.conf (which reminded me my old days with debian sarge and slackware).

Why are these things failing randomly is beyond me...
__________________
I'm back... again...
Reply With Quote
  #5  
Old 2nd September 2012, 05:31 AM
ptrax Offline
Registered User
 
Join Date: Jan 2011
Posts: 18
windows_7firefox
Re: KDE suddenly stopped working F17

I'm also gettting random crashes during KDE startup,
My Nvidia version is 302.17 ,
do you know what Xorg settings fixed your problem?
Reply With Quote
Reply

Tags
f17, kde, stopped, suddenly, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3d suddenly stopped working Jesus Using Fedora 0 27th March 2007 02:48 AM
Man, Firefox suddenly stopped working in FC5 b00st Using Fedora 16 14th April 2006 02:45 AM
sound suddenly stopped working... im_t0m Using Fedora 9 1st May 2005 12:00 AM
FC3 nfs suddenly stopped working gbaker Servers & Networking 5 2nd April 2005 01:13 AM


Current GMT-time: 11:14 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Floresti - Senftenberg Photos on Instagram - Fukiage-fujimi Travel Photos on Instagram