Fedora Linux Support Community & Resources Center
  #1  
Old 2nd August 2005, 02:18 AM
akbhargava Offline
Registered User
 
Join Date: Feb 2005
Location: Cambridge, MA
Posts: 27
vsftpd in FC4 and [550 Failed to open file]

Hi,

I have been struggling with vsftpd in FC4 since I installed FC 4 a week ago. I have disabled all firewalls and removed pretty much all restrictions that I know of. I am including the vsftpd.conf at the bottom of this post - it is pretty much the default file.

My problems lie with the 550 error: "550 Failed to open file." I cannot find any reference that sheds light on how to get rid of this error and have tried all that I know.

Any help would be greatly appreciated.

Thanks,
akb


================================


# Example config file /etc/vsftpd/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd/chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES

pam_service_name=vsftpd
userlist_enable=YES
#enable for standalone mode
listen=YES
tcp_wrappers=YES
Reply With Quote
  #2  
Old 12th August 2005, 09:03 PM
Patpicos Offline
Registered User
 
Join Date: Nov 2004
Posts: 9
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - SELinux is fully disabled.
SELINUX=permissive
# SELINUXTYPE= type of policy in use. Possible values are:
# targeted - Only targeted network daemons are protected.
# strict - Full SELinux protection.
SELINUXTYPE=targeted



/etc/selinux/config


make that file like listed above and you'll be fine, i just did it
Reply With Quote
  #3  
Old 17th August 2005, 10:02 PM
aarongen Offline
Registered User
 
Join Date: Aug 2005
Age: 36
Posts: 1
Thanks! I was having the same problems.
Reply With Quote
  #4  
Old 9th July 2008, 01:57 PM
sultanfahad Offline
Registered User
 
Join Date: Jul 2008
Posts: 1
I am having exactly the same problem. I set the SELINUX=disabled. But the problem still persists.
Reply With Quote
  #5  
Old 3rd February 2009, 10:05 PM
j27 Offline
Registered User
 
Join Date: Feb 2009
Posts: 1
Talking A better solution

Thanks for the selinux hint on this post. I read several other posts first that sounded more promising but were of no help for my situation (running vsftpd in CentOS 5.2).
I looked at file permissions, vsftp, vsftpd.conf, passwd, hosts, all to no avail.
Changing the SELINUX setting in /etc/selinux/config didn't make any difference for me, but I couldn't find a way to notify selinux that I had changed this file (yet the file is read automatically every minute by some process, so maybe selinux doesn't need to be notified). Perhaps I need to reboot, but don't want to do that at present.

In any case, rather than fighting against selinux, why not go with it? I had put the files that I wanted to read via ftp in /var/ftp/pub (which already existed, and could be changed to by the anonymous ftp user). I got the dreaded "550 Failed to open file." message when trying mget or get on the files. To work with selinux I simply ran "chcon -R -t public_content_t /var/ftp" as recommended by "man ftpd_selinux". This made all files in /var/ftp accessible by ftp. The 550 error message went away and the files transferred as desired. To check the selinux settings on a file use "secon -f filename".

I hope this helps some poor soul!
Reply With Quote
  #6  
Old 17th May 2013, 12:19 AM
badtyprr Offline
Registered User
 
Join Date: May 2013
Location: California, USA
Posts: 1
windows_7chrome
Re: A better solution

Quote:
Originally Posted by j27 View Post
Thanks for the selinux hint on this post. I read several other posts first that sounded more promising but were of no help for my situation (running vsftpd in CentOS 5.2).
I looked at file permissions, vsftp, vsftpd.conf, passwd, hosts, all to no avail.
Changing the SELINUX setting in /etc/selinux/config didn't make any difference for me, but I couldn't find a way to notify selinux that I had changed this file (yet the file is read automatically every minute by some process, so maybe selinux doesn't need to be notified). Perhaps I need to reboot, but don't want to do that at present.

In any case, rather than fighting against selinux, why not go with it? I had put the files that I wanted to read via ftp in /var/ftp/pub (which already existed, and could be changed to by the anonymous ftp user). I got the dreaded "550 Failed to open file." message when trying mget or get on the files. To work with selinux I simply ran "chcon -R -t public_content_t /var/ftp" as recommended by "man ftpd_selinux". This made all files in /var/ftp accessible by ftp. The 550 error message went away and the files transferred as desired. To check the selinux settings on a file use "secon -f filename".

I hope this helps some poor soul!
Thanks, I was worried about disabling SELINUX altogether. I much preferred this solution. 550 errors disappeared on CentOS 6.4 and everything's in tip-top shape. Thanks!
Reply With Quote
Reply

Tags
550, failed, fc4, file, open, vsftpd

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm losing it with vsftpd - 226 Transfer done (but failed to open directory). piergi Servers & Networking 3 10th January 2009 02:29 AM
(WW) Open APM failed (/dev/apm_bios) (No such file or directory) alphonsebrown Using Fedora 2 20th March 2006 11:38 AM
500 OOPS: could not open chroot() list file:/etc/vsftpd.chroot_list Hcard Servers & Networking 1 4th May 2005 01:45 PM


Current GMT-time: 03:44 (Friday, 01-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat