Fedora Linux Support Community & Resources Center
  #1  
Old 24th January 2009, 10:57 PM
crolma4 Offline
Registered User
 
Join Date: May 2007
Location: Cleveland, spiritual center of the rust belt
Posts: 34
pulse audio causes app freeze (f10)

I've been having intermittent problems with applications freezing, and I've finally had a string of consistent failures that lead me to suspect that pulse audio causes apps to freeze when they are expecting to play a sound but something about making the sound fails.

Specifically, I'm running gnome under f10 with the pulse audio with the famous mod to default.pa:

load-module module-hal-detect tsched=0

I'm using the proprietary nVidia driver from PRMfusion. It's a 64-bit machine.
The app in question is gedit, which wants to make sound when doing a search, inserting date and time, and many other things.

(1) When the sounds arrive, there's never a freeze
(2) When there was sound at launch, the if the sounds stop coming, there's a freeze.
(3) One time, there was a partial sound, and instantly there was a freeze.

These sounds are generally associated with dialog boxes, but there may have been a few cases where it wasn't.

I can go ahead and kill the app and restart. I eventually get lucky most of the time. Otherwise I have to restart X. I may try disabling such sounds and see what happens.

Does anyone else have this problem?

Last edited by crolma4; 24th January 2009 at 11:02 PM.
Reply With Quote
  #2  
Old 4th February 2009, 04:57 AM
crolma4 Offline
Registered User
 
Join Date: May 2007
Location: Cleveland, spiritual center of the rust belt
Posts: 34
OK, it's been a few days and my life has gotten a lot smoother. Nothing like the freezes described above.

What I did was System > Preferences > Hardware > Sounds > Sound Tabs uncheck play alerts and sound effects. As this appears to work, I must point not the finger at pulse audio per se, but at whatever mis-handles these event.
(Metacity??)
Reply With Quote
Reply

Tags
app, application, freeze, pulse, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pulse Audio relayer Installation, Upgrades and Live Media 0 13th March 2009 08:40 PM
Dumping Pulse Audio seohonolulu Using Fedora 12 18th February 2009 10:11 PM
F10 Bluetooth Audio + Pulse == pulse crashes. fwelland Hardware & Laptops 2 7th February 2009 01:07 PM
glitchy pulse audio Sono Pazzo Using Fedora 7 11th January 2009 06:58 PM
Fedora 8, Pulse Audio, 2 Audio Cards Alex Lang Using Fedora 5 24th January 2008 09:05 PM


Current GMT-time: 07:41 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat