Fedora Linux Support Community & Resources Center
  #1  
Old 9th June 2009, 07:44 PM
Cuvou Offline
Registered User
 
Join Date: Sep 2007
Location: Los Angeles, CA
Posts: 123
Gnome FAT32 - "shortname=lower" can't be changed?

Usually one of the first things I do on a fresh Fedora installation is to install gconf-editor, edit my /system/storage/default_options/vfat/mount_options key, and change the "shortname=lower" there to "shortname=mixed", because on my FAT32 volumes I have the occasional folder that must be all uppercase, but which gets turned to all lowercase by default.

This is particularly bothersome when backing up websites, where the website has a directory that's all in caps. When restoring from the backup, the directory ends up all in lowercase, and then 404s happen all over the place.

In Fedora 11, changing this option in the configuration editor doesn't do anything, though. Flash drives and external hard drives still mount with the shortname=lower option. So, I googled it, modified the HAL configuration files in /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi and created /usr/share/hal/fdi/policy/20thirdparty/95-fat-uppercase.fdi (which I found on a different thread on this forum).

Does anyone else know about this bug? Are there workarounds?

The 95-fat-uppercase.fdi I found on the forum has this content:

Code:
<?xml version="1.0" encoding="utf-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="block.is_volume" bool="true">
      <match key="volume.fsusage" string="filesystem">
        <match key="volume.fsversion" string="FAT12">
          <merge key="volume.policy.mount_option.iocharset=utf8" type="bool">false</merge>
          <merge key="volume.policy.mount_option.shortname=mixed" type="bool">true</merge>
        </match>
        <match key="volume.fsversion" string="FAT16">
          <merge key="volume.policy.mount_option.iocharset=utf8" type="bool">false</merge>
          <merge key="volume.policy.mount_option.shortname=mixed" type="bool">true</merge>
        </match>
        <match key="volume.fsversion" string="FAT32">
          <merge key="volume.policy.mount_option.iocharset=utf8" type="bool">false</merge>
          <merge key="volume.policy.mount_option.shortname=mixed" type="bool">true</merge>
        </match>
      </match>
    </match>
  </device>
</deviceinfo>
Also, output of lshal:

Code:
[kirsle@aerelon 20thirdparty]$ lshal | grep shortname
  volume.mount.valid_options = {'ro', 'sync', 'dirsync', 'noatime', 'nodiratime', 'noexec', 'quiet', 'remount', 'exec', 'utf8', 'shortname=mixed', 'codepage=', 'iocharset=', 'umask=', 'dmask=', 'fmask=', 'uid=', 'flush'} (string list)
  volume.policy.mount_option.shortname=mixed = true  (bool)
But, even with all these different attempts to make it mount with shortname=mixed, it still doesn't:

Code:
[kirsle@aerelon 20thirdparty]$ mount
/dev/mapper/vg_aerelon-lv_root on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw)
/dev/sda3 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
gvfs-fuse-daemon on /home/kirsle/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=kirsle)
/dev/sdb1 on /media/MIDNIGHT type vfat (rw,nosuid,nodev,uhelper=devkit,uid=500,gid=500,shortname=lower,dmask=0077,utf8=1,flush)
Reply With Quote
  #2  
Old 9th June 2009, 08:19 PM
Cuvou Offline
Registered User
 
Join Date: Sep 2007
Location: Los Angeles, CA
Posts: 123
It looks like HAL isn't the place to look for this, as Fedora 11 has moved to DeviceKit-disks to manage automounting. However, I can't seem to find configurable mount options for devkit. I saw a bug report where somebody said that exposing mount options to the end user is "useless" and unless somebody could convince him otherwise, that devkit would not have user-configurable mount options. I don't like how they remove functionality that used to be there for no reason whatsoever except that one developer just decided it all by himself...

So if these mount options are hardcoded they'd have to be patched and recompiled if one wants to change the shortname=lower to shortname=mixed for FAT32? -_-
Reply With Quote
  #3  
Old 9th June 2009, 10:15 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
The only solution I've found to this is to put the mount options in /etc/fstab

Code:
/dev/sdb1  /media/Elements  vfat  noauto,user,rw,nosuid,nodev,uid=500,gid=500,shortname=mixed,dmask=0077,utf8=1,flush 0 0
you also need to create the mountpoint /media/Elements manually.

(I just cut & pasted the hal mount options and prefaced with noauto,user)

Quote:
$ mount
...
/dev/sdb1 on /media/Elements type vfat (rw,noexec,nosuid,nodev,uid=500,gid=500,shortname=mixed,dmask=0077,utf8=1,flush)

EDIT
actually, i removed uhelper=devkit option, since otherwise only root can unmount. The behaviour is now as expected - plug the drive in and it mounts on gnome-desktop, right-click to unmount. You can use the UUID in fstab if not always assigned to /dev/sdb1

Last edited by sideways; 9th June 2009 at 10:25 PM.
Reply With Quote
  #4  
Old 9th June 2009, 10:49 PM
Cuvou Offline
Registered User
 
Join Date: Sep 2007
Location: Los Angeles, CA
Posts: 123
Thanks,

This should be fine for my external hard drives (I'll look into mounting them by UUID though since they might not always have the same names in /dev). I use the external HDDs for backups so this is the main area where I need the shortname=mixed option. But for the random flash drive I'm still out of luck (unless I can put all my flash drives into fstab and they'd automount when inserted using that instead of the default options DeviceKit gives it? I'll have to play around with it).
Reply With Quote
  #5  
Old 10th June 2009, 02:35 AM
Cuvou Offline
Registered User
 
Join Date: Sep 2007
Location: Los Angeles, CA
Posts: 123
I updated my fstab to add this line:

Code:
# External HDD Midnight
UUID=4929-C14C /mnt/Midnight vfat noauto,user,rw,nosuid,nodev,uid=500,gid=500,shortname=mixed,dmask=0077,utf8=1,flush,sync
With this line in here, the drive can't be mounted/unmounted "like normal" -- i.e. the drive isn't listed in Nautilus's Places folder, or placed on the desktop. It also doesn't mount on startup.

However if I just do `mount /dev/sdb1` as my regular user, it mounts to /mnt/Midnight fine and then its all good. I created a launcher on my desktop that does `nautilus --no-desktop /mnt/Midnight` so that there's an "icon" on my desktop, but it's not a real mount icon, and the folder is empty when I log on until I actually run the mount command.

It's not too bad though. I'm gonna try to work around it by adding a new startup item in GNOME, that will run the command `mount -U 4929-C14C`.
Reply With Quote
  #6  
Old 10th June 2009, 03:46 PM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
If you create the mount point in /media rather than /mnt then it should work ok (automount on gnome desktop and will appear in Places)
Reply With Quote
  #7  
Old 10th June 2009, 06:36 PM
Cuvou Offline
Registered User
 
Join Date: Sep 2007
Location: Los Angeles, CA
Posts: 123
Thanks, I'll try that if I switch back to GNOME.

I'm not a fan of where GNOME 3.0 looks like it's headed, so in the meantime I've grown more fond of XFCE, and honestly the only thing keeping me on GNOME for Fedora 11 was the fact that GNOME had configurable mount options for removable media -- but since those are out the window at the whim of a developer and I must use /etc/fstab to get around it, all desktop environments are on equal grounds there.

On XFCE my external hard drives have icons on the desktop (in addition to the custom launchers I created) and entries in the Places menu (on the panel applet and in Thunar). If they disappear again on next reboot though I'll try changing the mount point.

The reason for XFCE right now is that my NVIDIA card isn't working right (no 3D support, so no desktop effects or Compiz, however regular compositing works fine), and Metacity's compositing option insists on drawing thumbnails for windows when doing Alt+Tab, and with a no-3D video card driver, these thumbnails take half a second to generate, which slows me down. XFWM4 has compositing but uses simple icons for Alt+Tab instead of thumbnails, and XFWM4 doesn't integrate with GNOME - so, XFCE for now until I get the NVIDIA stuff sorted out. But that's a topic for a different thread.
Reply With Quote
Reply

Tags
changed, fat32, gnome, shortnamelower

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"ls" and "cd" treat ".." differently inside symlinked directories bnorman Using Fedora 0 19th June 2008 04:49 PM
Metacity and "Xlib: extension "SHAPE" missing on display ":0.0". debu_sagii Using Fedora 0 29th August 2007 05:53 PM
problems while installing gnome 2.18, "no module named libxml2" and "libmodule_id" parv Using Fedora 1 30th March 2007 09:22 AM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 04:59 AM
Scroll down to the last line by "end" key in "less" using "Terminal GNOME&q Szpak Using Fedora 0 7th June 2004 02:24 AM


Current GMT-time: 13:33 (Wednesday, 17-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat