Fedora Linux Support Community & Resources Center
  #1  
Old 15th August 2009, 12:07 AM
jbhardman Offline
Registered User
 
Join Date: Oct 2008
Posts: 32
linuxfedorafirefox
Package conflicts on update

I have searched and found others with this problem, but nothing has helped me resolve it. I've tried the "yum clean all" option to no avail. When I update either with the GUI or command line, I get this error:

Quote:
[root@joshhardman ~]# yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package anacron.x86_64 0:2.3-78.fc11 set to be updated
---> Package binutils.x86_64 0:2.19.51.0.14-1.fc11 set to be updated
---> Package crontabs.noarch 0:1.10-30.fc11 set to be updated
---> Package genisoimage.x86_64 0:1.1.9-6.fc11 set to be updated
---> Package icedax.x86_64 0:1.1.9-6.fc11 set to be updated
---> Package shadow-utils.x86_64 2:4.1.4.1-5.fc11 set to be updated
---> Package wodim.x86_64 0:1.1.9-6.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ================================================== ================================================== ================================================== =======
Package Arch Version Repository Size
================================================== ================================================== ================================================== ================================================== =======
Updating:
anacron x86_64 2.3-78.fc11 updates 43 k
binutils x86_64 2.19.51.0.14-1.fc11 updates 3.4 M
crontabs noarch 1.10-30.fc11 updates 9.8 k
genisoimage x86_64 1.1.9-6.fc11 updates 594 k
icedax x86_64 1.1.9-6.fc11 updates 196 k
shadow-utils x86_64 2:4.1.4.1-5.fc11 updates 1.2 M
wodim x86_64 1.1.9-6.fc11 updates 527 k

Transaction Summary
================================================== ================================================== ================================================== ================================================== =======
Install 0 Package(s)
Update 7 Package(s)
Remove 0 Package(s)

Total size: 6.0 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /usr/share/info/as.info.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/info/binutils.info.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/info/gprof.info.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/info/ld.info.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/es/LC_MESSAGES/bfd.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/id/LC_MESSAGES/bfd.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/da/LC_MESSAGES/binutils.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/es/LC_MESSAGES/binutils.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/id/LC_MESSAGES/binutils.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/sk/LC_MESSAGES/binutils.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/vi/LC_MESSAGES/binutils.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/es/LC_MESSAGES/gprof.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/id/LC_MESSAGES/gprof.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/es/LC_MESSAGES/ld.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/id/LC_MESSAGES/ld.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/es/LC_MESSAGES/opcodes.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/fi/LC_MESSAGES/opcodes.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/id/LC_MESSAGES/opcodes.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/nl/LC_MESSAGES/opcodes.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/es/LC_MESSAGES/gas.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/locale/id/LC_MESSAGES/gas.mo from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/addr2line.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/ar.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/as.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/c++filt.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/gprof.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/ld.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/nm.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/objcopy.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/objdump.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/ranlib.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/readelf.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/size.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/strings.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/strip.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586
file /usr/share/man/man1/windmc.1.gz from install of binutils-2.19.51.0.14-1.fc11.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.i586

Error Summary
-------------

[root@joshhardman ~]#
Any ideas? Can I not have the 64 bit and 32 bit packages installed at the same time?
Reply With Quote
  #2  
Old 15th August 2009, 12:20 AM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,294
linuxopera
Quote:
Can I not have the 64 bit and 32 bit packages installed at the same time?
Not on Fridays, nor when someone fumbles the builds.
Quote:
Any ideas?
It appears that an update of 32-bit binutils may be needed to allow the update. You can:
> remove the existing 32-bit binutils to allow this update to proceed, and add it back later when an update (hopefully fixed/compatible) is available.
> exclude (64-bit) binutils from this update in order to get the other stuff, and hope that the situation resolves itself soon.

In any case: the 32-bit binutils-2.19.51.0.2-17.fc11.i586 is the blocker.

V
Reply With Quote
Reply

Tags
conflicts, package, update

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
x86_64 fc8 package update conflicts Oldbutnew Using Fedora 7 26th December 2008 07:08 PM
yum update package conflicts mercadier Using Fedora 2 30th June 2008 03:47 AM
Package hal conflicts with kernel < 2.6.17 during FC5 upgrade to FC6 vsem EOL (End Of Life) Versions 11 16th January 2008 06:16 PM
upgrade package conflicts dan sawyer Installation, Upgrades and Live Media 4 22nd October 2007 01:59 AM
RPM package conflicts aretwodeetwo Using Fedora 3 30th August 2005 01:13 PM


Current GMT-time: 00:36 (Tuesday, 25-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Port Alfred Travel Photos on Instagram - Winchester Photos - Kudachi