Fedora Linux Support Community & Resources Center
  #1  
Old 18th August 2009, 10:55 AM
dandrestor Offline
Registered User
 
Join Date: Aug 2009
Posts: 5
linuxfedorafirefox
middle button scrolling

Hello everybody, this is my first post on this forum!

I just installed Fedora 11 on my Thinkpad T500 and am trying to get middle-button scrolling to work. I tried the same settings which I used on my old T61, that is, I created a HAL policy in /etc/hal/fdi/policy/mouse-wheel.fdi which contains the following:

<match key="info.product" string="TPPS/2 IBM TrackPoint">
<merge key="input.x11_options.EmulateWheel" type="string">true</merge>
<merge key="input.x11_options.EmulateWheelButton" type="string">2</merge>
<merge key="input.x11_options.YAxisMapping type="string">4 5</merge>
<merge key="input.x11_options.Emulate3Buttons" type="string">true</merge>
<merge key="input.x11_options.EmulateWheelTimeout" type="string">200</merge>
</match>

Unfortunately the scrolling doesn't work. Any ideas?

Thanks,
Dan
Reply With Quote
  #2  
Old 18th August 2009, 12:47 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
Did you create and save the file as root? Have you rebooted? I use exactly the same file with success on my T42. Which programs are you trying to scrolll in?
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #3  
Old 18th August 2009, 12:58 PM
CSchwangler Offline
Registered User
 
Join Date: Feb 2009
Posts: 2,535
windows_xp_2003firefox
If you type lshal in a CLI, do you find that your settings are active?
Reply With Quote
  #4  
Old 18th August 2009, 12:58 PM
dandrestor Offline
Registered User
 
Join Date: Aug 2009
Posts: 5
linuxfedorafirefox
Yes, the file is owned by root:root and has permissions 644. And yes, I have rebooted since adding the policy. I tried to scroll, for instance, in the Gnome Terminal. It didn't work.
Usually, on my old laptop, when I pressed the middle mouse button the cursor would be frozen in place and scrolling would occur instead of cursor movement. On my T500, the middle button is ignored - cursor movement occurs as usual.
Reply With Quote
  #5  
Old 18th August 2009, 01:04 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
I looked at thinkwiki.org, and a T300 user has the file in a different location. You might try his setup.

http://www.thinkwiki.org/wiki/Instal..._Thinkpad_X300
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #6  
Old 18th August 2009, 01:04 PM
dandrestor Offline
Registered User
 
Join Date: Aug 2009
Posts: 5
linuxfedorafirefox
I typed lshal and the only stanza that has "TPPS/2 IBM TrackPoint" in it is the one listed below.
Apparently my settings aren't being picked up. There should have been several more lines with my "input.x11_options" settings, right?

udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input'
access_control.file = '/dev/input/event5' (string)
access_control.type = 'mouse' (string)
info.callouts.add = {'hal-acl-tool --add-device', 'hal-probe-vmmouse'} (string list)
info.callouts.remove = {'hal-acl-tool --remove-device'} (string list)
info.capabilities = {'input', 'input.mouse', 'access_control'} (string list)
info.category = 'input' (string)
info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port' (string)
info.product = 'TPPS/2 IBM TrackPoint' (string)
info.subsystem = 'input' (string)
info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input' (string)
input.device = '/dev/input/event5' (string)
input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port' (string)
input.product = 'TPPS/2 IBM TrackPoint' (string)
input.x11_driver = 'evdev' (string)
linux.device_file = '/dev/input/event5' (string)
linux.hotplug_type = 2 (0x2) (int)
linux.subsystem = 'input' (string)
linux.sysfs_path = '/sys/devices/platform/i8042/serio1/input/input5/event5' (string)
Reply With Quote
  #7  
Old 18th August 2009, 01:16 PM
David Batson Offline
Registered User
 
Join Date: Jul 2009
Posts: 1,234
linuxopera
I am guessing here, but I would try using only the liines from the T300 post in /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi. I would remove all the other lines.

I only know what I see by what others have done. I don't really understand HAL very well myself. You might try other searches on thinkwiki.org or with Google.
__________________
Fedora 19 Gnome on a ThinkPad X220, i5-2540M CPU, Intel HD Graphics 3000, Intel N 6205 wireless, and Sierra Wireless 754S Mobile Hotspot (AT&T)
Reply With Quote
  #8  
Old 18th August 2009, 01:27 PM
dandrestor Offline
Registered User
 
Join Date: Aug 2009
Posts: 5
linuxfedorafirefox
From http://people.freedesktop.org/~david...i-search-paths :

Device Information files are read from two directories
* /usr/share/hal/fdi - for files provided by packages
* /etc/hal/fdi - for files provided by the system administrator / user

So, according to the documentation, the hal daemon should pick up what I put in /etc/hal/fdi/policy. Could this be a bug?
Reply With Quote
  #9  
Old 18th August 2009, 01:43 PM
dandrestor Offline
Registered User
 
Join Date: Aug 2009
Posts: 5
linuxfedorafirefox
I added the lines as suggested in the ThinkWiki howto... and the changes were obviously picked up since my mouse and keyboard stopped working in X However, I'd really like to make this work as it should, and not use the /usr/share/hal directory.
Reply With Quote
Reply

Tags
button, middle, scrolling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
the middle mouse button daniel_I_l Hardware & Laptops 1 30th August 2008 11:22 PM
Thinkpad Middle Mouse Button SiriusStarr Hardware & Laptops 1 31st August 2007 11:30 PM
Logitech magnetic mouse middle button scrolling richjoh Hardware & Laptops 8 27th March 2007 04:53 AM
Middle Mouse button not working klingon Hardware & Laptops 0 16th June 2005 04:56 AM


Current GMT-time: 11:20 (Monday, 20-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Arad - Uetersen Photos - Ilanskiy Instagram Photos