Fedora Linux Support Community & Resources Center
  #1  
Old 8th November 2010, 10:43 PM
AndyW Offline
Registered User
 
Join Date: Nov 2008
Location: London
Posts: 32
linuxfedorafirefox
Problem with bacula-sd on FC14 - maybe glibc related?

I have been using Bacula for a few months now happily on x86_64 FC12 & FC13. I have just now upgraded to FC14, duing which my Bacula packages got upgraded to 5.0.2-8.fc14, but am now unable to start bacula-sd (the storage daemon). The service dies as soon as I start it and I get a message "bacula-sd dead but subsys locked" if I query the status. Whenever I query the status or stop bacula-sd - but not when I (re)start it - I get the following syslog messages referencing libc-2.12.90.so:-
Code:
root@localhost init.d]# ./bacula-sd status
bacula-sd dead but subsys locked
Code:
Nov  8 21:24:47 localhost kernel: [161155.229044] pidof[17514]: segfault at 0 ip 00007f2f9097d316 sp 00007fffb83e2888 error 4 in libc-2.12.90.so[7f2f908fc000+199000]
Nov  8 21:24:47 localhost kernel: [161155.271610] pidof[17515]: segfault at 0 ip 00007f8835f08316 sp 00007fff931ff828 error 4 in libc-2.12.90.so[7f8835e87000+199000]
libc-2.12.90.so is part of GNU libc. I have both x86_64 and i686 versions, and a total of three instances of the file:
Code:
[root@localhost etc]# find / -name libc-2.12.90.so -exec ls -l {} \;
-rwxr-xr-x. 1 root root 1989560 Oct 22 18:50 /lib64/libc-2.12.90.so
-rwxr-xr-x. 1 root root 1906468 Oct 22 18:59 /lib/i686/nosegneg/libc-2.12.90.so
-rwxr-xr-x. 1 root root 1886052 Oct 22 18:59 /lib/libc-2.12.90.so
All are on version level glibc-2.12.90-18.

Are there any known issues with this version of glibc? Anyone else have the same problem with bacula / FC14 - or alternatively have it all working fine? The other parts of bacula (bacula-dir and bacula-fd) are fine and the tape drive (Tandberg SLR7) works fine with mt and tapeinfo. Kernel is 2.6.35.6-48.fc14.x86_64

Thanks for any advice,
Andrew
__________________
Gigabyte GA-970A-DS3 - AMD FX-6100 - 2 x 2GB PC6400 - Asus Radeon HD 4670 - Hauppauge WinTV Go! BT878 - Hauppauge HVR-2200
Reply With Quote
Reply

Tags
baculasd, fc14, glibc, problem, related

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FC14 - Firefox animated GIF problem? Cuvou Using Fedora 49 6th January 2011 07:42 PM
ca-certificates problem on FC14 mecrox Installation, Upgrades and Live Media 7 20th November 2010 10:35 AM
bacula-fd (on Windows Vista 64 bit) fails to connect with bacula-sd (on Fedora 11) Avner Using Fedora 2 20th September 2009 08:41 AM
Problem updating glibc-common/glibc maladeus Using Fedora 0 28th August 2007 08:23 PM
"yum install glibc-devel" = Error: glibc-common conflicts with glibc < 2.3.6 nat101l Using Fedora 22 10th November 2005 07:16 PM


Current GMT-time: 00:55 (Sunday, 23-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Kampong Baharu Balakong - Moram Instagram Photos - Deva Photos on Instagram