Fedora Linux Support Community & Resources Center
  #1  
Old 23rd December 2010, 07:05 PM
icebearsoft Offline
Registered User
 
Join Date: Aug 2010
Posts: 6
linuxfirefox
Thumbs down How to disable automounting

I want to disable automounting removable media when they are inserted, especially CD and DVD. I use F13 and Gnome. I went through System/Preferences/File Management/Media and set everything to "Do Nothing", see below:



I have installed gconf-editor and verified that all automounting options are unchecked:



according to "/sbin/chkconfig --list" haldaemon is off and automount is not installed.
What else should I check?

I would not mind if USB (flash) disks were automounted
Reply With Quote
  #2  
Old 23rd December 2010, 08:15 PM
mtk Offline
Registered User
 
Join Date: Apr 2004
Posts: 141
linuxchrome
Re: How to disable automounting

that's funny. i use KDE and i have the opposite problem. i can never get it to work. this behavior has persisted through FC12, FC13, and now FC14. sigh....
Reply With Quote
  #3  
Old 27th December 2010, 09:05 PM
icebearsoft Offline
Registered User
 
Join Date: Aug 2010
Posts: 6
linuxfirefox
Lightbulb Re: How to disable automounting

I know this is not the right way but I have "solved" the problem by developing an unmounting daemon, see http://icebearsoft.euweb.cz/zwumountd/
Reply With Quote
  #4  
Old 30th December 2010, 04:05 AM
Mariusz W Offline
Registered User
 
Join Date: Nov 2007
Location: Berkeley, California
Posts: 690
linuxfedoragaleon
Re: How to disable automounting

It is Nautilus that automounts for you USB drives. I have little idea about configuring Nautilus. I never done this myself, except for some really simple customizations. The reason is: I rarely use window managers.

Re. HAL -- it is deprecated, Nautilus doesn't use it any more if I am right, for mounting/unmounting.

One immediate solution is to start using fluxbox. There is an excellent tutorial thread devoted to fluxbox in the Guides area of the Fedora Forum. It encouraged me to dive into fluxbox a few days ago and in no time I was very happy with it: I realized that in fluxbox you can do anything you normally do in GNOME or KDE, usually even faster and more conveniently, if you are prepared to spend a few hours learning how to do that, or just following the instructions in that thread.

And replace the default style, whatever its name, initially with the preinstalled zimek blue style, and then go google for

fluxbox Equinox theme

(glorious GTK Equinox theme has been ported to fluxbox just 3 weeks ago), find it, download the archive (it's tiny), and unpack it in the ~/.fluxbox/style directory -- you will end up with a great looking, low footprint, very responsive, and powerful desktop.

Last edited by Mariusz W; 30th December 2010 at 04:08 AM.
Reply With Quote
Reply

Tags
automount, disabling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6 not automounting cd/dvd pjeeanah Hardware & Laptops 3 31st December 2006 08:44 AM
Automounting on FC5 ? Xavior Hardware & Laptops 10 2nd September 2006 09:32 PM
Disable automounting partition in Gnome Szpak Using Fedora 4 4th May 2005 10:33 PM
fc3 - where's gcc and automounting cd? confusednewuser EOL (End Of Life) Versions 7 15th March 2005 03:58 PM
Disable automounting in FC2 Viro EOL (End Of Life) Versions 5 23rd July 2004 06:57 AM


Current GMT-time: 07:36 (Thursday, 18-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Blackwood Coffee & Chocolate Kangar Photos - Arlington Park Photos - SMDC Grass Residences, SM North Edsa Travel Photos on Instagram - Luang Prabang, Laos