Fedora Linux Support Community & Resources Center
  #1  
Old 19th March 2011, 08:42 PM
Interax Offline
Registered User
 
Join Date: Mar 2011
Posts: 6
linuxfedorafirefox
No non-root sound in Fedora 14

I have just installed Fedora 14. x86-64 edition. It is my first experience of using Fedora.
Alas, I am having problems getting sound working for the normal user. I enabled root access to see if it was a permissions thing. Clearly it is. Sounds work for the root account. I have been reading a lot of posts to see what I can change.
Nothing has worked yet. I have put myself in the audio group in /etc/group, but it does not help. For some reason pulseaudio will only work for root. I am being denied access to /dev/snd/* even though I am in the audio group and the permissions of the files in /dev/snd allow read/write access to the audiio group.

lspci -v | grep audio
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)

Can anyone please suggest what I should do?
Reply With Quote
  #2  
Old 20th March 2011, 05:01 AM
JohnVV Offline
Registered User
 
Join Date: Aug 2005
Location: Ann Arbor
Age: 47
Posts: 3,948
linuxsusefirefox
Re: No non-root sound in Fedora 14

have you added your normal user to the " audio " group
under
users and groups
you might also need to add "pluse" to your own group

search the forums here
there are many many pages on this
__________________
OpenSUSE 13.1-64bit & Scientific Linux 6.5-64bit ( fedora 4 to 11) and 19/20 on KVM
My Celestia Downloads

h t t p ://celestiamotherlode.net/catalog/show_creator_details.php?creator_id=10
Reply With Quote
  #3  
Old 20th March 2011, 01:48 PM
Interax Offline
Registered User
 
Join Date: Mar 2011
Posts: 6
linuxfedorafirefox
Re: No non-root sound in Fedora 14

Thank you for your reply.
I tried all the permutations with permissions in /etc/group. In the end, after a lot of wasted time, I had to remove pulseaudio. Now sound works, but the sound system is slightly broken.
1) There is no volume control applet on the gnome panel.
2) I have a multi-user system. Between reboots whoever logs in first holds the sound server. If that user logs out and another user logs in, then the second user cannot get sound. He has to reboot and be the first to log in to get sound. All users are in the audio group, but in Fedora 14 it does not seem to make any difference whether they are there or not.

Do you, or does anyone know any way of fixing these problems, particularly the second? Thanks in advance.
Reply With Quote
  #4  
Old 20th March 2011, 03:40 PM
smr54 Online
Registered User
 
Join Date: Jan 2010
Posts: 5,567
linuxchrome
Re: No non-root sound in Fedora 14

Way back around Fedora 8, one had to sometimes edit /etc/security/console.perms.d, but that was usually for those who weren't using Gnome. (It was an issue with consolekit, and rather than fixing it, they just made consolekit, almost impossible to disable.)

I have a very dated page on this at http://home.roadrunner.com/~computer...u/rhsound.html

Note that it was written around the time of F8, and I have no idea if any of it is still applicable--I haven't had any of the problems mentioned there since F10 or F11.
Reply With Quote
  #5  
Old 21st March 2011, 12:54 PM
Interax Offline
Registered User
 
Join Date: Mar 2011
Posts: 6
linuxfedorafirefox
Re: No non-root sound in Fedora 14

Thank you smr54 for your reply. I have read your old howto with interest.
From this:
The avahi-daemon is running in run-levels 3, 4, and 5.
ConsoleKit is installed but the command:
/sbin/chkconfig --list ConsoleKit
returns an error.
/etc/ConsoleKit is empty apart from this file: .../seats.d/00-primary-seat
[Seat Entry]
Version=1.0
Name=Primary seat
Hidden=false
Devices=
which does not seem to do anything.
How do I use ConsoleKit in Fedora 14? I cannot find any information on this.
I created a /etc/security/console.perms.d/50-default.perms file with the entry specified in your old howto, but it did not improve the situation which is currently:
1) I have restored a volume control applet in the system tray by installing GMixer. I get a report that GMixer has crashed the first time that it is used, but this does not seem to stop me changing the volume. However the control-volume-slider does not dock with the gnome panel, but appears in the top left of the monitor screen.
2) New user still has to reboot rather than login to get full system sound for CD, DVD, music files, however sound with YouTube videos watched in Firefox is available after a login following a logout.
3) System/Preferences/Sound no longer works but hangs "waiting for the sound system to respond"

I have completely removed pulse and feel that alsa needs some configuring, but I am not sure how to do this in Fedora14.
Any more help would be appreciated. Thanks.
Reply With Quote
  #6  
Old 21st March 2011, 01:36 PM
smr54 Online
Registered User
 
Join Date: Jan 2010
Posts: 5,567
linuxchrome
Re: No non-root sound in Fedora 14

The only help I can give with your questions here is that part of the "fix" was to make ConsoleKit difficult to remove. Therefore, it's probably running.

As pulse hasn't given me much problem lately, I don't know how much more difficult it's become to remove it.. Again, although I get errors when using, for example, mplayer, about being unable to start the pulse daemon, sound works for me.
Reply With Quote
  #7  
Old 21st March 2011, 08:39 PM
JohnVV Offline
Registered User
 
Join Date: Aug 2005
Location: Ann Arbor
Age: 47
Posts: 3,948
linuxsusefirefox
Re: No non-root sound in Fedora 14

by cahnce when you installed 14
is it a DEFAULT install ?
or did you pick and choose what to install?
if so fedora's installer is notorious for messing a "custom" install up
__________________
OpenSUSE 13.1-64bit & Scientific Linux 6.5-64bit ( fedora 4 to 11) and 19/20 on KVM
My Celestia Downloads

h t t p ://celestiamotherlode.net/catalog/show_creator_details.php?creator_id=10
Reply With Quote
  #8  
Old 21st March 2011, 09:16 PM
Interax Offline
Registered User
 
Join Date: Mar 2011
Posts: 6
linuxfedorafirefox
Re: No non-root sound in Fedora 14

Thanks for your help anyway, smr54. I suppose we can live with these imperfections, but I'll go on looking for a solution. It must be a simple permissions thing, somewhere isn't it?
JohnVV. It was a default install. I agree that the installer could have been better. There were one or two niggles. For instance I wanted the home folder partition to use reiserfs, which wasn't an option. It also didn't give me the option of installing the grub boot info to the master boot record of the drive fedora was installed to. I had to force it by disabling the other hard drives during the install. It wanted to use the master boot record of the first hard drive, which would have messed the Ubuntu Grub 2 bootloader which I usually use. That was rather thoughtless. Linux usually tries to be polite and accommodating unlike a well-known commercial competitor.
Anyway, now that I have uninstalled pulse, I assume that it is alsa which is giving the sound. It is difficult to be sure because alsa keeps a low profile in Fedora 14. What commands should I give to stop and restart alsa? I thought it was worth a try for the next person to login after a logout (rather than a reboot).

Last edited by Interax; 21st March 2011 at 09:56 PM. Reason: Another post came in before posted
Reply With Quote
  #9  
Old 25th March 2011, 12:25 AM
Interax Offline
Registered User
 
Join Date: Mar 2011
Posts: 6
linuxfedorafirefox
Re: No non-root sound in Fedora 14

Does no-one know how to stop and restart alsa in Fedora 14? You used to be able to use commands:

sudo /etc/init.d/alsa-utils stop

sudo alsa force-reload

sudo /etc/init.d/alsa-utils start

These are not applicable to Fedora 14. How is it done now? Does no-one know?
Reply With Quote
  #10  
Old 25th March 2011, 01:07 AM
smr54 Online
Registered User
 
Join Date: Jan 2010
Posts: 5,567
linuxchrome
Re: No non-root sound in Fedora 14

Fedora (and many other desktop distributions) have pretty much changed their installers to be as, or more, inflexible as those well known commercial distributions. In the old days, it was fairly easy to remove pulseaudio, but at this point, it's become quite hard. You might try

http://www.fedoraforum.org/forum/sho...d.php?t=237230

untested by me, to see if it works.

In fairness, pulse doesn't bother me anymore since they got it to the point where it pretty much works. Therefore, I haven't kept up on whether it's easy or difficult to get rid of it.

http://fedoraunity.org/Members/fenri...nd-workarounds

deals with pulseaudio, but not how to get rid of it. It seems to be becoming the default in most Linux distributions now.
Reply With Quote
  #11  
Old 25th March 2011, 01:23 AM
JohnVV Offline
Registered User
 
Join Date: Aug 2005
Location: Ann Arbor
Age: 47
Posts: 3,948
linuxsusefirefox
Re: No non-root sound in Fedora 14

Quote:
Does no-one know how to stop and restart alsa in Fedora 14? You used to be able to use commands:

sudo /etc/init.d/alsa-utils stop
???????
fedora has been using pulse audio since fedora 8
pulse audio overrides alsa and oss as the system default

so unless you changed things .....
also fedora has NEVER used "sudo"
fedora can use it but it is NOT installed nor set up by default
so for
Code:
You used to be able to use commands:

sudo /etc/init.d/alsa-utils stop
YOU had to have installed sudo and have had to set it up
__________________
OpenSUSE 13.1-64bit & Scientific Linux 6.5-64bit ( fedora 4 to 11) and 19/20 on KVM
My Celestia Downloads

h t t p ://celestiamotherlode.net/catalog/show_creator_details.php?creator_id=10
Reply With Quote
  #12  
Old 25th March 2011, 04:03 PM
Interax Offline
Registered User
 
Join Date: Mar 2011
Posts: 6
linuxfedorafirefox
Re: No non-root sound in Fedora 14

Thanks to both of you for your replies and for trying to help.
smr54 Thanks for the links. I tried:
when I was trying to get pulse to work, but nothing there helped at all, and I eventually removed pulse completely, giving some success.
JohnVV you wrote:
Quote:
fedora has been using pulse audio since fedora 8
pulse audio overrides alsa and oss as the system default
Perhaps this is where the answer to the problem lies. Maybe the system is still thinking that pulse is the default sound server. Perhaps this is why System/Preferences/Sound just hangs, "waiting for sound system to respond."
How do I set the system default to alsa now that pulse has been removed?
To recap:- the minor problem that I have is that the second user on this multi-user system has to reboot and then login to be able to control the sound devices. The first user's control of them is not relinquished as they should be when the first user logs out. Obviously a complete reboot wastes time, as a logout/login is a much quicker process.
I tried adding the following code to /etc/gdm/PostSession/Default:
Code:
/etc/init.d/haldaemon stop
pkill hald
sleep 1
Then adding this to /etc/gdm/PreSession/Default:
Code:
/usr/sbin/hald
-
-
daemon=no --verbose=yes
but either these files are being ignored on login, or I am on the wrong lines here thinking that a restart of the haldaemon will solve the permissions problem.
Am I on the wrong lines here?
Should I try stopping and restarting another process instead? Which process?
Reply With Quote
Reply

Tags
fedora, nonroot, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 9 no login sound for non root users hobz Using Fedora 0 18th June 2009 05:00 AM
Sound only for root kromberg Using Fedora 3 5th May 2009 07:15 PM
Another FC4 Sound Problem Fix: No alsa sound as root JayTee Hardware & Laptops 6 29th August 2005 06:32 PM


Current GMT-time: 20:16 (Saturday, 20-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Napoli (centro Storico) - Chiang Mai Railway Station Instagram Photos - Samila Beach Songkla - Winterswijk (Niederlande) Photos - Diva Espresso Photos