Fedora Linux Support Community & Resources Center
  #16  
Old 22nd May 2011, 11:11 PM
ChrisTomalty Offline
Registered User
 
Join Date: May 2011
Posts: 3
linuxchrome
Re: Broadcom STA driver in FC15

Thanks for the response. I tried that, but it didn't see the package.

However, I switched from 64 bit to 32 bit (I guess I probably should have mentioned that >.<) and the earlier instructions worked fantastically.
  #17  
Old 23rd May 2011, 12:20 AM
EsteBandido2010 Offline
Registered User
 
Join Date: May 2011
Posts: 9
linuxfirefox
Re: Broadcom STA driver in FC15

@GoingEasy9:
THANKYOU... installing kernel-PAE-devel was solved and now detected my modem with Wireless card. Please, receive a big hug and for Stoat admin too.
  #18  
Old 23rd May 2011, 08:05 PM
Yasawas Offline
Registered User
 
Join Date: May 2011
Location: Scotland
Posts: 3
linuxfirefox
Re: Broadcom STA driver in FC15

Hello

Another Ubuntu refugee here, struggling to get a 4312 to work. It's been infuriating me since I tried the alpha weeks ago and decided I wanted to move to Fedora and I've tried a bunch of guides and posts I've found around the net but my problems seem a bit more unique.

From a fresh install clicking NetworkManager gives me the classic "Unavailable (firmware not loaded)" or whatever it says. So I dive into Stoat's excellent guide and set about installing the STA driver that I've always used faultlessly in Ubuntu:

1) sudo yum install akmod-wl seems to install fine (I get a kernel mismatch message if I try the kmod one) but upon rebooting NetworkManager doesn't seem to see my wireless card at all ie the (Firmware not loaded) message I was getting before this does not even appear. It only seems to see a wired connection. lspci shows it definitely sees it, but NetworkManager doesn't seem to.

2) Tried the b43 out of interest as it has worked in Pardus and Sabayon for me. Again seems to install OK, again NetworkManager denies any knowledge of a wireless card on reboot.

modprobe wl gives "FATAL: Module wl not found" which seems bad.

lsmod sort doesn't mention b43 or broadcom-wl anywhere, which also seems bad.

I don't know what else to do. It's probably something simple but having used Ubuntu for three years I've never had to worry about this too much as it makes it really easy. Any ideas gratefully received, I love what I've seen of this distro so far and it's maddening to be denied it because of a horrible wireless card.
  #19  
Old 24th May 2011, 02:23 AM
stoat Offline
Registered User
 
Join Date: Jun 2006
Posts: 7,550
windows_xp_2003ie
Re: Broadcom STA driver in FC15

Quote:
Originally Posted by Yasawas

1) sudo yum install akmod-wl seems to install fine (I get a kernel mismatch message if I try the kmod one) but upon rebooting NetworkManager doesn't seem to see my wireless card at all...
I would study the kmod packages and kernels (just to be sure the akmod is doing what is expected)...
Code:
rpm -qa | grep -e kernel -e kmod-wl -e broadcom-wl | sort
uname -r
Quote:
Originally Posted by Yasawas

2) Tried the b43 out of interest as it has worked in Pardus and Sabayon for me. Again seems to install OK, again NetworkManager denies any knowledge of a wireless card on reboot.
Often, BCM4312 works with b43. But if broadcom-wl was still around, it may have blacklisted the b43 module.
Code:
su
cat /etc/modprobe.d/blacklist.conf
 

Tags
broadcom, driver, fc15, sta

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom driver pmorg Installation, Upgrades and Live Media 2 7th December 2009 10:02 AM
broadcom 440x 10/100 driver for FC6 freshmeat EOL (End Of Life) Versions 0 16th November 2006 08:38 AM
Installing a Broadcom Driver... tsgc Hardware & Laptops 0 12th February 2005 01:42 AM


Current GMT-time: 10:42 (Monday, 22-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Bistro 100 Maneiras - Sucre Travel Photos on Instagram - SFU Applied Science Building Photos on Instagram - Disneyland, Paris Instagram Photos