Fedora Linux Support Community & Resources Center
Prev Previous Post   Next Post Next
  #1  
Old 28th December 2011, 11:21 AM
Loivia Offline
Registered User
 
Join Date: Dec 2011
Location: Varberg, Sweden
Posts: 3
linuxfirefox
Question Jack Driver is not running (long)

Hi,

I have a problem getting sound out of Rosegarden on Fedora 15. I searched this forum and googled and found many similar problems, the most similar on Ubuntu and unanswered. I have tried solutions to other similar error messages without success.

Starting jackd from command line, I have also tried hw:0 instead of hw:SB: (3 last lines appears first after starting Rosegarden)
jd@leviticus:~$ jackd -d alsa hw:SB
jackdmp 1.9.7
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2011 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 20
control device hw:0
control device hw:0
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
JackProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Driver is not running
Cannot create new client

Starting with qjackctl gives first the following messages:
12:13:30.981 Patchbay deactivated.
12:13:30.988 Statistics reset.
12:13:30.993 ALSA connection change.
Cannot connect to server socket err = Förbindelse vägras
Cannot connect to server socket
jack server is not running or cannot be started
12:13:31.005 ALSA connection graph change.

Then after clicking start in the controls:
12:14:19.333 JACK is starting...
12:14:19.333 /usr/bin/jackd -r -dalsa -dhw:SB -r48000 -p1024 -n2
Cannot connect to server socket err = Förbindelse vägras
Cannot connect to server socket
jack server is not running or cannot be started
no message buffer overruns
no message buffer overruns
12:14:19.408 JACK was started with PID=4015.
jackdmp 1.9.7
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2011 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in non-realtime mode
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:SB|hw:SB|1024|2|48000|0|0|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
12:14:26.470 Could not connect to JACK server as client. - Overall operation failed. - Server communication error. Please check the messages window for more info.
JackProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Driver is not running
JackSocketClientChannel read fail
Cannot create new client
Cannot open qjackctl client
12:14:49.644 JACK is stopping...
jack main caught signal 15

And a popup window with the text
Could not connect to JACK server as client.
- Overall operation failed.
- Server communication error.
Please check the messages window for more info.

My cards: (the last one seems not to be connected to something, maybe it is on the graphic card?)
jd@leviticus:~$ sudo cat /proc/asound/cards
[sudo] password for jd:
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xfcdf4000 irq 16
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfe97c000 irq 19
Reply With Quote
 

Tags
driver, jack, long, running

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how long have you had your desktop fedora core running before you need to restart? stephanie.steve Fedora Focus 16 5th December 2007 08:31 PM
RoseGarden revisited-No jack server running oswestryrambler Using Fedora 9 18th May 2007 08:36 PM


Current GMT-time: 04:37 (Wednesday, 03-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin Copyright 2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat