Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 28th December 2011, 06:05 AM
leadgolem Offline
Registered User
 
Join Date: Apr 2005
Location: Littleton, CO
Age: 29
Posts: 2,857
linuxfirefox
Wine update to 1.3.33 results in audio loss

Audio in wine was working just fine until I updated to 1.3.33. Then I got the following errors over and over again in the command line.
Code:
err:mmdevapi:DllGetClassObject Driver initialization failed
err:ole:apartment_getclassobject DllGetClassObject returned error 0x80004005
err:ole:CoGetClassObject no class object {bcde0395-e52f-467c-8e3d-c4579291692e} could be created for context 0x1
err:dsound:devenum_thread_proc CoCreateInstance failed: 80004005
err:quartz:DSoundRender_create Cannot create Direct Sound object (80070057)
fixme:ole:CoCreateInstance no instance created for interface {56a86895-0ad4-11ce-b03a-0020af0ba770} of class {79376820-07d0-11cf-a24d-0020afd79767}, hres is 0x80070057
After trying lots of solutions from older wine versions, mostly involving making sure that various libraries and packages are installed, I finally had to come to the conclusion that some update to wine broke compatibility with pulse completely. Before anyone asks, yes I have wine-pulseaudio installed.

The solution for me was to tell wine to use alsa instead.

First, make sure wine-alsa is installed.
Code:
su
yum install wine-alsa
To tell wine to use alsa instead of pulse:
1. Open Regedit
2. Go to HKEY_CURRENT_USER/software/wine/drivers
3. Edit the Audio key so the value of the key is alsa, instead of pulse.

When you run a wine app, you will get audio errors. I haven't had any of them actually cause any problems though. IE: Audio still plays and is synchronous with game events.

II don't like this solution, as I can't have other audio playing in the background while playing games anymore. Hence I'll be switching back once the wine packages have updated again, provided the sound works again.
__________________
S.C.O.U.R.G.E. Heroes of lesser renown, contributor.
Reply With Quote
  #2  
Old 5th January 2012, 03:41 AM
leadgolem Offline
Registered User
 
Join Date: Apr 2005
Location: Littleton, CO
Age: 29
Posts: 2,857
linuxfirefox
Re: Wine update to 1.3.33 results in audio loss

Updating to 1.3.35-1 and setting all 4 of the drop downs in the audio tab to system default allows playing audio from multiple programs at the same time. Audio output still set to alsa in regedit.
__________________
S.C.O.U.R.G.E. Heroes of lesser renown, contributor.
Reply With Quote
Reply

Tags
alsa, audio, morrowind, pulseaudio, wine

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to Update / Power Loss During Update ivinod Using Fedora 11 3rd October 2010 04:38 PM
wine and pulse audio Dors Using Fedora 1 24th September 2008 05:47 PM
Wine / Cakewalk Pro Audio 9 HMSS013 Using Fedora 0 18th April 2007 08:48 PM
Loss of sound function after fedora 2 update PolishSausage Hardware & Laptops 2 8th February 2005 05:52 AM


Current GMT-time: 09:13 (Wednesday, 23-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat