Fedora Linux Support Community & Resources Center
  #1  
Old 7th December 2011, 10:25 PM
Grayhawk Offline
Registered User
 
Join Date: Dec 2011
Location: Live in the Great White North called Canada
Posts: 4
windows_xp_2003firefox
Samba Server

I have installed a Samba server in our office using Fedora 15 on a desktop box. The problem I am having is that during the night it goes into a suspended mode and drops the wireless network connection.

1 How do I keep this server up and running 24/7 with no suspend or hibernate taking place?
This server needs to be up and accessible at all times. I come in the screen is blank and no matter the keys pressed it requires using the reset button to reboot which is totally unacceptable.

2 How do I keep it from dropping the network connection.

The only option for me right now is to write a silly script and run it during the night periodically using the job scheduling to keep the machine busy during the night and on the weekends. Any and all thoughts would be helpful. Thanks in advance.
Reply With Quote
  #2  
Old 8th December 2011, 10:30 AM
marriedto51 Offline
Registered User
 
Join Date: Jul 2009
Location: England, UK
Posts: 912
linuxfirefox
Re: Samba Server

I suspect you are seeing the result of some power management process.

I use KDE, and can configure things like after how long (if at all) the system suspends, or turns off the monitor from System Settings -> Power Management.

There must be an equivalent for Gnome, but I don't personally know what it is. Try having a play with the settings?
Reply With Quote
  #3  
Old 8th December 2011, 06:32 PM
Grayhawk Offline
Registered User
 
Join Date: Dec 2011
Location: Live in the Great White North called Canada
Posts: 4
windows_xp_2003firefox
Re: Samba Server

I do use KDE and have looked at the power management in the system settings but it is for laptops not a desktop. I have no batteries or ac adapters on this box. So I don't see how I could use this to control anything on my desktop.

---------- Post added at 01:32 PM ---------- Previous post was at 01:21 PM ----------

I did come across the following for Fedora 14 which I now have implemented on my f15 server. Don't know yet if it works.
Create a new file in /etc instead:
Code:
# vi /etc/polkit-1/localauthority/50-local.d/50-disable-suspend.pkla
And copy the following text into that file:
Code:
[Disable Suspend]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate;org.freede sktop.upower.suspend
ResultAny=no
ResultInactive=no
ResultActive=no
Reply With Quote
  #4  
Old 9th December 2011, 09:49 AM
marriedto51 Offline
Registered User
 
Join Date: Jul 2009
Location: England, UK
Posts: 912
linuxfirefox
Re: Samba Server

I don't know about the fix you found, but I do think that the Power Management settings apply equally to desktops and to laptops.

However, it does occur to me that the KDE power management only takes effect if you are logged in. To configure the settings for when you are logged in ...

Having opened the Power Management settings module, you should see two tabs on the left: "Global settings" and "Power Profiles". Under "Global settings", you should see that most of the options are greyed out; you should probably see "When AC adaptor is plugged in: Performance" as the only available choice.

Now switch to "Power Profiles", and click "Performance" in the middle list. Here you can configure whether or not to suspend (and after how long).

If the system is being left idle with no user logged in, then I don't know what would cause it to suspend. I've not seen that happen with Fedora 14 on either a desktop or laptop. (But then perhaps I've just not waited long enough!)

Hope you can get it sorted.
Reply With Quote
  #5  
Old 9th December 2011, 03:56 PM
lightman47 Online
Registered User
 
Join Date: Apr 2009
Location: central NY, USA
Posts: 610
linuxchrome
Re: Samba Server

Hmm - wonder if you can disable Suspend in the BIOS?? I don't know - haven't been in there in forever and can't right now.
Reply With Quote
  #6  
Old 9th December 2011, 08:32 PM
Grayhawk Offline
Registered User
 
Join Date: Dec 2011
Location: Live in the Great White North called Canada
Posts: 4
windows_xp_2003firefox
Re: Samba Server

Quote:
Originally Posted by marriedto51 View Post
I don't know about the fix you found, but I do think that the Power Management settings apply equally to desktops and to laptops.

However, it does occur to me that the KDE power management only takes effect if you are logged in. To configure the settings for when you are logged in ...

Having opened the Power Management settings module, you should see two tabs on the left: "Global settings" and "Power Profiles". Under "Global settings", you should see that most of the options are greyed out; you should probably see "When AC adaptor is plugged in: Performance" as the only available choice.

Now switch to "Power Profiles", and click "Performance" in the middle list. Here you can configure whether or not to suspend (and after how long).

If the system is being left idle with no user logged in, then I don't know what would cause it to suspend. I've not seen that happen with Fedora 14 on either a desktop or laptop. (But then perhaps I've just not waited long enough!)

Hope you can get it sorted.
Thanks for your help. It seems that script that I wrote did the trick but I did have the root account logged in overnight and a screen saver running. On the weekend I will leave the system up but not logged in and see where things stand Monday a.m. I will post the result. If it did not work then I will play with the power management option.
Reply With Quote
  #7  
Old 6th January 2012, 08:21 PM
Grayhawk Offline
Registered User
 
Join Date: Dec 2011
Location: Live in the Great White North called Canada
Posts: 4
windows_xp_2003firefox
Re: Samba Server

Quote:
Originally Posted by Grayhawk View Post
Thanks for your help. It seems that script that I wrote did the trick but I did have the root account logged in overnight and a screen saver running. On the weekend I will leave the system up but not logged in and see where things stand Monday a.m. I will post the result. If it did not work then I will play with the power management option.
All is right as rain. The script seems to work and I also hard wired the system now. Now it stays up all the time and can be accessed anytime.
Reply With Quote
Reply

Tags
samba, server

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba shares available only after OKing them in Samba server config tool gizenshu Servers & Networking 1 1st October 2010 06:08 PM
@ samba server bond Installation, Upgrades and Live Media 1 31st October 2008 07:53 AM
Samba Server... cyclopz Servers & Networking 5 21st November 2006 09:22 PM
Samba and FTP server on FC4 simplicity Servers & Networking 3 19th January 2006 10:39 AM


Current GMT-time: 18:58 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Hoyerswerda Instagram Photos - Sleaford Photos - Talagang