Fedora Linux Support Community & Resources Center
  #1  
Old 25th January 2012, 04:11 AM
persephone Offline
Registered User
 
Join Date: Jan 2012
Location: Portland
Posts: 2
windows_7chrome
Login Timeout, Root Disabled

How do I extend the time until my session times out and I have to log back in (due to inactivity) ?
I have just installed Fedora 11 on a slow computer, and can't even go through updates because my session times out before dependencies are resolved or whatever other task, I have to keep watching it and touching it otherwise it times out - and resets everything it's been doing.
There is no security concern - no other creatures around - I can't even log in as root (it seems that root is disabled ? Is there any way to re-enable it in Gnome ? Other than changing to runlevel 1).
Reply With Quote
  #2  
Old 25th January 2012, 08:11 AM
qualicum Offline
Registered User
 
Join Date: Jan 2012
Location: bc, canada
Posts: 3
linuxubuntufirefox
Re: Login Timeout, Root Disabled

The whole article is at:
http://www.faqs.org/docs/securing/chap5sec32.html
The section you need is;
Set login time out for the root account. Despite the notice to never, if they are not on the server sign in as root and leave it unattended, administrators still stay on as root or forget to logout after finishing their work and leave their terminals unattended. The answer to solve this problem is to make the bash shell automatically logout after not being used for a period of time. To do that, you must set the special variable of Linux named TMOUT to the time in seconds of no input before logout. Edit your profile file /etc/profile and add the following line somewhere after the line that read HISTFILESIZE= on this file:

TMOUT=7200
...if you remark this "timeout" from your /etc/profile file, then it should not close the session. The way to do that is to put a '#' or hash mark in front of it thus;
# TMOUT=7200
although the number is much lower in your file, this one is equivalent to 7200 seconds, or 120x60sec=2 hours.
To edit /etc/profile, you need to be root, open a terminal window, type su -<enter>
enter your admin password, and then type gedit /etc/profile
If you do not log in as root to do the edit, you will not be able to save any changes to the file.
Alternately, if that time out line is not there, add it in, and make it ...say...
TMOUT=28800
which will give you 8 hours before it closes on you.
Reply With Quote
  #3  
Old 25th January 2012, 11:28 AM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Login Timeout, Root Disabled

Moved to EOL (End Of Life) Versions
Reply With Quote
Reply

Tags
disabled, login, root, timeout

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SYSERR(root): collect: read timeout on connection from abcdefgh Servers & Networking 0 16th March 2008 09:48 PM
Graphical Login disabled phane Using Fedora 10 28th August 2007 05:36 AM
Synaptics touchpad disabled at login WebRuss Hardware & Laptops 0 23rd September 2006 03:11 PM
Setting a timeout for root lancherider Security and Privacy 3 17th January 2006 02:35 PM
[New Feature Login Timeout] Why oh why must I log in every minute??? t3gah Suggestions & Feedback 4 18th March 2005 08:16 PM


Current GMT-time: 03:50 (Saturday, 20-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Creek Side - Stockholm-Arlanda Airport (ARN) Travel Photos on Instagram - Marina of Koper Travel Photos - Te Whiti Park Instagram Photos - Texas State Fair Photos on Instagram