Fedora Linux Support Community & Resources Center
  #1  
Old 4th March 2012, 11:33 PM
jakebpg Offline
Registered User
 
Join Date: Feb 2009
Location: Northeast
Posts: 292
linuxfirefox
Cannot open font file True

Installed the alpha release (from get Fedora page)on my old laptop in the hopes the display problems would be fixed from F16, they haven't!

But I get the error that the system can not open font file True, Now I'm thinking it means true fonts file. This is at boot.

Anyone else get this error on F17 Alpha? Also it is the RC5 kernel release.

Hardware is a Toshiba A75 S2112 with 2GB of memory, 3.7GB Intel processor and an ATI Radeon Mobility 9100IGP video card!

The graphics are terrible when desktop effects are enabled but the error with the fonts is what I'm wondering about, but if anyone can assist in getting the graphics working I'd appreciate that to.

Thanks in advance!

And should I fill out a bug report for this and for the graphics also?

Last edited by jakebpg; 5th March 2012 at 12:13 AM.
Reply With Quote
  #2  
Old 5th March 2012, 06:58 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,334
linuxfirefox
Re: Cannot open font file True

That error is because it can not find the file named "True" that is specified on the kernel line in the SYSFONT=TRUE parameter that is on the alpha releases.

I changed mine back to load the latarcyrheb-sun16 font like previous releases did.

What I did...

modified /etc/default/grub

replaced SYSFONT=True with SYSFONT=latarcyrheb-sun16 on GRUB_CMDLINE_LINUX= line

Then run:

grub2-mkconfig -o /boot/grub2/grub.cfg

There is already a bug filed on this issue, but you can add to it if you wish.

https://bugzilla.redhat.com/show_bug.cgi?id=799401
Reply With Quote
  #3  
Old 13th May 2012, 12:08 PM
tuxor Offline
Registered User
 
Join Date: Mar 2011
Posts: 179
linuxfirefox
Re: Cannot open font file True

What's the best way to fix this?

I can replace "True" with "latarcyrheb-sun16". Of course, that works great.

But I can also remove the whole "SYSFONT=True" parameter from the boot cmdline and remove the respective line from my /etc/sysconfig/i18n file. Works as well - same result!

But I'm not sure whether some day there will be a problem, because that variable is not set?! Is SYSFONT really entirely dispensable?
__________________
Fedora on Lenovo ThinkPad T400s
Reply With Quote
  #4  
Old 13th May 2012, 04:54 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,334
linuxfirefox
Re: Cannot open font file True

According to the bug report, it's an anaconda bug which can't be fixed on an installed system, so th efix is to manually change it yourself.

Quote:
Just manually change True every place it is used as a font name in the
following 3 files:

/boot/grub2/grub.cfg
/etc/sysconfig/i18n
/etc/default/grub

Typically it was latarcyrheb-sun16 on most systems.

You could use latarcyrheb-sun32 if you want a bigger font for boot messages
and in console screens.
sysfont probably has a default font it uses if not specified, so you probably could do without the sysfont parameter without any problems.

Edit:
Link to bug report:
https://bugzilla.redhat.com/show_bug.cgi?id=799401
Reply With Quote
  #5  
Old 13th May 2012, 06:42 PM
smr54 Offline
Registered User
 
Join Date: Jan 2010
Posts: 5,542
linuxchrome
Re: Cannot open font file True

I've removed (when I thought this was causing a hang--turned out to be something else), the entire sysfont part without issue.

No guarantees that it won't come back and bite later on, but so far, it's been fine.

I've found, through the years, that most of the time, all grub needs--haven't really tested this with grub2 though--is where the vmlinuz and initrd files are. All the rest seems to be enhancement and can often be removed without causing any problems.
Reply With Quote
  #6  
Old 13th May 2012, 06:52 PM
tuxor Offline
Registered User
 
Join Date: Mar 2011
Posts: 179
linuxfirefox
Re: Cannot open font file True

Don't worry, it won't "come back" unless you reinstall F17. You can inspect the respective Anaconda source code here: http://git.fedorahosted.org/git/?p=a...e1eb50d7e7fd0e There's no doubt that SYSFONT=True is caused by Anaconda and nothing else. Unfortunately that's also the reason why it can't be fixed once F17 has been installed.
__________________
Fedora on Lenovo ThinkPad T400s
Reply With Quote
Reply

Tags
file, font, open, true

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
best true-type font rendering in Fedora danilo2 Using Fedora 0 19th January 2010 04:25 PM
Installation of true type font 'Helvetica' foez Installation, Upgrades and Live Media 2 31st January 2009 11:29 AM
How to install Windows vista true type font yinglcs Using Fedora 1 13th January 2007 07:43 PM
Where is true freetype-font-dir on Fedora core 5? endeavor Using Fedora 1 5th May 2006 07:07 AM


Current GMT-time: 10:01 (Wednesday, 26-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Candelaria Travel Photos on Instagram - Atwater - Shikarpur Instagram Photos