Fedora Linux Support Community & Resources Center
  #1  
Old 26th March 2012, 06:39 PM
hadrons123 Online
'The Blue Dragon'
 
Join Date: Jan 2011
Location: Pitt,PA
Posts: 1,260
linuxfirefox
button layout not working!

F17 gnome button layout doesn't work the way i try to set

Quote:
gconftool-2 -s -t string /desktop/gnome/shell/windows/button_layout "close:"
I don't know why?
__________________
LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD
Reply With Quote
  #2  
Old 27th March 2012, 01:13 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: button layout not working!

try "menu:minimize,maximize,close"

You have close on the wrong side of the colon. That would try to put the close box in the upper left corner of your windows.

You are actually better off using gsettings rather than gconftool-2 though..

gsettings set org.gnome.desktop.wm.preferences button-layout 'close:'

gsettings set org.gnome.desktop.wm.preferences button-layout 'menu:minimize,maximize,close'

Last edited by DBelton; 27th March 2012 at 01:17 AM.
Reply With Quote
  #3  
Old 27th March 2012, 02:07 AM
hadrons123 Online
'The Blue Dragon'
 
Join Date: Jan 2011
Location: Pitt,PA
Posts: 1,260
linuxfirefox
Re: button layout not working!

No joy.

I wanted it on the left side.

It doesn't respect the settings , Dont know why.
__________________
LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD
Reply With Quote
  #4  
Old 27th March 2012, 02:10 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: button layout not working!

did you try using gsettings instead of gconftool-2? I haven't tried putting the close box on the left, but I get the other buttons working.

It should work putting the close box on the left, I just haven't tried it here.[COLOR="Silver"]

Edit:

If you use the gconftool-2 you will have to restart gnome shell, and also make sure that gsettings-data-convert is being run when Gnome starts. That is what takes the gconf settings and converts them to the newer dconf.
Reply With Quote
  #5  
Old 27th March 2012, 02:14 AM
hadrons123 Online
'The Blue Dragon'
 
Join Date: Jan 2011
Location: Pitt,PA
Posts: 1,260
linuxfirefox
Re: button layout not working!

I tried it, logged out and logged in . no joy.
__________________
LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD
Reply With Quote
  #6  
Old 27th March 2012, 02:19 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: button layout not working!

looking at things.. it looks like the key name has changed...

try setting org.gnome-shell.overrides button-layout using gsettings.
Reply With Quote
  #7  
Old 27th March 2012, 08:30 AM
hadrons123 Online
'The Blue Dragon'
 
Join Date: Jan 2011
Location: Pitt,PA
Posts: 1,260
linuxfirefox
Re: button layout not working!

I searched for overrides. But don't really know how it works.

edit:
Ok. I found it and set the key too. but still no change.
__________________
LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD

Last edited by hadrons123; 27th March 2012 at 08:52 AM.
Reply With Quote
  #8  
Old 27th March 2012, 02:20 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: button layout not working!

what value does that key have in it if you run dconf-editor or even gsettings?

Code:
[Me@tower20 ~]$ gsettings list-recursively org.gnome.shell.overrides
org.gnome.shell.overrides attach-modal-dialogs true
org.gnome.shell.overrides button-layout 'menu:minimize,maximize,close'
org.gnome.shell.overrides dynamic-workspaces true
org.gnome.shell.overrides edge-tiling true
org.gnome.shell.overrides workspaces-only-on-primary true
The standard arrangement works here. I will try settings the close button on the left and see what happens.

Edit:

It did work here to set the close box to the left of the title bar.
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2012-03-27 08:21:54.png
Views:	128
Size:	76.1 KB
ID:	22899  

Last edited by DBelton; 27th March 2012 at 02:23 PM.
Reply With Quote
  #9  
Old 27th March 2012, 05:11 PM
hadrons123 Online
'The Blue Dragon'
 
Join Date: Jan 2011
Location: Pitt,PA
Posts: 1,260
linuxfirefox
Re: button layout not working!

Quote:
[candice@f17 ~]$ gsettings list-recursively org.gnome.shell.overrides
org.gnome.shell.overrides attach-modal-dialogs true
org.gnome.shell.overrides button-layout ':close'
org.gnome.shell.overrides dynamic-workspaces true
org.gnome.shell.overrides edge-tiling true
org.gnome.shell.overrides workspaces-only-on-primary true
[candice@f17 ~]$ gsettings set org.gnome.shell.overrides button-layout "close"
[candice@f17 ~]$

Now it works.
thanks a lot Dbelton!
__________________
LENOVO Y580 FHD Intel® Core™ i7-3630QM CPU @ 2.40GHz × 8 |660M GTX NVIDIA | 16 GB SSD
Reply With Quote
Reply

Tags
button, layout, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rebind laptop button or other keyboard layout? slavadev Hardware & Laptops 1 14th October 2009 10:03 PM
F11 KDE: Keyboard layout switching stopped working illich Using Fedora 0 30th June 2009 09:18 AM
FC5 Keyboard layout not completely working gertdesmet Using Fedora 3 27th March 2006 05:55 PM


Current GMT-time: 12:01 (Friday, 24-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Gameleira Travel Photos on Instagram - Gobernador Ingeniero Valentin Virasoro - Bafra