Fedora Linux Support Community & Resources Center
  #1  
Old 9th April 2012, 03:23 AM
ghborrmann Offline
Registered User
 
Join Date: Nov 2008
Posts: 33
linuxfirefox
Allowing User Mount of Ntfs

I have attempted to permit user mounting of an ntfs partition with the following entry in fstab:

/dev/sda3 /mnt/winc ntfs noauto,users,defaults 0 0

This works when logged in as root, but not otherwise. When a user attempts to mount /mnt/winc,
there is no error message or any other indication that it did not work. What's going wrong?
Reply With Quote
  #2  
Old 9th April 2012, 03:31 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,000
linuxfirefox
Re: Allowing User Mount of Ntfs

I think the problem is that your mount options list: noauto,users,defaults
is applied in list order, so "defaults" which is -> rw, suid, dev, exec, auto, nouser, async
resets your 'users' and 'noauto' back to 'nouser' and 'auto'

So to fix this, change the option list order so 'defaults' comes before noauto and users:
Quote:
/dev/sda3 /mnt/winc ntfs defaults,noauto,users 0 0
Reply With Quote
  #3  
Old 9th April 2012, 04:00 AM
ghborrmann Offline
Registered User
 
Join Date: Nov 2008
Posts: 33
linuxfirefox
Re: Allowing User Mount of Ntfs

Quote:
So to fix this, change the option list order so 'defaults' comes before noauto and users:
No difference. I also have another entry for a flash drive:

/dev/flash /mnt/flash vfat noauto,users,ro,defaults 0 0

which works perfectly.
Reply With Quote
  #4  
Old 9th April 2012, 04:07 AM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: Allowing User Mount of Ntfs

I just mount it for all users to use in my fstab here.

here is what I use:
Code:
UUID=4EAE6CB6AE6C986B   /mnt/Drive_C   ntfs-3g defaults,locale=en_US.utf8,comment=systemd.automount   0   0
Reply With Quote
  #5  
Old 9th April 2012, 04:19 AM
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 6,000
linuxfirefox
Re: Allowing User Mount of Ntfs

Quote:
Originally Posted by ghborrmann View Post
No difference. I also have another entry for a flash drive:

/dev/flash /mnt/flash vfat noauto,users,ro,defaults 0 0

which works perfectly.
Hmm, we'll ok, I was just getting the order information from the "man mount" (bold)
which seems to suggest that the order of the options matters:
Quote:
user Allow an ordinary user to mount the filesystem. The name of the mounting
user is written to mtab so that he can unmount the filesystem again. This
option implies the options noexec, nosuid, and nodev (unless overrid‐
den by subsequent options, as in the option line user,exec,dev,suid)
.
Reply With Quote
  #6  
Old 9th April 2012, 08:54 AM
fonya Offline
Registered User
 
Join Date: Mar 2006
Location: Hungary
Age: 37
Posts: 59
linuxfirefox
Re: Allowing User Mount of Ntfs

I have the almost same thing with nfs v3, I can mount, but not umount the remote fs.
My fstab:
Code:
192.168.41.1:/home/ftp/pub /mnt/ftp nfs defaults,noexec,nodev,nosuid,rw,hard,intr,rsize=4096,wsize=4096,vers=3,mountvers=3,nfsvers=3,user,noauto,_netdev 0 0
When umount, it say:
Code:
umount: /mnt/ftp mount disagrees with the fstab
With this options, it works from RH6.2 to Fedora14 nicely.
__________________
Fonya
Reply With Quote
Reply

Tags
allowing, mount, ntfs, user

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help editing fstab file to mount ntfs volumes rw for user account jspaceman Installation, Upgrades and Live Media 13 30th March 2009 08:31 PM
mount.ntfs takes up loads of CPU while accessing NTFS partitions coolpcguy Using Fedora 1 8th December 2008 11:46 AM
How to set context allowing user to modify /var/www lvona Security and Privacy 4 24th November 2006 07:44 AM
How can I mount external usb disk with ntfs to be readable by user? Stone Dragon Using Fedora 8 4th August 2006 09:43 PM
Allowing user access of shutdown command Hououtate Using Fedora 3 4th April 2006 12:08 AM


Current GMT-time: 19:36 (Thursday, 31-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat