Fedora Linux Support Community & Resources Center
  #1  
Old 13th January 2012, 07:31 PM
sinnud Offline
Registered User
 
Join Date: Jun 2005
Posts: 11
windows_7firefox
no sound in fedora core 16

It looks an old problem from fedora 13/14...

The output of aplay -l have:
Code:
aplay: device_list:240: no soundcards found...
The output of lspci have:
Code:
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
The output of lspci -v have:
Code:
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
        Subsystem: Dell Device 04f5
        Flags: bus master, fast devsel, latency 0, IRQ 41
        Memory at 91a30000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd-hda-intel
My system (uname -a) is:
Code:
Linux ******** 3.1.7-1.fc16.i686 #1 SMP Tue Jan 3 20:26:58 UTC 2012 i686 i686 i386 GNU/Linux
I have folder /sys/class/sound/card0/ but only have sub folder of hwC0D2 and hwC0D3. It may should have hwC0D1...

Any suggestion is welcome.
Reply With Quote
  #2  
Old 16th April 2012, 08:15 PM
tomahola Offline
Registered User
 
Join Date: Oct 2007
Posts: 3
linuxfirefox
Re: no sound in fedora core 16

I just ran into the same problem.
Seems to be an access rights problem and unspecified default audio device, at least for me. Still working on the solution

Code:
#lspci -v
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
	Subsystem: Lenovo ThinkPad T60/R60 series
	Flags: bus master, fast devsel, latency 0, IRQ 48
	Memory at ee400000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [100] Virtual Channel
	Capabilities: [130] Root Complex Link
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd-hda-intel
#alsamixer
-works and allows me to control the mixer and listen to my microphone
but it works only as root and not using the default device but only when selecting card 0

As user:
Code:
$aplay -l
aplay: device_list:252: no soundcards found...
As root:
Code:
#aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Tom
Reply With Quote
  #3  
Old 17th April 2012, 06:35 AM
oldcpu Offline
Registered User
 
Join Date: Jan 2009
Location: Europe
Posts: 241
linuxfirefox
Re: no sound in fedora core 16

Sometimes when there are permission problems, by adding a regular user to group 'audio' will solve a permissions problem (one needs to logout/login of GNU/Linux after having done so). Having typed that, adding a user to group 'audio' should not be nominally necessary.
Reply With Quote
Reply

Tags
core, fedora, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Sound on Fedora Core 5 #77 Hardware & Laptops 0 24th July 2006 06:45 PM
Fedora Core 4 - No Sound rouble Using Fedora 1 15th December 2005 06:30 AM


Current GMT-time: 03:55 (Friday, 22-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat