Fedora Linux Support Community & Resources Center
  #1  
Old 26th April 2012, 04:17 AM
pawanmup Offline
Registered User
 
Join Date: Apr 2012
Location: India
Posts: 3
windows_xp_2003firefox
after kernel compilation reboot says mount : couldnot find filesystem '/dev/root'

I am trying to install a 2.6.34.11 kernel.

I just checked out fresh tar ball for linux-2.6.34.11.tar.bz2

and followed below steps for compilation

tar -xjvf linux-2.6.34.11.tar.bz2 -C /usr/src; cd /usr/src/linux-2.6.34.11
make menuconfig
make
make modules
make module_install
make install

after this I rebooted with the new image but it says

No volume groups found Volume group "VolGroup00" not found mount : couldnot find filesystem '/dev/root'

Can any1 please suggest me if I have missed any steps..

Here is my grub.conf details, and image for "(2.6.34.11)" is not booting properly as I mentioned

HTML Code:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
# splashimage=(hd0,0)/grub/splash.xpm.gz
serial --unit=0 --speed=115200
terminal --timeout=5 serial console
hiddenmenu
title Fedora (2.6.34.11)
        root (hd0,0)
        kernel /vmlinuz-2.6.34.11 ro root=/dev/VolGroup00/LogVol00 rhgb quiet maxcpus=1
        initrd /initrd-2.6.34.11.img

title Fedora (2.6.23-gcov)
        root (hd0,0)
        kernel /vmlinuz-2.6.23-gcov ro root=/dev/VolGroup00/LogVol00 rhgb quiet maxcpus=1
        initrd /initrd-2.6.23-gcov.img

title Fedora (2.6.23.1-42.fc8)
        root (hd0,0)
        kernel /vmlinuz-2.6.23.1-42.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet maxcpus=1
        initrd /initrd-2.6.23.1-42.fc8.img
/etc/fstab

HTML Code:
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap

Attaching the kernel config file used.
Attached Files
File Type: txt config.txt (95.1 KB, 132 views)
Reply With Quote
  #2  
Old 26th April 2012, 06:17 AM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
windows_xp_2003firefox
Re: after kernel compilation reboot says mount : couldnot find filesystem '/dev/root'

I would try recreating the initrd file with mkinitrd and see if that fixes it.

Boot to one of the older working kernels and backup the old file
su -
cd /boot
mv initrd-2.6.34.11.img initrd-2.6.34.11.old

Then make a new one:
mkinitrd initrd-2.6.34.11.img 2.6.34.11

Compare the lengths of the files:
ls -ld initrd*

Reboot and see what happens.
Reply With Quote
  #3  
Old 26th April 2012, 11:05 AM
pawanmup Offline
Registered User
 
Join Date: Apr 2012
Location: India
Posts: 3
windows_xp_2003firefox
Re: after kernel compilation reboot says mount : couldnot find filesystem '/dev/root'

Hi thank you for the reply,

I tried as below and it didn't work

HTML Code:
cd /boot
mv initrd-2.6.34.11.img initrd-2.6.34.11.old

Then make a new one:
mkinitrd initrd-2.6.34.11.img 2.6.34.11

reboot 
I also tried and made the change as "CONFIG_BLK_DEV_DM=y" for enabling "Device mapper support" and rebooted I am still seeing the same problem..
Reply With Quote
  #4  
Old 26th April 2012, 03:38 PM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
linuxfirefox
Re: after kernel compilation reboot says mount : couldnot find filesystem '/dev/root'

I noticed you didn't put "make oldconfig" in the list of things you did. The purpose of that is to reproduce the config from the older kernel and only have to answer the questions for the new features of the newer kernel.

I would try "lspci -knn" on the working config especially noting what driver is loaded for your disk interface.

Also look at "lsmod", that driver would likely appear in the last 8 or so modules listed (the first 8 that load).
Reply With Quote
  #5  
Old 26th April 2012, 03:51 PM
jpollard Online
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,866
linuxfirefox
Re: after kernel compilation reboot says mount : couldnot find filesystem '/dev/root'

The easiest way is to copy the config (for me that is /boot/config-.....fc??.x86_64, for your specific working kernel) file for the working system before doing "make menuconfig".

That way you only have to tweak options and/or accept new options in the "make menuconfig" step.
Reply With Quote
  #6  
Old 26th April 2012, 08:15 PM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
linuxfirefox
Re: after kernel compilation reboot says mount : couldnot find filesystem '/dev/root'

I noticed an fc8 in his kernel menu. I believe that was when the old IDE kernel driver was in use. He probably needs to use mkinitrd option preload the proper libata driver module and its depends.
Reply With Quote
  #7  
Old 26th April 2012, 09:51 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,917
linuxfirefox
Re: after kernel compilation reboot says mount : couldnot find filesystem '/dev/root'

Quote:
Originally Posted by JEO View Post
I noticed an fc8 in his kernel menu. I believe that was when the old IDE kernel driver was in use. He probably needs to use mkinitrd option preload the proper libata driver module and its depends.
I *think* that changed earlier around 2.6.19. If I'm wrong, then he has a lot more to do than just adding in preloads. The drive names and possibly the enumeration change too.

Udevd has certainly changes since 2.6.23 tho' the degree of backward compatibility is unknown to me. HAL gome of course.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #8  
Old 26th April 2012, 11:37 PM
JEO Offline
Registered User
 
Join Date: Jan 2006
Posts: 2,787
linuxfirefox
Re: after kernel compilation reboot says mount : couldnot find filesystem '/dev/root'

Yea I think you are right. The IDE to libata change was from FC6 to 7.
Reply With Quote
Reply

Tags
compilation, couldnot, filesystem, kernel, mount, or dev or root, reboot

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Unable to find a filesystem on /dev/root apechimp Using Fedora 0 18th June 2010 04:12 PM
mount could not find filesystem fuoms Using Fedora 4 29th July 2007 02:33 AM
FC6: "mount: could not find filesystem '/dev/root'" bthornton EOL (End Of Life) Versions 5 14th November 2006 06:40 PM


Current GMT-time: 02:46 (Saturday, 25-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Shizuishan Travel Photos - Komatipoort Photos on Instagram - Chateauroux Travel Photos on Instagram