Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (No Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (No Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #2116  
Old 26th April 2012, 05:13 AM
allknowingfrog Offline
Registered User
 
Join Date: Apr 2012
Location: U.S.
Posts: 1
linuxfirefox
Re: F16,F15 & F14 Nvidia driver guides

I've been using Fedora for about a year, so I know a little, but not a lot. This is my first time actually posting on the forums.

The set of updates from a few days ago broke my system. I tried to cheat and just reinstall. After a yum update and a reboot, I followed leigh's instructions for akmod. Another reboot, and I'm back to the original crash. I get to the end of the loadscreen, see the background for a few seconds, then get the "system cannot recover" message. I've run nvidia-xconfig, and nvidia shows up with lsmod.

Yellowman's link suggests that I shouldn't be using 295.40. How do I change that? Any help would be greatly appreciated.

Code:
abrt-addon-kerneloops-2.0.7-2.fc16.i686
akmod-nvidia-295.40-2.fc16.i686
kernel-3.1.0-7.fc16.i686
kernel-3.3.2-6.fc16.i686
kernel-devel-3.3.2-6.fc16.i686
kernel-headers-3.3.2-6.fc16.i686
kmod-nvidia-3.3.2-6.fc16.i686-295.40-2.fc16.i686
libreport-plugin-kerneloops-2.0.8-4.fc16.i686
nvidia-settings-1.0-16.fc16.i686
nvidia-xconfig-1.0-14.fc16.i686
xorg-x11-drv-nvidia-295.40-1.fc16.i686
xorg-x11-drv-nvidia-libs-295.40-1.fc16.i686
3.3.2-6.fc16.i686
nvidia              10958344  26 
i2c_core               28151  3 nvidia,i2c_nforce2,videodev
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.40  (mockbuild@)  Thu Apr 12 13:28:25 CEST 2012

# RPM Fusion - nvidia-xorg.conf
# 

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Videocard0"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection
  #2117  
Old 26th April 2012, 06:50 AM
VernDog Offline
Registered User
 
Join Date: Aug 2009
Posts: 312
linuxchrome
Re: F16,F15 & F14 Nvidia driver guides

I tried 295.20 and that didn't help at all. I think the problem is in the new xorg.
  #2118  
Old 26th April 2012, 06:51 PM
dehaseth Offline
Registered User
 
Join Date: Apr 2006
Location: Georgia, USA
Posts: 39
linuxfirefox
Re: F16,F15 & F14 Nvidia driver guides

Leigh,

These guides are great and I have been successful installing the nvidia drivers on several machines. This one is a bit of a problem with an external monitor.

Basic output:

$ rpm -qa *\nvidia\* *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
abrt-addon-kerneloops-2.0.7-2.fc16.x86_64

akmod-nvidia-295.40-2.fc16.x86_64
kernel-3.1.0-7.fc16.x86_64
kernel-3.3.2-6.fc16.x86_64
kernel-devel-3.3.2-6.fc16.x86_64
kernel-headers-3.3.2-6.fc16.x86_64
kmod-nvidia-3.3.2-6.fc16.x86_64-295.40-2.fc16.2.x86_64
libreport-plugin-kerneloops-2.0.8-4.fc16.x86_64
nvidia-settings-1.0-16.fc16.x86_64
nvidia-xconfig-1.0-14.fc16.x86_64
xorg-x11-drv-nvidia-295.40-1.fc16.x86_64
xorg-x11-drv-nvidia-libs-295.40-1.fc16.i686
xorg-x11-drv-nvidia-libs-295.40-1.fc16.x86_64
3.3.2-6.fc16.x86_64
nvidia 12319418 32
i2c_core 37991 3 nvidia,videodev,i2c_i801
# RPM Fusion - nvidia-xorg.conf
#
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

System: ThinkPad W701 with a NVIDIA Quadro FX 96-core CUDA parallel computing processor 1GB.
Intel Core i7-820QM Processor and 16 GB DDR3 RAM

Installed Fedora 16 with KDE on a new laptop drive (750 GB) is the only drive in the system. All updates have been loaded.

The nvidia drivers work great on the LCD (WUXGA). Everything works. When I put the system into a docking station the external monitor is not recognized. None of the ports is seen. Upon power on the inital grub boot info appears on the external monitor, but when it goes to the login screen the external monitor is blank. I can open the laptop and see the login screen. When I log in and go to System Settings the "Display and Monitor" shows only the LCD monitor.

Before I added the nvidia drivers it worked on the external monitor and the Display & Monitor in System Settings showed all the ports on the docking station.

I know nothing about xorg.conf, but it appears it is missing a lot.

Thanks.

Last edited by dehaseth; 27th April 2012 at 04:05 PM.
  #2119  
Old 28th April 2012, 11:15 PM
fabalexbar Offline
Registered User
 
Join Date: Nov 2010
Location: Colombia
Posts: 4
linuxfirefox
Re: problem with GeForce 6150SE nForce 430

Finally I was able to get my gnome-shell running a couple of days ago. After repeating the process again and again and getting the same results I tried something else, thinking that maybe the problem was in the packages' version:
  • Uninstall the kmodia and nvidia packages and correct the img files.
  • Restart using the kernel 3.1.0-7
  • Install the appropriate driver packages: kmod-nvidia-285.05.09 and xorg-x11-drv-nvidia-libs-285.05.09
    Code:
    yum install kmod-nvidia-285.05.09 xorg-x11-drv-nvidia-libs-285.05.09
  • Do everything else according to the guide.
And it worked!

Of course I have packages out of date and eventually I'll try some update to see if the problem it's solved. Also, I had to set the default kernel boot:
Code:
grub2-set-default 'Fedora Linux, with Linux 3.1.0-7.fc16.x86_64'
grub2-mkconfig -o /boot/grub2/grub.cfg
I hope this helps someone out there.
  #2120  
Old 29th April 2012, 05:45 PM
dehaseth Offline
Registered User
 
Join Date: Apr 2006
Location: Georgia, USA
Posts: 39
linuxfirefox
Re: problem with GeForce 6150SE nForce 430

Quote:
Originally Posted by fabalexbar View Post
Finally I was able to get my gnome-shell running a couple of days ago. After repeating the process again and again and getting the same results I tried something else, thinking that maybe the problem was in the packages' version.
Many thanks. This does explain a lot. I have been able to get another system, a T520 with an Optimus card, working. I had the set the UEFI display to integrated and disable the OS detection of the Optimus card. Then the standard drivers worked. That is, do not load the drivers as in this guide. Work will continue on the W701 and your suggestions will be tried. F17 will be out soon and it will be interesting to see how that works.

BTW, I am running a KDE desktop. I doubt it makes a difference...

Thanks again.
  #2121  
Old 7th May 2012, 04:42 AM
Thetargos Online
Registered User
 
Join Date: May 2004
Location: Mexico City, Mexico
Age: 37
Posts: 4,423
linuxfirefox
Re: F16,F15 & F14 Nvidia driver guides

Has anyone been successful at installing and following these instruction on an nVidia based MacBook Pro?

I don't seem able to avoid having KMS, as proved by the boot in single user mode where I can see, despite all my efforts, the console come up at native resolution, while using the nvidia driver... While text looks pretty, I am unalbe to start X (system hang), and I don't seem to be able to prevent this from happening. I boot Linux in an unconventional way, but it is still possible for me to parse commands to the kernel, however rdblacklist=nouveau and nouveau.modeset=0 does not seem to prevent this.

Plus lspci -vv states that the driver in use is nvidia, not nouveau. I'm using the latest RPMFusion available package (295.49).

Would 'nomodeset' be of some use still?
__________________
If ain't broken, don't fix it! :eek:
If can be improved, go for it! :cool:

FedoraForum Community forums lurker.
Fedora user since RHL 5.2 :cool:

Systems: Laptop, Main System, Netbook.
  #2122  
Old 10th May 2012, 01:55 AM
lordamus Offline
Registered User
 
Join Date: Apr 2007
Posts: 128
linuxchrome
Re: F16,F15 & F14 Nvidia driver guides

After some try to work with multiple displays and failed now my gnome 3 starting with fallback session and cant fix it. it was working without problem before the nvidia-settings...now cant use 3D

here is some info my selinux is disabled state any clue ??

Code:
abrt-addon-kerneloops-2.0.7-2.fc16.x86_64
akmod-nvidia-295.49-1.fc16.x86_64
kernel-3.3.2-6.fc16.x86_64
kernel-3.3.4-3.fc16.x86_64
kernel-devel-3.3.2-6.fc16.x86_64
kernel-devel-3.3.4-3.fc16.x86_64
kernel-headers-3.3.4-3.fc16.x86_64
kmod-nvidia-3.3.2-6.fc16.x86_64-295.40-2.fc16.2.x86_64
kmod-nvidia-3.3.4-3.fc16.x86_64-295.49-1.fc16.1.x86_64
libreport-plugin-kerneloops-2.0.8-4.fc16.x86_64
nvidia-settings-1.0-17.fc16.x86_64
nvidia-xconfig-1.0-15.fc16.x86_64
xorg-x11-drv-nvidia-295.49-1.fc16.x86_64
xorg-x11-drv-nvidia-libs-295.49-1.fc16.i686
xorg-x11-drv-nvidia-libs-295.49-1.fc16.x86_64
3.3.4-3.fc16.x86_64
nvidia              12336594  24 
i2c_core               37991  2 nvidia,i2c_nforce2
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.49  (mockbuild@)  Thu May  3 20:26:32 CEST 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
  #2123  
Old 10th May 2012, 08:35 AM
Yellowman
Guest
 
Posts: n/a
linuxfirefox
Re: F16,F15 & F14 Nvidia driver guides

Quote:
Originally Posted by lordamus View Post
After some try to work with multiple displays and failed now my gnome 3 starting with fallback session and cant fix it. it was working without problem before the nvidia-settings...now cant use 3D

here is some info my selinux is disabled state any clue ??

Code:
abrt-addon-kerneloops-2.0.7-2.fc16.x86_64
akmod-nvidia-295.49-1.fc16.x86_64
kernel-3.3.2-6.fc16.x86_64
kernel-3.3.4-3.fc16.x86_64
kernel-devel-3.3.2-6.fc16.x86_64
kernel-devel-3.3.4-3.fc16.x86_64
kernel-headers-3.3.4-3.fc16.x86_64
kmod-nvidia-3.3.2-6.fc16.x86_64-295.40-2.fc16.2.x86_64
kmod-nvidia-3.3.4-3.fc16.x86_64-295.49-1.fc16.1.x86_64
libreport-plugin-kerneloops-2.0.8-4.fc16.x86_64
nvidia-settings-1.0-17.fc16.x86_64
nvidia-xconfig-1.0-15.fc16.x86_64
xorg-x11-drv-nvidia-295.49-1.fc16.x86_64
xorg-x11-drv-nvidia-libs-295.49-1.fc16.i686
xorg-x11-drv-nvidia-libs-295.49-1.fc16.x86_64
3.3.4-3.fc16.x86_64
nvidia              12336594  24 
i2c_core               37991  2 nvidia,i2c_nforce2
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.49  (mockbuild@)  Thu May  3 20:26:32 CEST 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
Your xorg.conf is complete garbage, delete it.


http://forums.fedoraforum.org/showpo...postcount=2106

Last edited by Yellowman; 10th May 2012 at 08:38 AM.
  #2124  
Old 10th May 2012, 01:18 PM
carlinux Offline
Registered User
 
Join Date: May 2012
Location: Italy
Posts: 1
linuxfirefox
Re: F16,F15 & F14 Nvidia driver guides

Hi all i have F16 in my old computer my VGA is a old VGA Nvidia Ti 4800 only work on nvdriver 96.x.x ... anyone have try to install this old vga ?
Anyone give my a way to install this vga ?

tnx all

p.s. sorry 4 my bad english
  #2125  
Old 10th May 2012, 03:28 PM
lordamus Offline
Registered User
 
Join Date: Apr 2007
Posts: 128
linuxchrome
Re: F16,F15 & F14 Nvidia driver guides

Quote:
Originally Posted by Yellowman View Post
Your xorg.conf is complete garbage, delete it.


http://forums.fedoraforum.org/showpo...postcount=2106

Thanks for point it out... Fixed! Here is Another problem!


I have second display connected via Analog Vga LED TV HD and want to use twinmode when using my desktop on LCD Monitor i want to watch hd video on the LED TV display... Trying lots of setups with nvidia-settings but all failed or not fitted well also it corrupted my xorg.conf to loose GLX ( same as nvidia-xconfig) Can you suggest some xorg settings for my setup ? or Any other people who using same like setup please write your suggestions...

Last edited by lordamus; 10th May 2012 at 03:51 PM.
  #2126  
Old 10th May 2012, 09:40 PM
johnlvs2run Offline
Registered User
 
Join Date: Jul 2008
Location: western u.s.
Posts: 147
linuxfirefox
Re: F14 Nvidia driver guide

F14 won't boot anymore after doing step #2 from post #3.
After rebooting, the screen freezes just before the desktop comes up, with the following code:
Code:
sb: conflicting fb hw usage nouveau fb vs EFI VGA - removing gener
[2.482758] [drm] nouveau 0000:01:00:0: Pointer to BIT ladval table invalid
Update: There must have been an issue with F14.
I've installed F16, run the steps from post #1, and the video is working. Thanks much for the thread.
__________________
biostar a870u3 / amd athlonII x2 regor250 3.0ghz am3 65w / gskill sniper 2x4gb ddr3 1333
evga 512-P3-1311-KR geforce 210 32bit ddr3 pci express hdcp video card / fedora 16 64 lxde
nvidia onboard / seagate barracuda 7200 250gb 3gbs hard drive / hannsg hw192 / earthwatts psu

Last edited by johnlvs2run; 22nd May 2012 at 01:56 AM.
  #2127  
Old 12th May 2012, 04:49 PM
marksm Offline
Banned
 
Join Date: May 2012
Location: USA
Posts: 1
windows_7chrome
Re: F16,F15 & F14 Nvidia driver guides

Thanks for helping with this guideline.


My Mother Hates Me
  #2128  
Old 12th May 2012, 06:15 PM
Dan Offline
Administrator
 
Join Date: Jun 2006
Location: Paris, TX
Posts: 23,267
linuxfirefox
Re: F16,F15 & F14 Nvidia driver guides

Hey! Marks&m!

Signature spamming is a no-no!



Buh, bye!


BANG!


(Tinkle-tink.)

  #2129  
Old 14th May 2012, 08:44 PM
itsjustarumour Offline
Registered User
 
Join Date: Jul 2009
Posts: 60
linuxfirefox
Re: F16,F15 & F14 Nvidia driver guides

The Fedora 16 part of the NVidia driver guide worked like a charm for me on Fedora 17 RC.

Cheers Leigh!

Just for reference, using NVidia GT240 card.

Code:
[ian@COOLERMASTER ~]$ rpm -qa *\nvidia\*  *\kernel\*|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf
abrt-addon-kerneloops-2.0.10-3.fc17.x86_64
akmod-nvidia-295.49-1.fc17.4.x86_64
kernel-3.3.4-3.fc16.x86_64
kernel-3.3.4-5.fc17.x86_64
kernel-devel-3.3.4-5.fc17.x86_64
kernel-headers-3.3.4-5.fc17.x86_64
kmod-nvidia-3.3.4-5.fc17.x86_64-295.49-1.fc17.4.x86_64
libreport-plugin-kerneloops-2.0.10-2.fc17.x86_64
nvidia-settings-1.0-17.fc17.x86_64
nvidia-xconfig-1.0-15.fc17.x86_64
xorg-x11-drv-nvidia-295.49-1.fc17.x86_64
xorg-x11-drv-nvidia-libs-295.49-1.fc17.i686
xorg-x11-drv-nvidia-libs-295.49-1.fc17.x86_64
3.3.4-5.fc17.x86_64
nvidia              12336597  40 
i2c_core               38028  2 i2c_i801,nvidia
# RPM Fusion - nvidia-xorg.conf
# 
Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
EndSection
[ian@COOLERMASTER ~]$
  #2130  
Old 16th May 2012, 01:43 AM
hunger Offline
Registered User
 
Join Date: Jun 2008
Location: San Francisco
Posts: 75
windows_xp_2003firefox
Re: F16,F15 & F14 Nvidia driver guides

Wondering: supposing the driver is installed and working in F16 via the instructions in the first post, will it, in theory at least, be safe to upgrade to F17 via preupgrade when F17 Final is released?

Sorry if this is already covered in the thread. I tried reading backwards, but wasn't able to make it through everything.
Closed Thread

Tags
drivers, fedora 14, fedora 15, fedora 16, guide, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rescue after failed nvidia driver install? restore nouveau or basic video driver? Icm76 Using Fedora 11 14th January 2012 04:23 AM
Nvidia set up guides. sepoto Using Fedora 2 5th March 2011 06:11 AM
nVidia Driver Guides & Autoten: Thanks! Hobashira Fedora Focus 0 12th November 2010 08:29 AM
msi n220gt series not working with Nvidia driver guides top of page davidvandoren Hardware & Laptops 0 7th September 2010 06:52 PM
FC11 nVidia No Sound After RPMFusion nVidia Driver Load basimmer Using Fedora 0 16th October 2009 12:46 AM


Current GMT-time: 04:04 (Thursday, 05-03-2015)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat