Fedora Linux Support Community & Resources Center
  #1  
Old 28th April 2012, 12:52 PM
JuhaniJaakola Offline
Registered User
 
Join Date: Mar 2009
Posts: 74
linuxfirefox
Problem enabling wireless (ACPI errors)

I upgraded my Acer 9301 laptop from Fedora 16 to Fedora 17. Now I can't enable wireless networks in KDE. When I boot, the LED for WLAN is lit, which indicates that it is enabled. However, KDE NetworkManager says that the WLAN Interface is Unavailable.

ifconfig shows interface eth0, but it is not UP.

I have attached lines from dmesg relating to ath0 or ACPI in the attachment.

This is my chip:

[2012-04-27 18:09:06] ath5k phy0: Atheros AR2413 chip found (MAC: 0x78, PHY: 0x45)

When I try to enable wireless, I get:

[2012-04-27 18:14:28] ACPI: EC: GPE storm detected, transactions will use polling mode
[2012-04-27 18:15:16] ADDRCONF(NETDEV_UP): ath0: link is not ready

And when I push the WLAN button, I get:

[2012-04-26 23:54:25] ADDRCONF(NETDEV_UP): ath0: link is not ready
[2012-04-26 23:54:48] ACPI Error: [CB04] Namespace lookup failure, AE_ALREADY_EXISTS (20120111/dsfield-143)
[2012-04-26 23:54:48] ACPI Error: Method parse/execution failed [\_SB_.AMW0.WMCA] (Node f682fc30), AE_ALREADY_EXISTS (20120111/psparse-536)
[2012-04-26 23:54:48] ACPI: Marking method WMCA as Serialized because of AE_ALREADY_EXISTS error

I have these versions:

NetworkManager-0.9.4.0-7.git20120403.fc17.i686
kde-plasma-networkmanagement-0.9.0.1-1.fc17.i686
kernel-3.3.2-8.fc17.i686

Any ideas?
Attached Files
File Type: txt err3.txt (8.8 KB, 92 views)
Reply With Quote
  #2  
Old 28th April 2012, 04:29 PM
Boricua Offline
Registered User
 
Join Date: Oct 2005
Location: Puerto Rico
Posts: 488
linuxfirefox
Re: Problem enabling wireless (ACPI errors)

Not sure it's the same, but I have a similar issue with my atheros card under gnome, so I filed this bug report:
HTML Code:
https://bugzilla.redhat.com/show_bug.cgi?id=814914
Reply With Quote
  #3  
Old 29th April 2012, 08:30 AM
JuhaniJaakola Offline
Registered User
 
Join Date: Mar 2009
Posts: 74
linuxfirefox
Re: Problem enabling wireless (ACPI errors)

WLAN works in kernel kernel-3.3.0-1.fc17.i686 but not in kernel-3.3.2-8.fc17.i686.

In kernel-3.3.0-1.fc17.i686 I have to clear the check box "Enable wireless" and then mark it again. After that WLAN works.

There are no ACPI errors in dmesg.

---------- Post added at 09:30 AM ---------- Previous post was at 07:58 AM ----------

I updated to the latest packages now, and kernel 3.3.4-1.fc17.i686 has the same problem. However, it seems that dmesg contains no ACPI errors this time.
Reply With Quote
Reply

Tags
acpi, enabling, errors, problem, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf problem? Or hardware? ACPI Errors. spliffeh Hardware & Laptops 2 27th February 2009 12:31 PM
Trouble enabling ACPI USB wakeup C Huff Hardware & Laptops 0 20th July 2007 04:30 AM
HELP: Problem with enabling Intel 3945 Wireless Card on Dell D520 marvell Servers & Networking 6 16th April 2007 07:58 PM
Enabling PHP extensions giving errors everah Installation, Upgrades and Live Media 2 2nd November 2006 12:12 AM
MSI 875P Wont boot after enabling S3 ACPI r3dkoder Using Fedora 1 20th May 2005 05:17 PM


Current GMT-time: 15:08 (Wednesday, 26-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Southglenn Instagram Photos - Campos Novos Travel Photos on Instagram - Northridge Travel Photos on Instagram