Fedora Linux Support Community & Resources Center
  #1  
Old 3rd December 2011, 05:08 PM
kbs1 Offline
Registered User
 
Join Date: Oct 2008
Posts: 91
linuxopera
Thumbs up Gnome 3 Fallback mode on GeForce 450 GTS with PAE kernel

Today I have installed fedora 16 (upgrade from fedora 14 using preupgrade) on my second computer, and sure enough, got message "Gnome 3 failed to load" [only once, the first time]. So I did follow this giude as I did when installing F16 the very same way on my other PC: http://www.if-not-true-then-false.co...ouveau-driver/

Everything went fine, but gnome 3 will not start up, only in fallback mode. Googling a lot, and trying a lot of suggestions, nothing works.

SeLinux is disabled [fully disabled]. Kernel is PAE. Tried to install nvidia driver using akmod, kmod, and also kmod-PAE. Nothing works. Also tried to install nvidia proprietary drivers from nvidia official site, still the same. nvidia-settings says everything is okay and direct rendering is enabled.

Graphics is good it's just not the true gnome 3 experience but fallback mode. Forced fallback mode is disabled.

output of:

rpm -qa |grep -e nvidia -e kernel|sort;uname -r;lsmod |grep -e nvidia -e nouveau;cat /etc/X11/xorg.conf

Code:
abrt-addon-kerneloops-2.0.6-1.fc16.i686
akmod-nvidia-290.10-1.fc16.1.i686
kernel-headers-3.1.2-1.fc16.i686
kernel-PAE-3.1.2-1.fc16.i686
kernel-PAE-devel-3.1.2-1.fc16.i686
kernel-tools-3.1.2-1.fc16.i686
kmod-nvidia-3.1.2-1.fc16.i686.PAE-290.10-1.fc16.1.i686
libreport-plugin-kerneloops-2.0.7-1.fc16.i686
nvidia-settings-1.0-13.fc16.i686
nvidia-xconfig-1.0-11.fc16.i686
xorg-x11-drv-nvidia-290.10-1.fc16.i686
xorg-x11-drv-nvidia-libs-290.10-1.fc16.i686


3.1.2-1.fc16.i686.PAE


nvidia              10769859  30 
i2c_core               21564  3 nvidia,videodev,i2c_i801


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 290.10  (mockbuild@)  Wed Nov 23 16:03:50 EST 2011

# RPM Fusion - nvidia-xorg.conf
# 

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbLayout" "sk_qwerty"
    Option         "XkbModel" "pc105"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Videocard0"
    Monitor        "Monitor0"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

I'm starting to think there is a problem with the PAE kernel. Anyone has the same problem?

Oh and also, I did set the execute flag on nvidia.ko file as mentioned in one thread. Did not help. And I did update dracut initramfs image after each change and before every reboot.

Graphics cards, drivers, kernels:
Machine 1: GeForce 6600 GT, akmod-nvidia, x86_64 kernel [works]
Machine 2 (this one): GeForce GTS450, any driver (currently akmod-nvidia), 32-bit PAE kernel [does not work, fallback mode only]

Anyone having the same issues?

Thanks

---------- Post added at 06:08 PM ---------- Previous post was at 05:51 PM ----------

It just started to work, don't ask me why. I did NOTHING related. I just said "oh well" and went at to least enable desktop icons. So I did

sudo yum install gnome-tweak-tool
... waited for it to finish
sudo yum install gconf-editor
... chose yes and waited for it to finish

Opened gnome-tweak-tool and noticed some options (like shelll extensions) were blank, but that was okay because I'm in fallback mode. I checked "let file manager handle the desktop", selected "all three buttons" in window bar, selected show seconds in clock, date in clock, weekday in calendar.

Then I went to change the window theme from my old gnome theme [don't know what it was] to modern "Adwaita", and then I proceeded to shrink the window border using

sudo sed -i "/title_vertical_pad/s/value=\"[0-9]\{1,2\}\"/value=\"4\"/g" /usr/share/themes/Adwaita/metacity-1/metacity-theme-3.xml

Setting "let file manager handle the desktop" did not take effect, I assumed that was because I was in fallback mode. So to enable it, I had to restart gnome.

I realised ALT+F2 r won't do me any good in fallback mode, so I logged out. Then it came. I saw "nvidia" logo blink there for a second [first time I saw that on this PC and this installation of fedora], and when I logged in, viola, full GNOME 3 experience.

Now hence that I'm happy, I have no idea why, all of the sudden, it started to work.

Was the problem that I had the "old" window theme selected? Or that while installing gnome-tweak-tool and gconf-editor yum somehow installed something important? Or did the "let filemanager handle the desktop" setting really matter?

Personally, I think that the problem was in old window theme. I saw gnome top panel "blink" and change shape a couple of times before in fallback mode as if it has tried to to go to full mode, but it never did.

So just a quick wrap up - it you can't get gnome 3 full experience to run for any reason, try changing your window theme! ;-)

Last edited by kbs1; 3rd December 2011 at 05:12 PM.
Reply With Quote
  #2  
Old 22nd December 2011, 11:46 PM
volrath Offline
Registered User
 
Join Date: Nov 2004
Posts: 3
windows_7chrome
Re: Gnome 3 Fallback mode on GeForce 450 GTS with PAE kernel

I had a similar issue. I saw this and tried it:
Code:
sudo yum install gnome-tweak-tool
... waited for it to finish
sudo yum install gconf-editor
... chose yes and waited for it to finish
I noticed one of the required dependencies to do this was to install gnome-shell. I looked up that package, and determined it's probably pretty important to get the new experience. Low and behold, after installing gnome-shell and logging out and back in, I had the new experience working just fine.
Reply With Quote
  #3  
Old 8th March 2012, 09:21 PM
ericrjones1 Offline
Registered User
 
Join Date: Mar 2012
Location: Indianapolis
Posts: 1
linuxchrome
Re: Gnome 3 Fallback mode on GeForce 450 GTS with PAE kernel

Thanks for the advise. This worked for me.
Reply With Quote
  #4  
Old 7th May 2012, 04:01 AM
rweed Offline
Registered User
 
Join Date: Jun 2007
Posts: 224
linuxfirefox
Re: Gnome 3 Fallback mode on GeForce 450 GTS with PAE kernel

Quote:
Originally Posted by volrath View Post
I had a similar issue. I saw this and tried it:
Code:
sudo yum install gnome-tweak-tool
... waited for it to finish
sudo yum install gconf-editor
... chose yes and waited for it to finish
I noticed one of the required dependencies to do this was to install gnome-shell. I looked up that package, and determined it's probably pretty important to get the new experience. Low and behold, after installing gnome-shell and logging out and back in, I had the new experience working just fine.
Thanks, this just fixed the issue for me. I'm still having issues with multi-monitors, but now I get the standard experience after I installed gnome-shell.

+1
Reply With Quote
Reply

Tags
450, fallback, geforce, gnome, gts, gts 450, gts450, kernel, mode, pae

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make Gnome 3 look and feel like Gnome 2 without Fallback Mode Jamwa Guides & Solutions (No Questions) 2 4th July 2012 12:22 AM
Easy method to enforce fallback mode in Gnome 3 pwil3058 Using Fedora 4 28th November 2011 01:06 AM
Problems with Gnome 3 & Nvidia Geforce GTX460M - fallback mode only paulrogers6 Hardware & Laptops 2 31st July 2011 12:01 AM
T60: GNOME 3 fallback mode when docked jfwillia Hardware & Laptops 6 18th June 2011 04:30 AM
How to switch to gnome-fallback mode on Fedora 15 beta? megaloman F15 Development 8 5th May 2011 03:40 PM


Current GMT-time: 07:00 (Wednesday, 03-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat