Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 24th May 2012, 09:05 PM
wireman Offline
Registered User
 
Join Date: Nov 2011
Location: Scotland
Posts: 24
linuxfirefox
How to get rid of gnome-panel from XFCE session?

I switched to XFCE a while back as I'm not getting on with Gnome3.

However, today gnome-panel insists on appearing in my XFCE session thereby covering up the XFCE panels Plus, it loads some programs and terminals by default.

I've tried deleting as many things I can find in ~/.config which seem to be related to sessions, but gnome-panel and the default programs still keep appearing!

Please can someone tell me two things:

1. how to kill gnome-panel in my XFCE session? I don't want to kill it completely as other users use Gnome.
2. where on earth are the default session settings stored for the programs that are appearing?

Please help. This is driving me mad!
TIA
Reply With Quote
  #2  
Old 24th May 2012, 09:24 PM
nonamedotc Offline
Community Manager
 
Join Date: Mar 2011
Location: USA
Posts: 3,719
linuxfirefox
Re: How to get rid of gnome-panel from XFCE session?

I just saw that if you remove gnome-shell gnome-panel is not removed. I don't understand why (or how) it runs though!

Code:
yum remove gnome-panel
See if this helps to solve your problem.

---------- Post added at 03:24 PM ---------- Previous post was at 03:23 PM ----------

Oops! I did not read the post carefully. Removing gnome-panel would not work if you want gnome for other users! Apologies!
Reply With Quote
  #3  
Old 25th May 2012, 12:06 AM
sea Offline
"Shells" (of a sub world)
 
Join Date: May 2011
Location: Confoederatio Helvetica (Swissh)
Age: 34
Posts: 3,278
linuxchrome
Re: How to get rid of gnome-panel from XFCE session?

You could use a script which on login kills the gnome-panel in your profile.

To place in ~/.config/autostart/
script-on-login.desktop
PHP Code:
[Desktop Entry]
Encoding=UTF-8
Name
=StartScript
Comment
=Execute Script on login
Icon
=gnome-info
Exec
=$HOME/bin/login.sh
Terminal
=true
Type
=Application
Categories
=System
Hidden
=false 
And for example in $HOME/bin/login.sh
PHP Code:
#!/bin/bash
#tar -acf /nas/backups/$(hostname)/$USER/hiddenfiles-$(date +'%y.%m.%d-%H:%M').tar.gz  $HOME/"."*
sudo pkill gnome-panel 
__________________
Laptop: Toshiba satellite p50-a-11 CPU: Intel i7 8*2400 MHz GPU: GeForce GT 745M RAM: 8192 MB Distro: Fedora (Rawhide) DE: Awesome
Text User Interface (TUI) // Windows 8+ & Fedora 20+ Dualboot

Last edited by sea; 25th May 2012 at 12:26 AM.
Reply With Quote
  #4  
Old 25th May 2012, 08:30 AM
ozjd Offline
Registered User
 
Join Date: Feb 2008
Location: Sydney Australia
Age: 59
Posts: 2,346
linuxchrome
Re: How to get rid of gnome-panel from XFCE session?

You could try deleting the sessions cache in ~/.cache/sessions/
Reply With Quote
  #5  
Old 25th May 2012, 11:57 AM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,716
linuxfirefox
Re: How to get rid of gnome-panel from XFCE session?

Verify that nauilus isn't running too. I've had some weird cases w/ nautilus messing up a xfce session. Unclear how it's started since I've unchecked it in Administration->Session&Startup.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #6  
Old 27th May 2012, 11:12 AM
wireman Offline
Registered User
 
Join Date: Nov 2011
Location: Scotland
Posts: 24
linuxfirefox
Re: How to get rid of gnome-panel from XFCE session?

Quote:
Originally Posted by ozjd View Post
You could try deleting the sessions cache in ~/.cache/sessions/
Perfect!

I just deleted everything in ~/.cache just to be sure and it fixed it. Many thanks.

BTW thanks for the other replies, but nautilus wasn't running and killing gnome-panel doesn't work as it just respawns.
Reply With Quote
Reply

Tags
gnomepanel, rid, session, xfce

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
XFCE saving my session even when I tell it not to. Boner Champ Using Fedora 2 6th October 2011 06:36 PM
KDE with a XFCE session type technique a help jenaniston Fedora Spins & Remixes 2 12th July 2011 08:41 PM
gdm doesn't show xfce as session option zoinksbob Alpha, Beta & Snapshots Discussions (Fedora 10 Only) 5 17th October 2008 07:06 PM
how do you add xfce to the session manager? Shadow Skill Using Fedora 3 16th October 2004 04:56 AM


Current GMT-time: 05:20 (Thursday, 31-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat