Fedora Linux Support Community & Resources Center
  #1  
Old 20th May 2012, 11:38 PM
midair5 Offline
Registered User
 
Join Date: Sep 2008
Posts: 7
linuxfirefox
Muting Speakers When Headphones Are Plugged In

How do I get the speakers to mute when the headphones are plugged into the front jack. Currently, if I plug in the headphones I get audio out of both. I can't find any switch on kmix or alsamixer that enables this. I've attached the output of alsa-info.sh.

Thanks

Mike
Attached Files
File Type: txt alsa-info.txt (34.8 KB, 141 views)
Reply With Quote
  #2  
Old 21st May 2012, 12:41 AM
ozjd Offline
Registered User
 
Join Date: Feb 2008
Location: Sydney Australia
Age: 59
Posts: 2,365
linuxchrome
Re: Muting Speakers When Headphones Are Plugged In

Doesn't answer your question but in Pulseaudio Volume Control, yum install pavucontrol if you don't have it, you can select which output is used.
Reply With Quote
  #3  
Old 21st May 2012, 12:57 AM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,798
linuxfirefox
Re: Muting Speakers When Headphones Are Plugged In

Pavucontrol should have a mute button for each output too. Far more useful than alsa-mixer I think.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #4  
Old 21st May 2012, 10:18 AM
marriedto51 Offline
Registered User
 
Join Date: Jul 2009
Location: England, UK
Posts: 908
linuxfirefox
Re: Muting Speakers When Headphones Are Plugged In

For my laptop, doing the following fixed this.

Run
Code:
alsamixer
in a terminal, press F6 and choose the sound card (probably entry '0'), then use the right arrow to get to the switch labelled "Auto-Mute", and the up arrow to make Auto-Mute be Enabled. Press Escape to get out of the ALSA mixer.

(Once done, this setting seems to persist after reboots etc.)
Reply With Quote
  #5  
Old 21st May 2012, 03:08 PM
midair5 Offline
Registered User
 
Join Date: Sep 2008
Posts: 7
linuxfirefox
Re: Muting Speakers When Headphones Are Plugged In

Niether one helps. pavucontrol has no way to mute one or the other. And alsamixer has no switches, that I can see. I've attached screen shots of alsamixer.

Also, this is a dual boot computer and Windows can mute the speakers automatically when the headphones are plugged in.
Attached Thumbnails
Click image for larger version

Name:	snapshot3.png
Views:	185
Size:	61.0 KB
ID:	23116   Click image for larger version

Name:	snapshot2.png
Views:	154
Size:	60.0 KB
ID:	23117  
Reply With Quote
  #6  
Old 21st May 2012, 08:05 PM
marriedto51 Offline
Registered User
 
Join Date: Jul 2009
Location: England, UK
Posts: 908
linuxfirefox
Re: Muting Speakers When Headphones Are Plugged In

From your screenshots, it looks like there may be some more options to the right of those displayed (I'm looking at the column of '>' signs). Is there anything useful if you keep pressing the right arrow?
Reply With Quote
  #7  
Old 22nd May 2012, 12:11 AM
ozjd Offline
Registered User
 
Join Date: Feb 2008
Location: Sydney Australia
Age: 59
Posts: 2,365
linuxchrome
Re: Muting Speakers When Headphones Are Plugged In

Quote:
Originally Posted by midair5 View Post
Niether one helps. pavucontrol has no way to mute one or the other.
In the output device tab select the output, speakers or headphone, top right has 3 icons, the left one is mute. Click on it and the output is muted.
Reply With Quote
  #8  
Old 22nd May 2012, 12:59 AM
midair5 Offline
Registered User
 
Join Date: Sep 2008
Posts: 7
linuxfirefox
Re: Muting Speakers When Headphones Are Plugged In

Marriedto51, I goofed up the screenshots, the second one was supposed to show the last two options, "Input Source [Mic]" and "Input Source 1 [Mic]". Those didn't seem too useful anyway.

ozjd, pavucontrol only mutes both if I hit that icon you refer to. If I select "Analog Headphones" from the port dropdown tab, it shuts everything off without even hitting the mute button. I'm missing something in the configuration, I just can't see what it is. I was able to do this on an old HP laptop with F13, but I'm having a hell of a time with F16.
Reply With Quote
  #9  
Old 22nd May 2012, 01:14 AM
ozjd Offline
Registered User
 
Join Date: Feb 2008
Location: Sydney Australia
Age: 59
Posts: 2,365
linuxchrome
Re: Muting Speakers When Headphones Are Plugged In

Try different options in the configuration tab.

---------- Post added at 10:14 AM ---------- Previous post was at 10:09 AM ----------

Quote:
Originally Posted by marriedto51 View Post
For my laptop, doing the following fixed this.

Run
Code:
alsamixer
in a terminal, press F6 and choose the sound card (probably entry '0'), then use the right arrow to get to the switch labelled "Auto-Mute", and the up arrow to make Auto-Mute be Enabled. Press Escape to get out of the ALSA mixer.

(Once done, this setting seems to persist after reboots etc.)
This appears to be dependent on the type of sound card. On my desktop only the internal analogue audio shows this option. The external usb card doesn't. My laptop doesn't have it either. Useful where it is available. Thanks for pointing it out.
Reply With Quote
  #10  
Old 19th June 2012, 01:38 PM
borlander Offline
Registered User
 
Join Date: May 2005
Posts: 8
linuxchrome
Re: Muting Speakers When Headphones Are Plugged In

Sorry to resurrect this thread...

I'm having the very same problem. Audio card is: 00:1b.0 Audio device: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller (rev 02)

Problem happens in both F16 KDE and F16 XFCE. I guess it's a pulseaudio issue since Archlinux, which uses plain ALSA, works just fine (under both KDE and XFCE).

I believe muting speakers upon inserting headphone's jack should be kind of the default behaviour... in fact it's been so for many years and it still is when using plain ALSA.

Any clue about how to do this when using Pulseaudio?

Thanks so much,
Miguel
Reply With Quote
  #11  
Old 19th June 2012, 09:44 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: Muting Speakers When Headphones Are Plugged In

My Intel audio did indeed default to automuting the speakers when the headphones are plugged in (I know from F14 on up to F17 it has been) I have gone in and changed the switch on one of my machines upon every installation so that I could use both at the same time (I just leave my headphones plugged in on that machine, and turn off the speakers when I don't want sound from the speakers)

Edit:

Audio on the above mentioned machine:

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
Reply With Quote
  #12  
Old 20th June 2012, 09:05 AM
rohanimb Offline
Registered User
 
Join Date: Jun 2012
Location: India
Posts: 7
windows_xp_2003firefox
Re: Muting Speakers When Headphones Are Plugged In

if you reduce volume in sys tray, u will not get sound in machine speaker but your headphones will get sound..i think the sound system is given like 0 - 50% sound will work fine with headphones, if you increase morethan 50% then your computer speaker will activate for sound.
Reply With Quote
  #13  
Old 20th June 2012, 09:56 AM
borlander Offline
Registered User
 
Join Date: May 2005
Posts: 8
linuxchrome
Re: Muting Speakers When Headphones Are Plugged In

Quote:
Originally Posted by DBelton View Post
My Intel audio did indeed default to automuting the speakers when the headphones are plugged in (I know from F14 on up to F17 it has been) I have gone in and changed the switch on one of my machines upon every installation so that I could use both at the same time (I just leave my headphones plugged in on that machine, and turn off the speakers when I don't want sound from the speakers)

Edit:

Audio on the above mentioned machine:

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
What's your "default" option so that automuting works? I can do as you say and manually select either speakers ("analog speakers" switch) or headphones ("analog headhpone"), but not both and definetely no automuting...

Maybe it's an issue with my audio card specifically...
Reply With Quote
  #14  
Old 20th June 2012, 09:45 PM
DBelton Offline
Administrator
 
Join Date: Aug 2009
Posts: 7,320
linuxfirefox
Re: Muting Speakers When Headphones Are Plugged In

in the pulseaudio settings, as the hardware profile, I have Analog Stereo Duplex, and on the Output tab, Analog Output for the connector.

The run alsamixer from the terminal.

I have to switch the default device to the HDA Intel device (You can hit F6 to select the device). Once I select the correct device, I have the automute setting if I use the right arrow to get to the options that don't fit on the first screen.
Reply With Quote
  #15  
Old 21st June 2012, 10:45 AM
borlander Offline
Registered User
 
Join Date: May 2005
Posts: 8
linuxchrome
Re: Muting Speakers When Headphones Are Plugged In

Thanks so much, DBelton!

Playing with alsamixer's automuting thing has done the trick. It was disabled and I've changed it to "Headphone+Speaker".

Now automuting works and, best of all, I've learned something :-)

All in all, I've just installed F17 and automuting works out-of-the-box, no alsamixer thing necessary.

Thanks!!!!!!!!!!!
Reply With Quote
Reply

Tags
headphones, muting, plugged, speakers

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Muting the speakers when headphones are plugged in (Intel HDA) PercentSevenC Hardware & Laptops 10 11th May 2012 08:10 PM
The speakers can be heard only if the headphones are plugged in micechal Hardware & Laptops 3 15th February 2012 09:08 AM
[SOLVED] Speakers don't Mute when headphones are plugged in (Both play at the same time) Jmlevick Using Fedora 4 29th October 2011 07:38 PM
Speakers not muting when headphones are plugged in AlexBelov Using Fedora 5 6th August 2011 10:58 PM
ALSA not muting speakers when headphones plugged in bbecker Fedora 13 Development Branch 9 18th May 2010 07:24 PM


Current GMT-time: 14:18 (Friday, 29-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat