Fedora Linux Support Community & Resources Center
  #1  
Old 17th June 2012, 01:29 PM
TheBigRed Offline
Registered User
 
Join Date: Mar 2008
Location: Germany
Posts: 290
linuxfirefox
rpm creation and systemd problem

hi,

i am trying to build a new rpm package for fedora 17, i have already created a package review

However, I cant interpret the systemd error messages.

Code:
[root@fc17-64 tmp]# systemctl enable tntnet.service
ln -s '/usr/lib/systemd/system/tntnet.service' '/etc/systemd/system/multi-user.target.wants/tntnet.service'
Code:
[root@fc17-64 tmp]# systemctl start tntnet.service
Job failed. See system journal and 'systemctl status' for details.

Code:
[root@fc17-64 tmp]# systemctl status tntnet.service
tntnet.service - tntnet web application server
    Loaded: loaded (/usr/lib/systemd/system/tntnet.service; enabled)
    Active: failed (Result: timeout) since Sun, 17 Jun 2012 14:07:14 +0200; 2min 12s ago
    Process: 2475 ExecStart=/usr/bin/tntnet (code=killed, signal=TERM)
    CGroup: name=systemd:/system/tntnet.service

    Jun 17 14:05:44 fc17-64 tntnet[2475]: tntnet 2.1
    Jun 17 14:05:44 fc17-64 tntnet[2475]: unknown group www-data
any hint ?
Reply With Quote
  #2  
Old 17th June 2012, 01:34 PM
pete_1967 Online
Clueless in a Cuckooland
 
Join Date: Mar 2006
Location: Here now, elsewhere tomorrow.
Posts: 4,320
linuxfirefox
Re: rpm creation and systemd problem

Quote:
Jun 17 14:05:44 fc17-64 tntnet[2475]: unknown group www-data
There's your hint right there.
__________________
A Drink is Not Just For Christmas - SaskyCom :thumb:


“Give a man a fish; you have fed him for today. Teach a man to fish; and you have fed him for a lifetime” so now go and...
RTFM FIRST: http://docs.fedoraproject.org/ & http://rute.2038bug.com/index.html.gz
Reply With Quote
  #3  
Old 19th June 2012, 07:05 PM
TheBigRed Offline
Registered User
 
Join Date: Mar 2008
Location: Germany
Posts: 290
linuxfirefox
Re: rpm creation and systemd problem

Quote:
Originally Posted by pete_1967 View Post
There's your hint right there.
ok,
after adding a new group www-data an adding my user name to the group, service starts and a status is displayed.
Code:
groupadd www-data
Code:
usermod -a -G www-data martin
Code:
martin@fc17 tmp$ systemctl start tntnet.service
Code:
martin@fc17 tmp$ systemctl status tntnet.service
Quote:
tntnet.service - tntnet web application server
Loaded: loaded (/usr/lib/systemd/system/tntnet.service; enabled)
Active: active (running) since Tue, 19 Jun 2012 20:15:49 +0200
Process: 580 ExecStart=/usr/bin/tntnet (code=exited, status=0/SUCCESS)
Main PID: 587 (tntnet)
CGroup: name=systemd:/system/tntnet.service
├ 586 /usr/bin/tntnet
└ 587 /usr/bin/tntnet
I only need a reviewer for the bug review.

Last edited by TheBigRed; 19th June 2012 at 10:01 PM.
Reply With Quote
  #4  
Old 20th June 2012, 12:11 AM
pete_1967 Online
Clueless in a Cuckooland
 
Join Date: Mar 2006
Location: Here now, elsewhere tomorrow.
Posts: 4,320
linuxfirefox
Re: rpm creation and systemd problem

Who are you building this package? If it's for Red Hat/ Fedora, there is never a group called www-data, Apache runs as apache:apache. www-data is used in Debian (and derivatives) for Apache.
__________________
A Drink is Not Just For Christmas - SaskyCom :thumb:


“Give a man a fish; you have fed him for today. Teach a man to fish; and you have fed him for a lifetime” so now go and...
RTFM FIRST: http://docs.fedoraproject.org/ & http://rute.2038bug.com/index.html.gz
Reply With Quote
  #5  
Old 20th June 2012, 09:11 AM
TheBigRed Offline
Registered User
 
Join Date: Mar 2008
Location: Germany
Posts: 290
windows_xp_2003firefox
Re: rpm creation and systemd problem

Quote:
Originally Posted by pete_1967 View Post
Who are you building this package? If it's for Red Hat/ Fedora, there is never a group called www-data, Apache runs as apache:apache. www-data is used in Debian (and derivatives) for Apache.
i am tried to build a new rpm package for fedora 17, i have already created a package review

the contens of the orignial tntnet.conf.in looks like this:

Code:
Daemon	    1
User	    www-data
Group	    www-data
CompPath    @libdir@/tntnet
this means, i must change the User and Group in tntnet.conf.in ?
Reply With Quote
  #6  
Old 20th June 2012, 09:51 AM
pete_1967 Online
Clueless in a Cuckooland
 
Join Date: Mar 2006
Location: Here now, elsewhere tomorrow.
Posts: 4,320
linuxfirefox
Re: rpm creation and systemd problem

Quote:
Originally Posted by TheBigRed View Post
this means, i must change the User and Group in tntnet.conf.in ?
If you want it to work on Red Hat/ Fedora, yes you do.
__________________
A Drink is Not Just For Christmas - SaskyCom :thumb:


“Give a man a fish; you have fed him for today. Teach a man to fish; and you have fed him for a lifetime” so now go and...
RTFM FIRST: http://docs.fedoraproject.org/ & http://rute.2038bug.com/index.html.gz
Reply With Quote
  #7  
Old 20th June 2012, 05:47 PM
TheBigRed Offline
Registered User
 
Join Date: Mar 2008
Location: Germany
Posts: 290
linuxfirefox
Re: rpm creation and systemd problem

thanks for reply
Reply With Quote
  #8  
Old 24th June 2012, 03:43 PM
TheBigRed Offline
Registered User
 
Join Date: Mar 2008
Location: Germany
Posts: 290
linuxfirefox
Re: rpm creation and systemd problem

In Fedora Apache uses httpd UID/GID 48 (fixed!) for user/group "Apache". This means, among other things, that files from the httpd package have set appropriate access rights can and are intended only for httpd.

%changelog
* Sun Jun 24 2012 Martin Gansser <linux4martin@gmx.de> - 2.1-8
- removed group and user apache from tntnet.conf
- added own group tntnet to tntnet.conf
- added creation of users and groups in pre section

tntnet.src.rpm
tntnet.spec


review closed package review

Last edited by TheBigRed; 27th July 2012 at 10:43 AM.
Reply With Quote
Reply

Tags
creation, problem, rpm, systemd

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
systemd and mgetty problem dave539 Using Fedora 0 12th March 2012 12:36 AM
Fedora 12 Bootable USE creation Problem vijayrawatsan Installation, Upgrades and Live Media 5 14th January 2010 04:39 PM
Mirror creation problem georgesgiralt Using Fedora 0 11th January 2007 11:23 PM


Current GMT-time: 23:55 (Tuesday, 30-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat