Fedora Linux Support Community & Resources Center
  #1  
Old 29th June 2012, 12:10 AM
ANSCCPL
Guest
 
Posts: n/a
linuxfirefox
Connecting to Steam account forever

Hello.
I'm not sure if this is the right place to post this problem but I really need some help.
I'm trying to install Steam on Fedora 17 (64-bit; GNOME).
I first installed WINE and then installed Steam. I inserted my log-in info and then it starts connecting to Steam Account [User-name]. Forever. Perpetually. OR it just disappears. Forever. Perpetually.
I've tried to fix this, really:
- Used Winetricks (did everything that's in this page_forums.fedoraforum.org/showthread.php?t=169544);
- Used Play on Linux (which installed some fonts and deleted some dll files that (supposedly) could compromise Steam);
- Installed Tahoma font and TransGaming ActiveX Control (did everything that's in this page_fedorasolved.org/gaming-solutions/installing-steam-using-wine/);
- Did everything that's in this page (http://appdb.winehq.org/objectManage...on&iId=19444);
- Disabled SElinux;
- Renamed ClientRegistry.blob to ClientRegistryOld.blob;
- Deleted ClientRegistry.blob
- Made sure I hadn't any of the programs that could interfere with steam (https://support.steampowered.com/kb_...28-SFLZ-9289);
- Renamed another file (I'm sorry, I can't remember what file, but someone recommended that one of the forums);
- Deleted that file;
- Re-installed Fedora (“clean” install) various times trying to combine those steps in different ways;
- Reconfigured my router;
- Restarted the computer various times;
- Logged off, restarted, powered off the computer (in this order, without interruptions);

I can open Steam on Windows (this computer) and on OS X (computer of a friend).
My computer's info:
● 3 GB of memory;
● Processor: Intel® Core™2 Duo CPU T5870 @ 2.00GHz × 2;
● Graphics: Mobile Intel® GM45 Express Chipset;
● HD: 314,4 GB.

I just want to play Portal 2! (and uninstall Windows.)
Thank you.
Reply With Quote
  #2  
Old 30th June 2012, 10:34 PM
StyxD Offline
Registered User
 
Join Date: Apr 2010
Posts: 49
linuxfirefox
Re: Connecting to Steam account forever

I had the same problem, but I don't guarantee I'll be of any help to you, since I had a peculiar situation.

I had 32-bit wine installed on 64-bit machine. Logging into Steam used to hang indefinitely in the way you describe, until I installed 32-bit version of mesa-dri-drivers (wine doesn't pull 3d graphics drivers by default, it seems).

Steam runs normally since then.

But that assumes you have 32-bit wine and use mesa drivers.
Reply With Quote
  #3  
Old 1st July 2012, 12:58 AM
ANSCCPL
Guest
 
Posts: n/a
linuxepiphany
Re: Connecting to Steam account forever

Hello and thank you.

In "Add/Remove Software" app I can only find Mesa-based DRI drivers for 64-bit machines (which are already installed). Where did you get those drivers?


UPDATE: I've already found them. I'll try them and then I'll post if it worked or not.

---------- Post added at 12:58 AM ---------- Previous post was at 12:26 AM ----------

It worked!!!
One interesting fact: I have WINE for 64-bit machines and I installed 32-bit version of mesa-dri-drivers for steam to work. Do you know what that means? It means that I can finally play Portal 2 on linux. (AND uninstall windows.) THANK YOU SO MUCH.

Last edited by ANSCCPL; 1st July 2012 at 12:31 AM.
Reply With Quote
Reply

Tags
account, connecting, forever, steam

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Steam won't let me lg in to my account alexander224 Gamers' Lounge 3 29th July 2008 01:14 AM
Install into root account instead of normal user account myisty Using Fedora 1 3rd June 2007 08:27 PM
Which account to use ? Root or a new user account TeachMeLinux Using Fedora 3 7th March 2007 09:55 AM
steam Roybert Using Fedora 4 29th July 2006 07:02 AM
Blank Screen on every new and old account except for root account deverej Using Fedora 2 1st March 2005 09:11 AM


Current GMT-time: 18:41 (Sunday, 20-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat