Fedora Linux Support Community & Resources Center
  #1  
Old 2nd August 2012, 03:00 AM
Erunur Offline
Registered User
 
Join Date: Mar 2012
Location: New Mexico
Posts: 32
linuxfirefox
How do I change the default ondemand governer to conservative

I have been trying to change the governer on my laptop from ondemand to conservative on my CPUs using
"echo conservative > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor"

It works but I have to go through and run that command on all my cpus from cpu0 tp cpu7. but the real problem is is that every time I reboot the governer always changes back from conservative to ondemand. Is there a way to make the conservative gonerner the default governer?
Reply With Quote
  #2  
Old 2nd August 2012, 02:03 PM
vallimar Offline
Registered User
 
Join Date: Jul 2008
Posts: 1,058
windows_xp_2003chrome
Re: How do I change the default ondemand governer to conservative

Install the "kernel-tools" rpm package.
Read "cpupower help frequency-set"
Then modify the file "/etc/sysconfig/cpupower"
Now enable the service: systemctl enable cpupower.service
And start: systemctl start cpupower.service

Settings should be applied automatically on reboots now.

---------- Post added at 09:03 AM ---------- Previous post was at 09:01 AM ----------

Btw, you can also shorten your command to a one-liner, just do this instead:
"echo conservative > /sys/devices/system/cpu/*/cpufreq/scaling_governor"
Reply With Quote
  #3  
Old 2nd August 2012, 02:04 PM
Dan Offline
Administrator
 
Join Date: Jun 2006
Location: Paris, TX
Posts: 23,279
linuxfirefox
Re: How do I change the default ondemand governer to conservative

http://forums.fedoraforum.org/showthread.php?p=1529569
Reply With Quote
  #4  
Old 2nd August 2012, 07:08 PM
Erunur Offline
Registered User
 
Join Date: Mar 2012
Location: New Mexico
Posts: 32
linuxfirefox
Re: How do I change the default ondemand governer to conservative

So im new to this but I installed kernel-tools and I read the help page. then I ran cpupower frequency-set -g conservative and that changed the governer right away. then I modified both lines of /etc/sysconfig/cpupower to be conservative ( I wasn't sure which lines to modify so I did both.) then I ran "systemctl enable cpupower.service" followed by "systemctl start cpupower.service". And I rebooted the computer and the governer changed back to ondemand. I'm not sure why its doing that but it's probably something I did to cause that.
Reply With Quote
  #5  
Old 2nd August 2012, 07:22 PM
dd_wizard Online
Registered User
 
Join Date: Sep 2009
Posts: 1,436
linuxfirefox
Re: How do I change the default ondemand governer to conservative

If you look through the thread that Dan linked, you'll find a script that I wrote that uses the tools you installed. It belongs in /etc/pm/power.d and does exactly what you want to do. If you use it, be sure to disable the cpupower service so they don't conflict.

dd_wizard
Reply With Quote
  #6  
Old 3rd August 2012, 01:45 AM
Erunur Offline
Registered User
 
Join Date: Mar 2012
Location: New Mexico
Posts: 32
linuxfirefox
Re: How do I change the default ondemand governer to conservative

Thanks for the script. but I'm still having problems. I dumped the script in /etc/pm.power.d and made it an executable. I changed both governers to be conservative then I ran "pm-powersave false" and it worked just fine but it still won't run by itself on bootup. I know this is kindof a dumb question but would it matter what I name the executaable?
I'm pretty sure cpupower service is off because I ran "systemctl stop cpupower.service" followed by "systemctl disable cpupower.service"

A little off topic here but this is all kinda new to me, what's the difference between online_governer and battery_governer?
Reply With Quote
Reply

Tags
change, conservative, default, governer, ondemand

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Powernow-k8/cpuspeed ondemand governor fails longhaven Using Fedora 0 8th June 2009 09:40 PM
how to change the default page of apache from index.htm to default.htm sourin Servers & Networking 6 16th December 2005 04:08 PM
how to change the default page of apache from index.htm to default.htm sourin Servers & Networking 0 14th December 2005 12:42 PM


Current GMT-time: 03:10 (Wednesday, 22-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Rioja Photos - Jhunjhunun - Hammamet Travel Photos on Instagram