Fedora Linux Support Community & Resources Center
  #1  
Old 10th February 2006, 06:29 AM
Beomoss Offline
Registered User
 
Join Date: Nov 2004
Age: 30
Posts: 11
Question no text console, improper video mode?

Hello,

I'm experiencing a problem with my display, such that I'm unable to get a text console. I boot my system, to see "Cannot display this video mode" on my monitor, rather than the typical system-startup messages. If I wait long enough for the system to fully boot, X starts fine, and I'm able to log into an X session.

The issue seems to be related to my Dell system; The following is a page from Dell support:

http://support.dell.com/support/topi...dn=FA1079260#0

But their reccommended solution doesn't help at all. Can anyone help me out here? I'm not even sure where to begin with this one; my natural inclination was to re-install the nvidia drivers (I'm using a GeForce 6800 GT if that helps), but as my system is completely non-functional unless it's in an X server, that's not an option. Attatched is my xorg.conf.

Can anyone give me a hand here?
Attached Files
File Type: txt xorg.conf.txt (2.8 KB, 122 views)
Reply With Quote
  #2  
Old 27th May 2006, 08:26 AM
schneis Offline
Registered User
 
Join Date: May 2006
Location: Portland, OR, USA
Posts: 4
I'm experiencing what may be the same problem, but with non-Dell hardware. X works fine once the system finally starts it. The problem (for me) is that I'm used to working from the text console.

The problem is specific to one LCD panel that I have - one that I need to use. I'm running FC5 with the latest patches (just a basic install & I have reinstalled a couple times with the same results - text consoles during the install work fine).

I've been able to track the problem down to when udev starts in /etc/rc.sysinit. udev is changing the text mode video refresh rate from whatever the BIOS default is, to something that is just too much for my LCD.

I've been fighting this for about a month and keep coming up with nothing. Can anyone help???
Reply With Quote
  #3  
Old 27th May 2006, 09:39 AM
solarisman Offline
Registered User
 
Join Date: Apr 2006
Posts: 73
Beomoss,

Your post says you have a 6800GT, your xorg.conf shows a 6600. Which is correct? Are you using the livna drivers or the stock nVidia ?
Reply With Quote
  #4  
Old 27th May 2006, 09:56 AM
schneis Offline
Registered User
 
Join Date: May 2006
Location: Portland, OR, USA
Posts: 4
I can't answer for Beomoss, but I'd read his problem to be with the text-mode console, not with X.

In any case, it looks like I had to post about my problem to finally find the solution (or at least one that will work).

I'd previously tried the vga=ask parameter to the kernel in Grub, only to have it return a rather short list - the 80x25 mode listed was 0x0f01 and selecting it did not change my problem. Based on seeing other VESA modes described elsewhere on the web, I tried the 80x25 mode that they had listed - 0x0301. That was enough to keep udev from changing the refresh rate on my text console and will all me to get back to work on this system.
Reply With Quote
Reply

Tags
console, improper, mode, text, video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot install in Graphical Mode, Forced into Text mode, an stuck with text mode!! yogeshnachnani Installation, Upgrades and Live Media 14 11th February 2009 06:57 AM
Cannot Login to Console(Text Mode) Peter_APIIT Installation, Upgrades and Live Media 19 7th March 2007 02:27 AM
console text mode shows fedora core 5 but fc6 installed jsanza@terra.es EOL (End Of Life) Versions 6 13th January 2007 09:10 PM
strange mc colors under console text mode CD-RW Using Fedora 7 15th December 2006 07:43 PM
Text Mode console does not change back to GUI, savio_mit_glug Using Fedora 1 24th June 2006 04:54 PM


Current GMT-time: 08:48 (Wednesday, 20-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat