Fedora Linux Support Community & Resources Center
  #1  
Old 1st July 2005, 12:43 AM
cdlaforc Offline
Registered User
 
Join Date: Jun 2005
Location: Wisconsin
Age: 34
Posts: 241
smb error

Hello,
I have just setup a samba share and tried to start the smb service and it fails. If I try to start it from the command line I get this error:

Starting SMB services: /etc/init.d/functions: line 83: 16565 Aborted $nice $*

Any ideas?
Thanks,

Chris.
Reply With Quote
  #2  
Old 5th July 2005, 02:14 PM
cdlaforc Offline
Registered User
 
Join Date: Jun 2005
Location: Wisconsin
Age: 34
Posts: 241
Hello,
This was found to be a bug and the work around is to for now uncheck the enforcing checkbox in the selinux gui.
Thanks,

Chris.
Reply With Quote
  #3  
Old 6th July 2005, 08:54 PM
scarab02 Offline
Registered User
 
Join Date: Jul 2005
Posts: 4
Hello,

Do you happen to have a link to the bug report??? I am running Fedora as a CLI only... I couldn't find the bug report via bugzilla. I am starting to feel like a hopeless case... Never had a problem with starting Samba before now - jesh.

thanks,
chris
Reply With Quote
  #4  
Old 6th July 2005, 09:27 PM
scarab02 Offline
Registered User
 
Join Date: Jul 2005
Posts: 4
Found answer on Bugzilla: (https://bugzilla.redhat.com/bugzilla....cgi?id=158802)

Samba can be started manually using /usr/sbin/smbd -D. I have become to complacent using 'server X stop/start/status'.

-c.
Reply With Quote
  #5  
Old 5th March 2006, 03:59 AM
nveteran Offline
Registered User
 
Join Date: Mar 2006
Posts: 1
Talking strange...

I solved this problem, but it's strange.

I did following.

# cd /etc/init.d/

# cp smb samba
# mv smb smb.bak
# mv samba smb --> just swap

# diff smb smb.bak --> same

# service smb restart
root 5566 1 0 12:58 ? 00:00:00 smbd -D
root 5567 5566 0 12:58 ? 00:00:00 smbd -D
root 5569 1 0 12:58 ? 00:00:00 nmbd -D
Reply With Quote
  #6  
Old 28th March 2006, 11:38 AM
hollymcr Offline
Registered User
 
Join Date: Mar 2006
Posts: 1
Thumbs up

Quote:
Originally Posted by nveteran
I solved this problem, but it's strange.
Odd, but it just worked for me too (thanks for posting it, and I'm glad I didn't follow my first instinct to ignore it because it shouldn't have made a difference).

Only thing I can think of is that the file date will have changed by doing this. If so, "touch smb" should have worked (too late to check now).
Reply With Quote
  #7  
Old 6th April 2006, 05:46 AM
macob Offline
Registered User
 
Join Date: Apr 2006
Posts: 1
The "copy then rename" trick is essentially changing the selinux context.
If you did an 'ls -Z smb' before doing this, you would see that the context was:
system_u:object_r:initrc_exec_t

When you copied the smb file, you created a new file which got the default contex of:
root:object_r:etc_t

You then renamed the copy back to smb. You could have accomplished the same thing with the command:
Code:
chcon root:object_r:etc_t smb
But, alas, this still didn't solve the problem. Sure I could now start smb manually, but I still get the same "Aborted" error on system startup.

The solution for me was to indeed turn off selinux enforcement for smb.
Since I don't have a GUI installed, I used the command line command:
Code:
setsebool -P smbd_disable_trans 1
(I got the command line directions from here )
Reply With Quote
  #8  
Old 29th April 2006, 04:01 AM
seamus Offline
Registered User
 
Join Date: Apr 2006
Posts: 1
Thanks to macob for resolving my problem.
Also nveteran helped me a lot.
Reply With Quote
  #9  
Old 1st June 2006, 05:58 PM
superkun Offline
Registered User
 
Join Date: May 2006
Posts: 1
Thanks to nveteran for giving a workaround solution.
Thanks to macob for explaning the real reason hidden behind, or I would be confused for some time.
Reply With Quote
Reply

Tags
error, smb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mount error - error mounting /dev/root on sysroot as ext3 : invalid argument marko Using Fedora 7 5th February 2013 11:00 AM
Error: DBus error org.freedesktop.DBus.Error.NoReply: -- F10 -- bluetooth kamil Using Fedora 4 12th April 2009 02:29 PM
madman error freshrpm error repository error! ilbh Using Fedora 5 1st June 2006 10:52 PM


Current GMT-time: 03:42 (Thursday, 24-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat