Fedora Linux Support Community & Resources Center
  #1  
Old 18th January 2007, 04:49 PM
kacperix Offline
Registered User
 
Join Date: Jan 2007
Posts: 7
Exclamation Kernel Panic on boot system

Hi everybody. I know that this was bringing up question many times, but I still don't know how resolve it.

When I want select my Fedora system from GRUB's list and press ENTER, then I'v got this error:

Code:
Reading all physical volumes: This make take a while...
    No volume groups found
    Volume group "VolGroup00" not found
Unable to access resume device (/dev/VolGroup00/LogVol00)
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kerenl panic - not syncing: Attempted to kill init!
What I must do to resolve this problem?? I really want working on Fedora, but this problem more and more discourage me :/

# fdisk -l
Code:
Disk /dev/sda: 250.0 GB, 250058268160 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        1912    15358108+   7  HPFS/NTFS
/dev/sda2            1913       28617   214507912+   f  W95 Ext'd (LBA)
/dev/sda3           28618       28630      104422+  83  Linux
/dev/sda4           28631       30401    14225557+  8e  Linux LVM
/dev/sda5            1913       28617   214507881    7  HPFS/NTFS
# cat /etc/grub.conf
Code:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,2)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=8
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.18-1.2869.fc6)
        root (hd0,2)
        kernel /vmlinuz-2.6.18-1.2869.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.18-1.2869.fc6.img
title Fedora Core (2.6.18-1.2798.fc6)
        root (hd0,2)
        kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.18-1.2798.fc6.img
title Windows
        rootnoverify (hd0,0)
        chainloader +1

PLEASE HELP

Last edited by kacperix; 18th January 2007 at 05:28 PM.
Reply With Quote
  #2  
Old 18th January 2007, 05:05 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,150
How did this get renamed: VolFroup00 (should be VolGroup00) - also, why is it looking for LogVol01 when it should be LogVol00? Did you tweak something?
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #3  
Old 18th January 2007, 05:26 PM
kacperix Offline
Registered User
 
Join Date: Jan 2007
Posts: 7
Quote:
Originally Posted by bob
How did this get renamed: VolFroup00 (should be VolGroup00) - also, why is it looking for LogVol01 when it should be LogVol00? Did you tweak something?
No, no...that's only clerical error. I must wrote this by hand

I was correcting this.

Last edited by kacperix; 18th January 2007 at 05:31 PM.
Reply With Quote
  #4  
Old 18th January 2007, 05:38 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,150
Well, how about the grub.conf? Notice that there's a space between (hd0 and 2) -it should be booting (hd0,2) instead of (hd0, 2). Can you stop the boot at the menu and then test by 'e' for edit on the appropriate line, 'enter' to make changes, 'enter' again to save the change and 'b' to boot? The error's also the same at (hd0,0) for Windows, BTW.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #5  
Old 18th January 2007, 05:45 PM
kacperix Offline
Registered User
 
Join Date: Jan 2007
Posts: 7
There are no spaces between this to numbers.

But this problem is no always. Now I write this post from LINUX OS, but for example, when I Turn On my computer then this problem is and then I must restart many times my machine then it to start. Or when I want start LINUX after shutdown Windows OS.
Reply With Quote
  #6  
Old 18th January 2007, 05:50 PM
bob Online
Administrator (yeah, back again)
 
Join Date: Jul 2004
Location: Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
Age: 69
Posts: 22,150
You may have a hard drive problem. I'd go to the manufacturer's site and check for tools to test the drive.
__________________
Linux & Beer - That TOTALLY Computes!
Registered Linux User #362651


Don't use any of my solutions on working computers or near small children.
Reply With Quote
  #7  
Old 18th January 2007, 05:58 PM
kacperix Offline
Registered User
 
Join Date: Jan 2007
Posts: 7
I think my HDD is OK. I buy this machine a few weeks ago. Windows working on it good, and before I have Mandriva too, and all worked without problems. I have this problem since first time installed my Fedora, I try reinstalled it but this no help.
Reply With Quote
  #8  
Old 19th January 2007, 05:55 AM
beissemj Offline
Registered User
 
Join Date: Jan 2007
Posts: 43
You have an fstab problem. Post your /etc/fstab and it should be an easy fix.
Reply With Quote
  #9  
Old 19th January 2007, 12:00 PM
kacperix Offline
Registered User
 
Join Date: Jan 2007
Posts: 7
#cat /etc/fstab

Code:
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
Reply With Quote
  #10  
Old 20th January 2007, 12:21 AM
beissemj Offline
Registered User
 
Join Date: Jan 2007
Posts: 43
Okay, if I'm reading this corrently, partition /dev/sda3 is your boot partition and /dev/sda4 is your primary linux partition. Your fstab looks a little strange to me, however I don't use LVM.

1. You don't have a swap partition according to fdisk -l so you can comment out that line.

2. /dev/VolGroup00/LogVol00 doesn't make sense to me. I would try changing that. So your fstab should look something like this:
Code:
/dev/sda4               /                       ext3    defaults        1 1
/dev/sda3               /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
#/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
Grub.conf
Code:
title Fedora Core (2.6.18-1.2869.fc6)
        root (hd0,2)
        kernel /vmlinuz-2.6.18-1.2869.fc6 ro root=/dev/sda4 rhgb quiet
        initrd /initrd-2.6.18-1.2869.fc6.img
Reply With Quote
  #11  
Old 20th January 2007, 05:32 PM
ActivationFree Offline
Registered User
 
Join Date: Oct 2004
Posts: 4
Hi, I would like to help if I can.

There seems to be a problem with the partition you are trying to boot from.

your /boot/grub/grub.conf has the following:

Quote:
title Fedora Core (2.6.18-1.2869.fc6)
root (hd0,2)
..as fas as i'm aware this is the second partition of the first hard drive.

but output of fdisk -l says that you boot partition should be (0,3):

Quote:
/dev/sda2 1913 28617 214507912+ f W95 Ext'd (LBA)
/dev/sda3 28618 28630 104422+ 83 Linux
...this is the third partition on the first hard drive

The partition you appear to be trying to boot from is an extended parttiton ! if you can not boot into the OS to fix this. I would try booting from the installation disk and typing linux rescue, once you have mounted your OS edit grub so it is booting from the correct partition.

The output of fdisk -l on my FC6 install with LVM doesnot show a SWAP file either, however, I do have one, confirmed with system monitor. Not sure why it doesnt show with fdisk.
Reply With Quote
  #12  
Old 21st January 2007, 10:48 AM
kacperix Offline
Registered User
 
Join Date: Jan 2007
Posts: 7
Quote:
Originally Posted by beissemj
Okay, if I'm reading this corrently, partition /dev/sda3 is your boot partition and /dev/sda4 is your primary linux partition. Your fstab looks a little strange to me, however I don't use LVM.

1. You don't have a swap partition according to fdisk -l so you can comment out that line.

2. /dev/VolGroup00/LogVol00 doesn't make sense to me. I would try changing that. So your fstab should look something like this:
Code:
/dev/sda4               /                       ext3    defaults        1 1
/dev/sda3               /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
#/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
Grub.conf
Code:
title Fedora Core (2.6.18-1.2869.fc6)
        root (hd0,2)
        kernel /vmlinuz-2.6.18-1.2869.fc6 ro root=/dev/sda4 rhgb quiet
        initrd /initrd-2.6.18-1.2869.fc6.img
I was doing what you wrote here, but then system wan'ted start. I then was changin one thing: in grub.conf I didn't change anything, that's mean the line is:

kernel /vmlinuz-2.6.18-1.2869.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet

and in fstab file I commented this line what you say and since I do this all it's OK. My system boot without any problem If sth will be wrong i write about this here. But now is OK
Reply With Quote
  #13  
Old 23rd January 2007, 09:55 AM
kacperix Offline
Registered User
 
Join Date: Jan 2007
Posts: 7
Hi everybody.

This problem return to me after install kmod-nvidia and the kernel was updating. My KERNEL now is 2.6.19-1.2895. Where is know the problem?? I will in near feature reinstall the system, maybe you have some propsitions how redistibute my disk partitions??
Reply With Quote
  #14  
Old 23rd January 2007, 03:00 PM
beissemj Offline
Registered User
 
Join Date: Jan 2007
Posts: 43
I believe installing kmod-nvidia / kmod-ati (or whatever it is called) reinstalls a FC6 kernel and changes your grub.conf. However, check grub.conf again and change your kernel line to reflect the updated kernel.
Code:
/vmlinuz-2.6-19-1.2895 ro root=... rhgb quiet
You shouldn't ever need to reinstall, unless you do something REALLY stupid, but even then it can usually be fixed with a liveCD. You can turn off LVM (I think) and repartition your drive with either fdisk /dev/pick_your_device or something like gparted/qtparted.
Reply With Quote
Reply

Tags
boot, kernel, panic

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 7 Kernel Panic [System x3655 w/RAID] denniswimer Installation, Upgrades and Live Media 3 25th September 2007 08:38 PM
My FC6 system is screwed! Kernel panic (can not mount root) joe.pelayo EOL (End Of Life) Versions 4 5th July 2007 03:47 AM
OpenMotif removal leads to kernel panic - and no usable system IanWaring Installation, Upgrades and Live Media 6 29th October 2006 03:03 PM
Kernel Panic During System Boot Besnell Using Fedora 1 12th September 2005 09:58 AM


Current GMT-time: 22:19 (Wednesday, 01-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat