Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 20th December 2007, 03:11 AM
mdebusschere Offline
Registered User
 
Join Date: Dec 2007
Posts: 4
Fedora8 Dell Poweredge 2600 System Clock Jumps Forward

Synposis:

Installed Fedora 8 from Live CD image onto a Dell Power Edge 2600 Server.
The disks are setup in raid 5 with a custom but typical load using boot
and LVM partition.

During boot it mentions it doesnt like clocksource, setting to HPET, but
otherwise no major problems booting. I have set the clocksource=hpet and
that appears to run without issue. Twice it has reported bad blocks
on root during boot, not sure why the system is usually shutdown clean
as far as I can tell..

Once the system is up, the system clock jumps ahead 4-5 minutes every so often.

Hence,
if I run date randomly a few seconds after each other I can see
the time jump 4 minutes, but if I run hwclock the clock runs as expected.

Of course during shutdown this fast moving system clock appears
to get set back to the hwclock.

I have tried every Kernel option I can think off, has been suggested etc, hence I
am asking here for suggestions I may have missed.

I have ntpd turned off.
Reply With Quote
  #2  
Old 21st December 2007, 06:17 PM
mdebusschere Offline
Registered User
 
Join Date: Dec 2007
Posts: 4
Jump interval

It appears that System time jumps forward every 14 seconds.
I read somewhere the kernel periodically checks & resets from
the hw clock at a similar interval ?

It doesn't really make sense as the hwclock keeps time normal
well at least over small period of time its not jumping minutes.

Anyone know how it might be adjusting or why during these
time checks ?
Reply With Quote
  #3  
Old 15th January 2008, 08:11 PM
mdebusschere Offline
Registered User
 
Join Date: Dec 2007
Posts: 4
Fedora 7 appears to be working

Installed Fedora 7 as a test. It appears the clock is not
longer jumping forward. I assume this is kernel related.
Reply With Quote
  #4  
Old 13th February 2008, 03:16 PM
kilen Offline
Registered User
 
Join Date: Feb 2008
Posts: 3
Quote:
Originally Posted by mdebusschere
Once the system is up, the system clock jumps ahead 4-5 minutes every so often.
I have the same problem but I'm running Fedora 7 on our PowerEdge 2600. I have just updated from Fedora Core 2. It may work fine for some time but occasinally the clock is steped several minits, and in /var/log/messages the line "Feb 13 15:06:00 adara kernel: Clocksource tsc unstable (delta = 238990016277 ns)" is printed!

When this occurs the server hangs and none of the services running on the PowerEdge is available on the network (dhcp, bind, httpd, svn etc). The wierd thing is that I only have to activate the server from screen saver state and its back on the network again.

This is a very big problem because the backup to DLT-tapes also failes when this happens.

Please, someone help! I don't wont to go back to Fedora Core 2.
Reply With Quote
  #5  
Old 13th February 2008, 05:44 PM
mdebusschere Offline
Registered User
 
Join Date: Dec 2007
Posts: 4
Try setting clocksource=hpet or as need as kernel param.

Also, I always though powersaving related items were causing the problems.
I don't recall if tried to disable all the possible scenarios.

It seems our system is stable with fedora 7. Sorry dont have a current
list of running daemons.
Reply With Quote
  #6  
Old 14th February 2008, 06:24 AM
kilen Offline
Registered User
 
Join Date: Feb 2008
Posts: 3
Quote:
Originally Posted by mdebusschere
Try setting clocksource=hpet or as need as kernel param.
Ok, what kind of clocksource is that?

Quote:
Also, I always though powersaving related items were causing the problems.
I don't recall if tried to disable all the possible scenarios.
Yesterday I rebooted the server with the kernel param acpi=off. And this morning the server is still running without problems. The time hasn't jumpt and backup finnished successfully. Hopefully the server will continue working now, but I'll have to wait a couple of days and see.

If not, I'll try the clocksource param.

Last edited by kilen; 14th February 2008 at 06:27 AM.
Reply With Quote
  #7  
Old 20th February 2008, 07:30 AM
kilen Offline
Registered User
 
Join Date: Feb 2008
Posts: 3
My problem seems to be solved. After the server was booted with the kernel param "acpi=off", it has been running for severel days without any problems.

It seems like the acpi isn't compatible with the CPU.
Reply With Quote
Reply

Tags
2600, clock, dell, fedora8, forward, jumps, poweredge

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
System clock shifting two hours forward on boot Belegdol Using Fedora 2 31st July 2005 07:34 AM
Dell Inspiron 2600 ACPI jgeorgeson Hardware & Laptops 0 28th February 2005 04:34 AM
System clock slow; Hardware clock fine voxelbox Using Fedora 8 23rd September 2004 04:43 AM
FC2 and PowerEdge 2600 wiz561 EOL (End Of Life) Versions 3 11th August 2004 09:53 PM


Current GMT-time: 10:48 (Sunday, 20-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat