Fedora Linux Support Community & Resources Center
  #1  
Old 26th March 2006, 12:13 PM
marco75 Offline
Registered User
 
Join Date: Mar 2005
Posts: 35
Angry rpmdb: Program version 4.3 doesn't match environment version

I'm running FC3. I use Synaptic for software management. I have not run it in quite a while, so I was surprised to find it broke itself on the last system update:

# apt-get update
Get:1 http://mirrors.kernel.org fedora/3/i386 release [1389B]
Get:2 http://rpm.livna.org fedora/3/i386 release [1106B]
Get:3 http://wftp.tu-chemnitz.de fedora/3/en/i386 release [505B]
Get:4 http://apt.atrpms.net fedora/3/en/i386 release [516B]
Get:5 http://ayo.freshrpms.net fedora/linux/3/i386 release [2136B]
Get:6 http://newrpms.sunsite.dk redhat/en/i386/fc3 release [496B]
Fetched 6148B in 11s (540B/s)
Hit http://mirrors.kernel.org fedora/3/i386/os pkglist
Hit http://rpm.livna.org fedora/3/i386/stable pkglist
Hit http://mirrors.kernel.org fedora/3/i386/os release
Hit http://mirrors.kernel.org fedora/3/i386/updates pkglist
Hit http://mirrors.kernel.org fedora/3/i386/updates release
Hit http://mirrors.kernel.org fedora/3/i386/extras pkglist
Hit http://mirrors.kernel.org fedora/3/i386/extras release
Hit http://wftp.tu-chemnitz.de fedora/3/en/i386/dag pkglist
Hit http://ayo.freshrpms.net fedora/linux/3/i386/core pkglist
Hit http://apt.atrpms.net fedora/3/en/i386/at-stable pkglist
Hit http://wftp.tu-chemnitz.de fedora/3/en/i386/dag release
Hit http://ayo.freshrpms.net fedora/linux/3/i386/core release
Hit http://ayo.freshrpms.net fedora/linux/3/i386/updates pkglist
Hit http://ayo.freshrpms.net fedora/linux/3/i386/updates release
Hit http://ayo.freshrpms.net fedora/linux/3/i386/freshrpms pkglist
Hit http://ayo.freshrpms.net fedora/linux/3/i386/freshrpms release
Hit http://rpm.livna.org fedora/3/i386/stable release
Hit http://apt.atrpms.net fedora/3/en/i386/at-stable release
Hit http://newrpms.sunsite.dk redhat/en/i386/fc3/newrpms pkglist
Hit http://newrpms.sunsite.dk redhat/en/i386/fc3/newrpms release
rpmdb: Program version 4.3 doesn't match environment version
error: db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages index using db3 - (-30974)
error: cannot open Packages database in /var/lib/rpm
E: could not open RPM database

This seems quite stupid ... why doesn't the RPM system rebuild the database itself using the package headers?

I have also tried:

# yum clean all
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

No module named cElementTree

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.1 (#1, Jun 21 2005, 02:38:47)
[GCC 3.4.3 20050227 (Red Hat 3.4.3-22.fc3)]

If you cannot solve this problem yourself, please go to
the yum faq at:
http://wiki.linux.duke.edu/YumFaq

What's the command to rebuild the RPM database?

How do I avoid apt-get / synaptic messing itself up in the future?

Thanks for your time looking at this.

Marco

-- I have attached relevant config files.
Attached Files
File Type: gz apt.conf.tar.gz (485 Bytes, 233 views)
File Type: gz sources.list.tar.gz (433 Bytes, 176 views)
File Type: gz yum.conf.tar.gz (2.4 KB, 264 views)
Reply With Quote
Reply

Tags
environment, match, program, rpmdb, version

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel-devel package with version between the fedora and update repo version Cajga Installation, Upgrades and Live Media 2 13th September 2009 06:46 PM
Yum Installing Old Version of Program jazzer386 Using Fedora 3 31st August 2008 01:29 AM
F8=>F9 upgrade, lost X--module doesn't match server version scottro Using Fedora 4 17th June 2008 03:34 PM
db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH: Database environment version lk95jofr Installation, Upgrades and Live Media 4 31st July 2006 10:32 AM


Current GMT-time: 17:55 (Monday, 20-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Triggiano Photos - Dellys - Mandapeta