Fedora Linux Support Community & Resources Center
  #1  
Old 26th March 2006, 02:48 PM
DaleEMoore Offline
Registered User
 
Join Date: Apr 2005
Location: San Antonio, Texas
Age: 61
Posts: 85
rpm error %preun() scriptlet failed?

Hi All,

RPM isn't removing a package for me, and I'm unsure how to get rid of the package. I've looked into forcing rpm to uninstall freenx but have yet to find a solution. I've tried yum and yumex with no improvement. Here's the focus of my problem:

# rpm -e freenx
error: %preun(freenx-0.4.4-2.FC5.0.noarch) scriptlet failed, exit status 1

# rpm --rebuilddb
didn't help anything.

# rpm -q freenx
freenx-0.4.4-2.FC5.0
shows you that it's there...

Many thanks for any help,
Dale E. Moore
Reply With Quote
  #2  
Old 26th March 2006, 02:53 PM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Hi:
Try # yum remove freenx

Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #3  
Old 26th March 2006, 03:54 PM
DaleEMoore Offline
Registered User
 
Join Date: Apr 2005
Location: San Antonio, Texas
Age: 61
Posts: 85
When yum uses rpm to remove freenx it fails, too.

When yum uses rpm to remove freenx it fails, too:

# yum remove freenx
Loading "installonlyn" plugin
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package freenx.noarch 0:0.4.4-2.FC5.0 set to be erased
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Removing:
freenx noarch 0.4.4-2.FC5.0 installed 152 k

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 0 Package(s)
Remove 1 Package(s)
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
error: %preun(freenx-0.4.4-2.FC5.0.noarch) scriptlet failed, exit status 1

Removed: freenx.noarch 0:0.4.4-2.FC5.0
Complete!
Reply With Quote
  #4  
Old 26th March 2006, 04:51 PM
w5set Offline
Registered User
 
Join Date: Feb 2005
Location: ark n saw out in the sticks
Posts: 2,316
rpm -qa |grep freenx
should tell ya if it's still installed.
Reply With Quote
  #5  
Old 26th March 2006, 05:40 PM
DaleEMoore Offline
Registered User
 
Join Date: Apr 2005
Location: San Antonio, Texas
Age: 61
Posts: 85
I'm certain it's still there.

# rpm -qa | grep freenx
freenx-0.4.4-2.FC5.0
# rpm -q freenx
freenx-0.4.4-2.FC5.0
Reply With Quote
  #6  
Old 26th March 2006, 06:00 PM
DaleEMoore Offline
Registered User
 
Join Date: Apr 2005
Location: San Antonio, Texas
Age: 61
Posts: 85
Thanks for all y'alls thoughts; I found it at https://bugzilla.redhat.com/bugzilla/query.cgi by searching for "rpm error %preun scriptlet failed". This seems to have worked:

# rpm -e freenx --noscripts
Reply With Quote
  #7  
Old 14th February 2007, 03:03 AM
newleonne Offline
Registered User
 
Join Date: Sep 2005
Posts: 18
Quote:
Originally Posted by DaleEMoore
Thanks for all y'alls thoughts; I found it at https://bugzilla.redhat.com/bugzilla/query.cgi by searching for "rpm error %preun scriptlet failed". This seems to have worked:

# rpm -e freenx --noscripts
Great !! and thank you.

This worked for me too. Funny that I got the same error with freenx
Reply With Quote
  #8  
Old 5th February 2014, 11:36 PM
mianosm Offline
Registered User
 
Join Date: Sep 2007
Posts: 4
linuxchrome
Re: rpm error %preun() scriptlet failed?

Found this thread through a google search and wanted to say that it helped me as well.

Hate to grave dig, but at the same time this was immensely useful in figuring out why:

rpm -e <package_name>

or

yum remote <package_name>

would continually fail.

Hopefully other people who end up using Google to troubleshoot will also find it useful.
Reply With Quote
Reply

Tags
%preun, error, failed, rpm, scriptlet

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rpm doesn't work - scriptlet failed, exit status 255 vsem Using Fedora 5 11th April 2006 01:15 AM
gstreamer scriptlet failed, exit status 127 oleanj Using Fedora 0 10th November 2005 11:02 AM
rpm error: %post scriptlet failed, exit status 255 micattack Using Fedora 1 31st October 2005 03:50 PM
RPM installation - scriptlet failed, exit status 255 Entity Using Fedora 1 27th February 2005 10:43 PM


Current GMT-time: 18:40 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat