Fedora Linux Support Community & Resources Center
  #1  
Old 4th April 2006, 06:02 PM
tbl Offline
Registered User
 
Join Date: May 2005
Location: France (Bretagne)
Age: 47
Posts: 360
howto disable automount usb-devices...

Hi all
I am working (as tester only ) on GParted project. and we have a problem around the automount of usb partitions :
When running GParted, if i want to create a new partition, during the proces, the very-next-new partition is mounted, and it makes the proces failed !

So we are looking for a way to disable automount just when running GParted, and enable after closing.

SO the question is : howto disable automount when running a soft ? what syntax to add....

Of course, if i disable automount (running "gnome-volume-information" and uncheck the first line), then i have no error. But it is what we would like to make this automaticaly, for users comfort
PS : working on gnome !

thx a bunch
__________________
LarryT, GParted-project Admin
Main site : http://gparted.sourceforge.net/index.php

Last edited by tbl; 4th April 2006 at 06:08 PM.
Reply With Quote
  #2  
Old 4th April 2006, 06:26 PM
daverj Offline
Registered User
 
Join Date: Jan 2006
Location: Denver, CO USA
Posts: 670
I believe usb devices are automounted thru the haldaemon. If you stop this service your problem would then be solved. It can always be started after you are through. Give it a shot and see.

Dave
Reply With Quote
  #3  
Old 4th April 2006, 07:17 PM
tbl Offline
Registered User
 
Join Date: May 2005
Location: France (Bretagne)
Age: 47
Posts: 360
yep ! thx.
But the problem is that even when disabling haldeamon, the unew usb partition is automounted during its creation
that's not good
__________________
LarryT, GParted-project Admin
Main site : http://gparted.sourceforge.net/index.php
Reply With Quote
Reply

Tags
automount, disable, howto, usbdevices

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How Do I Disable Automount? robertfdawson Hardware & Laptops 27 4th April 2009 06:34 AM
Non-root cannot automount USB or CD/DVD devices mbratch Using Fedora 12 24th December 2007 07:38 PM
usb devices no longer automount th350urc3 Using Fedora 2 9th June 2007 06:40 AM
Automount of USB Devices is not working spamllama2000 Hardware & Laptops 3 6th February 2007 12:17 AM
devices don't automount weinerdogus Using Fedora 2 1st April 2006 12:38 AM


Current GMT-time: 02:44 (Saturday, 02-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat