Fedora Linux Support Community & Resources Center
  #1  
Old 9th May 2006, 09:33 PM
aaronmac3232 Offline
Registered User
 
Join Date: May 2006
Posts: 5
Windows says Samba share is write protected

I'm tired of the slow performance of Windows file sharing, so I'm playing around with samba in FC5 as a possible replacement for my home file server. I have created a share in FC5 using the Samba configuration tool, and I am able to access it from my Windows machine. The problem is that the share is read-only even though I checked the "writeable" box in the samba config utility. When I try to write a file to the share from a Windows machine I get a message that says "Access is denied. Make sure the disk is not full or write-protected...." I can copy files from the share just fine.

The directory that I've shared is /share/test, and here are the local permissions assigned to the folder:

[root@localhost share]# pwd
/share
[root@localhost share]# ls -l
total 8
drwxrwxrwx 2 aaron aaron 4096 May 9 15:01 test
[root@localhost share]#

Through the samba config utility I have created a user named aaron, and assigned that user to the share. When I connect to the share from Windows I use the username and password I created for samba, but access is read-only.

Any thoughts?
Reply With Quote
  #2  
Old 9th May 2006, 09:39 PM
frharris27 Offline
Registered User
 
Join Date: May 2006
Posts: 12
Take a look at the permissions on the linux file system, not just the samba share conf. Make sure they're writable for all the users who will be accessing it.
Reply With Quote
  #3  
Old 9th May 2006, 09:41 PM
webdude Offline
Registered User
 
Join Date: Dec 2005
Posts: 23
I had the same problem. There was a setting on the config in the program for samba that I have to change from User to Share. That fixed the problem.

Cheers.
Reply With Quote
  #4  
Old 9th May 2006, 09:42 PM
aaronmac3232 Offline
Registered User
 
Join Date: May 2006
Posts: 5
I used chmod 777 on the directory that I am sharing, and I used chown to set the owner to aaron before I posted my problem, and it didn't make any difference. Is there a samba user that I need to assign to the directory?
Reply With Quote
  #5  
Old 9th May 2006, 09:56 PM
aaronmac3232 Offline
Registered User
 
Join Date: May 2006
Posts: 5
Quote:
Originally Posted by webdude
I had the same problem. There was a setting on the config in the program for samba that I have to change from User to Share. That fixed the problem.

Cheers.
I tried using share authentication instead of user authentication, but Windows still says the share is write-protected. Maybe its because I'm using active directory. The machine that I am using to connect to the samba share is my Windows Server 2003 box. I will try connecting from a Windows XP machine and report back.
Reply With Quote
  #6  
Old 9th May 2006, 10:03 PM
aaronmac3232 Offline
Registered User
 
Join Date: May 2006
Posts: 5
Well, it has nothing to do with active directory, as I tried using a stand alone Windows XP machine to connect to the samba share and it was still read only. I also checked the smb.conf file and confirmed that the share is set to writeable. It must have something to do with the file permissions assigned to the directory itself, but I used chmod 777 command to give full access to all users so I'm not sure what else to try.
Reply With Quote
  #7  
Old 9th May 2006, 10:17 PM
frharris27 Offline
Registered User
 
Join Date: May 2006
Posts: 12
Can you post the part of your smb.conf file that shows the share? I seem to remember that there's this issue of "writeable" versus "writable". It's very easy to mess up the spelling and I wouldn't be surprised if the config tools get it wrong.

Also, do your logs say anything abou it? I think there's a /var/log/smb directory or something like that.
Reply With Quote
  #8  
Old 9th May 2006, 10:20 PM
frharris27 Offline
Registered User
 
Join Date: May 2006
Posts: 12
Oh yeah. Have you looked at Selinux regarding this? You may want to turn it off for samba.
Reply With Quote
  #9  
Old 9th May 2006, 10:36 PM
aaronmac3232 Offline
Registered User
 
Join Date: May 2006
Posts: 5
SELinux was the culprit. I changed it from Enforcing to Disabled and now I can write to the share from Windows. Thanks for your help!
Reply With Quote
Reply

Tags
protected, samba, share, windows, write

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba share as read only w/ admin write access.... exutable Servers & Networking 6 19th July 2008 06:17 AM
FC5 Samba Share - Can't write arckid Servers & Networking 4 6th January 2007 11:23 PM
Cannot write to Samba share(s) Prizzle Servers & Networking 2 5th December 2006 06:58 PM
Cannot write in Samba share when it runs as smbd -D s3ntry666 Servers & Networking 1 24th October 2006 01:58 PM


Current GMT-time: 01:49 (Friday, 25-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat