Fedora Linux Support Community & Resources Center
  #1  
Old 20th May 2006, 12:32 AM
bajo Offline
Registered User
 
Join Date: May 2006
Posts: 1
Wake On LAN

How can I use the WOL?
In the BIOS the WOL is enabled. In Windows it worked with the NIC.
Now in Linux fc5 I want to use it but it does not work.
If I use ethtool -s eth0 wol g it is oke if I look with ethtool eth0.
But after a reboot it is set back to disabbled.
I am wandering what I have to do to get it working.
Where do I have to look ?
Reply With Quote
  #2  
Old 8th June 2006, 08:02 PM
maestronn Offline
Registered User
 
Join Date: Feb 2004
Location: OH
Posts: 1
Apparantly you need to some how prevent fedora from shutting down the network devices during the shutdown process. I've been trying to get WOL working on my FC box for a few days now too. I found this http://gentoo-wiki.com/Wake_on_lan that give a general idea of what's needed but I haven't figured out how to do this in Fedora.
Does anyone know what scripts to edit or where to look to prevent fedora shutting down the network devices?
Reply With Quote
  #3  
Old 12th June 2006, 04:48 AM
toolazy2p Offline
Registered User
 
Join Date: Feb 2006
Location: Texas
Posts: 19
Quote:
Originally Posted by bajo
How can I use the WOL?
In the BIOS the WOL is enabled. In Windows it worked with the NIC.
Now in Linux fc5 I want to use it but it does not work.
If I use ethtool -s eth0 wol g it is oke if I look with ethtool eth0.
But after a reboot it is set back to disabbled.
I am wandering what I have to do to get it working.
Where do I have to look ?
WOL works for me, but after reboot wake-on gets set back to disabled as well. Does anyone know how to fix this?
Reply With Quote
  #4  
Old 12th June 2006, 08:28 AM
toolazy2p Offline
Registered User
 
Join Date: Feb 2006
Location: Texas
Posts: 19
Quote:
Originally Posted by toolazy2p
WOL works for me, but after reboot wake-on gets set back to disabled as well. Does anyone know how to fix this?
I managed to find a solution. I added a script to the boot sequence to re-enable wol.
Code:
su -

gedit /etc/rc.d/rc.local
In rc.local, I added the line /user/sbin/ethtool -s eth0 wol g. Saved, rebooted. Ran ethtool eth0 as root and tada!...happy me.
Reply With Quote
  #5  
Old 25th July 2006, 10:20 AM
marisdembovskis Offline
Registered User
 
Join Date: Mar 2006
Location: Gulbene - Latvia - Europe
Age: 31
Posts: 292
I did:
su -
gedit /etc/rc.d/rc.local
inserted line:
/usr/sbin/ethtool -s eth0 wol g.
saved.


Now i switch off the pc.
And from another pc tried to wake the first pc up with command
ssh 192.168.....
and also
ping 192.168.....

But nothing happens, pc does not wake up.
However if I unplug the RJ 45 cable, pc starts. ???

Any ideas, what is wrong?
Thanks
__________________
Jesus will back you UP!
Maris Dembovskis
Your life is the same as you.
---
my box=F 10 Toshiba R200 = nice & cool
was using ubuntu for a year, return to Fedora. :) Faster.
Reply With Quote
  #6  
Old 25th July 2006, 10:34 AM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Hello:
Dunno if this will help you or not, however, have you tried # ether-wake 192.168........
Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #7  
Old 25th July 2006, 10:38 AM
pigpen Offline
Registered User
 
Join Date: Nov 2003
Location: Regensburg, Germany
Age: 43
Posts: 447
The most used commands to wake a PC via a magic packet are:
1. ethtool (from the ethtool package) and
2. ether-wake (from the net-tools package).
Neither ssh nor ping will work.

In order to put the card into WOL mode I just had to add "wol_enable=1" to the line in /etc/modprobe.conf in which the options for the network card are set.
__________________
/(bb|[^b]{2})/ -- that is the question!
Reply With Quote
  #8  
Old 25th July 2006, 12:04 PM
marisdembovskis Offline
Registered User
 
Join Date: Mar 2006
Location: Gulbene - Latvia - Europe
Age: 31
Posts: 292
1. I have ethtool installed
2. added /usr/sbin/ethtool -s eth0 wol g
in /etc/rc.d/rc.local
3. added wol_enable=1
in /etc/modprobe.conf

Tried to start remote pc with addres 192.168... and Mac 00:14:85:34......
with command:
ether-wake 00:14:85:34......
answer: SIOCGIFHWADDR on eth0 failed: No such device


and command:
ether-wake 192.168.1.201
answer:
ether-wake: The Magic Packet host address must be specified as
- a station address, 00:11:22:33:44:55, or
- a hostname with a known 'ethers' entry.


???
Thanks for help guys!
__________________
Jesus will back you UP!
Maris Dembovskis
Your life is the same as you.
---
my box=F 10 Toshiba R200 = nice & cool
was using ubuntu for a year, return to Fedora. :) Faster.
Reply With Quote
  #9  
Old 25th July 2006, 12:17 PM
Seve Offline
Retired Community Manager
 
Join Date: Oct 2004
Location: The GTA, Ontario, Canada
Age: 56
Posts: 12,371
Hello:
Hello:
Check your /etc/ethers file and make sure that the target mac address is present. Then, unless the nic card in the target box is mis-configured, ether-wake should work.
hth
Seve
__________________
Registered Linux User: #384977
.................................................. ............
See the Links below for more Help and those much wanted extras ... :)
Reply With Quote
  #10  
Old 25th July 2006, 12:35 PM
marisdembovskis Offline
Registered User
 
Join Date: Mar 2006
Location: Gulbene - Latvia - Europe
Age: 31
Posts: 292
Uups, I don't have /etc/ethers file at all!
I have:
eclipse.conf environment exports
enscript.cfg esd.conf exports.bak

what can I do?
__________________
Jesus will back you UP!
Maris Dembovskis
Your life is the same as you.
---
my box=F 10 Toshiba R200 = nice & cool
was using ubuntu for a year, return to Fedora. :) Faster.
Reply With Quote
Reply

Tags
lan, wake

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F10 can't wake from suspend using WOL but can wake from shutdown jonmyatt Using Fedora 1 2nd July 2009 10:35 AM
Can't wake up TheCigarman Using Fedora 0 13th August 2008 05:18 PM
Wake on Lan keatonvictor Hardware & Laptops 0 3rd January 2008 08:29 PM
what is wake on lan (WOL) agenol Hardware & Laptops 3 13th July 2005 05:03 PM


Current GMT-time: 15:15 (Tuesday, 22-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat