Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Servers & Networking
FedoraForum Search

Forgot Password? Join Us!

Servers & Networking Discuss any Fedora server problems and Networking issues such as dhcp, IP numbers, wlan, modems, etc.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 8th July 2006, 11:18 AM
rantanplan Offline
Registered User
 
Join Date: Oct 2004
Location: Germany
Age: 43
Posts: 125
Unhappy All kernel above 2133 disconnects randomly from DSL internet connection

I have DSL flatrate connection with an Fritz!Box Router/Modem.
Never had problems until i updated to kernel-2.6.17-1.2139_FC5.i686.
I hoped it's temporarily and thought it's gone with kernel-2.6.17-1.2145_FC5.i686. But
still the same problem. I am now at kernel-2.6.16-1.2133_FC5.i686 and all works fine.
So i think it's definitely a problem with the newest kernels.

With kernel 2139 or 2145 i tried to fiddle around somehow but don't know exactly how. ifconfig shows
eth0 is all ok. I use usb connection.

It's not really disconnecting as i have still my VoiceOverIP telephone connection. So it doesnt disconnect from dsl but the connection is at one point stucked. And firefox is not possible to connect to any site.
Even the WebFrontend for the router is not accessible.

Any ideas what have changed that i have this problems ?

Thanks
__________________
No bugs, no hugs, no virus, no spiritus. :rolleyes:

Last edited by rantanplan; 8th July 2006 at 11:21 AM. Reason: Better problem description
Reply With Quote
  #2  
Old 20th July 2006, 01:47 AM
rapik Offline
Registered User
 
Join Date: Apr 2006
Posts: 5
Some Problem

Hi.....This happend too me...i dont know what is the problem....iam using the old old (2.6.15....) kernel because some problem.......I hope anybody help us.....

See you.....
Reply With Quote
  #3  
Old 20th July 2006, 01:09 PM
ganesanrajesh Offline
Registered User
 
Join Date: Aug 2004
Location: India
Age: 41
Posts: 4
same to me

Yes, it happens to me too. Especially when I use network manager. When I turn NM service off and use system-control-network, everything works fine.
Reply With Quote
  #4  
Old 24th July 2006, 01:21 AM
rantanplan Offline
Registered User
 
Join Date: Oct 2004
Location: Germany
Age: 43
Posts: 125
I thought it could be the usb kernel module or something with firestarter because i get errors foriptables is not available etc. and firestarter.lock can not be accessed. I don't have the right errors i will write it down.
Maybe someone of you find a solution.

@ganesanrajesh
i tried to disable the NM but no difference. After some time. The connection (especially at downloads) stands still. No error only void.....

cu
__________________
No bugs, no hugs, no virus, no spiritus. :rolleyes:
Reply With Quote
  #5  
Old 25th July 2006, 07:51 AM
VisezTrance Offline
Registered User
 
Join Date: Jan 2006
Posts: 39
Hello
I think i'm having the same problem. I'm using fedora core 5 as a router, and after a full update my internet connection sometimes just stops. I have to restart the network service to get the internet working again and firestarter to get internet sharing work *again*. I'm using a usb cable modem. The problem is that i didn't knew what has caused this (until reading this thread), so a day later i did another full update, and the kernel was updated again, and i can't boot using the precedent kernel. How did you roll back to a 2.6.1.x kernel ?
Reply With Quote
  #6  
Old 25th July 2006, 10:05 AM
rantanplan Offline
Registered User
 
Join Date: Oct 2004
Location: Germany
Age: 43
Posts: 125
Lightbulb

You can download the older kernel-RPM manually from the fedora servers and then install as root
with yum --localinstall <package>. This worked for me. The good thing is. Even if you make 'yum update' and there is a newer kernel. This kernel which you installed manually will not be overwritten. It's now forever ....

The other thing to this problem is i disconnected my dsl router/modem from usb and switched to LAN-cable.
Until now all seems to me pretty good. I try some greater downloads and we will see....
My thoughts are, as i mentioned above, there IS something with the usb-module which lacks sometimes with dsl routers/modems. But i don't figure out what it is.

The strange thing i had now since yesterday is that i got a boot message, right after udev, which said that in '/etc/modprobe.conf' line 6 an illegal entry is. There was 'option usbnet'. I deleted it manually. The error-message is gone.

And still the messages. firestarter can't remove lock from /var/lock/firestarter. I DISABLED firestarter. Only having iptables running. And still this message ? What is here wrong ?
Also 'can't enable eth0' as boot but after that all is running.



Would be nice if anyone has a solution.

cu
__________________
No bugs, no hugs, no virus, no spiritus. :rolleyes:
Reply With Quote
  #7  
Old 25th July 2006, 01:33 PM
VisezTrance Offline
Registered User
 
Join Date: Jan 2006
Posts: 39
I did a yum local install as you said .. and it works!
(it usually would have disconnected within 2 minutes if i had the network dispatcher service activated)
Many thanks. I hope this issue will be fixed soon.
By the way .. "can't remove lock from /var/lock/firestarter." .. i had this message during boot up, however firestarter still worked well.
I think i should buy another network card and stop using the USB ..
Reply With Quote
  #8  
Old 25th July 2006, 01:37 PM
rantanplan Offline
Registered User
 
Join Date: Oct 2004
Location: Germany
Age: 43
Posts: 125
Talking

Yep, thats it. Until now, about 4 hours and many files downloaded, i had no connection breakup.
Try an network-cable and don't use USB anymore. It works well now.
Maybe they get this fixed in FC6 or another kernel.

cu
__________________
No bugs, no hugs, no virus, no spiritus. :rolleyes:
Reply With Quote
  #9  
Old 30th July 2006, 08:03 PM
cmsps Offline
Registered User
 
Join Date: Oct 2005
Location: Sheffield, UK
Age: 66
Posts: 28
I'm suffering from this one too! My question is: where do you download the old kernel RPM from? I've looked all over the Fedora site and can't find any.

TIA
Peter
Reply With Quote
  #10  
Old 31st July 2006, 06:13 AM
VisezTrance Offline
Registered User
 
Join Date: Jan 2006
Posts: 39
The exact kernel i downloaded was this one http://download.fedora.redhat.com/pu...3_FC5.i586.rpm
In my haste to make the internet connection work i've downloaded the first kernel i could find, even though i don't have a SMP machine . Works great.
Reply With Quote
  #11  
Old 31st July 2006, 05:36 PM
rantanplan Offline
Registered User
 
Join Date: Oct 2004
Location: Germany
Age: 43
Posts: 125
Thumbs down USB or LAN cable

My question to you all is:
Has anyone of you who has this problem his router wired with USB cable ? Or does anyone has this
problem with LAN cable (ethernet card, on-board or PCI) ?

How i said above. Since i switched to Ethernet LAN cable the problem is gone and i can use the latest kernel.

@cmsps
I used the kernel-2.16 2133. It's no longer at the Fedora Site. Try rpmseek or google.
SMP is not needed and recommended. Look for i686 architecture if you have Athlon etc. (newer processor).
Thank you.
__________________
No bugs, no hugs, no virus, no spiritus. :rolleyes:

Last edited by rantanplan; 31st July 2006 at 05:43 PM.
Reply With Quote
Reply

Tags
2133, connection, disconnects, dsl, internet, kernel, randomly

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sify Internet Disconnects after 15 mins kamgos Using Fedora 9 8th April 2009 05:58 AM
Internet disconnects when performing updates JY707 Servers & Networking 0 1st April 2008 11:39 PM
Randomly no internet connection? exutable Using Fedora 4 18th October 2007 10:51 PM
Wireless Disconnects in Favor of Better Connection Cody Servers & Networking 0 30th March 2007 01:57 AM
Internet connection disconnects briefly with FC 5 Frogdude Servers & Networking 3 30th July 2006 09:27 PM


Current GMT-time: 18:05 (Thursday, 24-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat