Fedora Linux Support Community & Resources Center
  #1  
Old 7th August 2006, 07:16 AM
frodopunk Offline
Registered User
 
Join Date: May 2005
Posts: 34
volume muted everytime I reboot FC5

Hi there all, can anyone help me out with my sound being muted every time I reboot. I remember having the same problem with FC4, but now I forget how I fixed it then.I have tried "alsactl store" but I get a command not found error.
Reply With Quote
  #2  
Old 7th August 2006, 07:21 AM
u-noneinc-s Offline
Registered User
 
Join Date: Jul 2005
Location: Wine Country, California
Posts: 2,850
locate alsactl
/sbin/alsactl
/usr/sbin/alsactl
Is sbin in your path, did you try as root?
Reply With Quote
  #3  
Old 7th August 2006, 07:24 AM
frodopunk Offline
Registered User
 
Join Date: May 2005
Posts: 34
Hello, yes I did /usr/sbin/alsactl store as root, and got the command not found error?
Reply With Quote
  #4  
Old 7th August 2006, 07:52 AM
u-noneinc-s Offline
Registered User
 
Join Date: Jul 2005
Location: Wine Country, California
Posts: 2,850
Does alsactl actually exist there? You could be missing a package. I have ...
alsa-lib-1.0.11-4.rc2.i386.rpm
alsa-lib-devel-1.0.11-4.rc2.i386.rpm
alsa-tools-1.0.10-2.fc5.i386.rpm
alsa-utils-1.0.11-4.rc2.i386.rpm
alsamixergui-0.9.0-0.2.rc1.fc5.i386.rpm
Are you running gnome or KDE? KDE you can set the levels and go to the kmenu and save session. Don't know about gnome, but I've read several threads in the past that said Gnome's save doesn't work like it should.
Reply With Quote
  #5  
Old 7th August 2006, 08:04 AM
frodopunk Offline
Registered User
 
Join Date: May 2005
Posts: 34
oh I think I know what is going on now, I am using the kernel-module-alsa-2.6.16-1.2080. from the planet ccrma repo, and I have the livna kernel-2.6.17-1.2157_FC5 running now.I should have checked that first, so thats my mistake.
Reply With Quote
  #6  
Old 7th August 2006, 08:21 AM
frodopunk Offline
Registered User
 
Join Date: May 2005
Posts: 34
I have these packages,
alsa-lib-1.0.11-4.rc2
alsa-lib-devel-1.0.11-4.rc2
alsa-utils-1.0.11-4.rc2
alsa-tools-1.0.11-1.rhfc5.ccrma
alsamixergui-0.9.0-0.2.rc1.fc5
Reply With Quote
  #7  
Old 7th August 2006, 01:32 PM
wneumann Offline
Registered User
 
Join Date: Dec 2004
Posts: 512
alsa-utils installs the following (amongst other things)

/sbin/alsactl
/usr/sbin/alsactl
/usr/share/man/man1/alsactl.1.gz

according to "rpm -ql alsa-utils |grep alsactl"

Maybe you mispelled when you issued the /usr/sbin/alsactl command?

I have a line

remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0

(all on one line) in my modprobe.conf that automatically stores configuration as alsa unloads on shutdown. You'd have to modify it for your sound module if it is not intel8x0.

Last edited by wneumann; 7th August 2006 at 01:36 PM.
Reply With Quote
  #8  
Old 7th August 2006, 03:18 PM
frodopunk Offline
Registered User
 
Join Date: May 2005
Posts: 34
Hello wneumann, I have checked my modprobe conf and I have these lines concerning my soundcard, which is a soundblaster128.If snd-ens1371 is not the proper sound module name, how can I find out the proper one so that I can edit my modprobe.conf accordingly?

options snd-card-0 index=0
options snd-ens1371 index=0
remove snd-ens1371 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-ens1371

Also do I need both these lines "options snd-card index=0" and "options snd-ens1371 index=0"
Reply With Quote
  #9  
Old 7th August 2006, 04:48 PM
wneumann Offline
Registered User
 
Join Date: Dec 2004
Posts: 512
That looks like the correct driver. But I'm now puzzled myself about what runs "alsactl store" for me on shutdown. Earlier versions of fedora had an alsa service that loaded and unloaded the modules, and that was when that line would be run, but I can't see what is unloading the modules now. Maybe someone else can tell us.

In any case, whatever it is does not work for you so you might want to write your own script to run on shutdown and startup.

First you might check if /etc/asound.state is created when you shutdown. If so, your sound state is being saved and it is the restore on boot up that is failing. That would be easy to fix with a line in rc.local. Otherwise, use some simple script in /etc/init.d as a model and write a script that runs

/usr/sbin/alsactl store 0

when called with "stop"

and

/usr/sbin/alsactl restore 0

when called with "start"

If you need more guidance on this post back or send me a private message.

PS before you start writing a script check that "/usr/sbin/alsactl store 0"
and "/usr/sbin/alsactl restore 0" do actually work for you. You need to run them as root.
According to your extract from your modprobe.conf your soundcard is card 0, but I'm beginning to wonder how much fedora actually uses modprobe.conf.

Last edited by wneumann; 7th August 2006 at 04:53 PM.
Reply With Quote
  #10  
Old 7th August 2006, 05:13 PM
frodopunk Offline
Registered User
 
Join Date: May 2005
Posts: 34
Hi wneumann, yay! finally got it working properly, I deleted my asound.conf and thats all I did, and when I rebooted my computer the volume was no longer muted .I must have mucked it up somehow? Thanks much for helping me figure this out. regards, frodo
Reply With Quote
  #11  
Old 8th August 2006, 02:50 AM
frodopunk Offline
Registered User
 
Join Date: May 2005
Posts: 34
I had a look at my alsactl in sbin, but it was not set as executable, it was sitting in there as a plain text document, not sure how that came about, so I deleted it reinstalled alsa-utils and now "alsactl store" works as it should. I also ran system-config-soundcard and that regenerated my asound.conf and asound.state which I had previously deleted.
Thanks again wneuman for help.
Reply With Quote
Reply

Tags
everytime, fc5, muted, reboot, volume

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F11 audio volume changes everytime I switch to new song in any music player golgotha Using Fedora 4 3rd September 2009 08:50 AM
Volume muted when I log in... icanfly0307 Using Fedora 4 2nd February 2009 06:27 PM
F10 Live CD: Configuration rolled back everytime I reboot joshua.java Alpha, Beta & Snapshots Discussions (Fedora 10 Only) 1 11th November 2008 09:44 AM
microphone muted after reboot jim Using Fedora 2 11th November 2006 04:17 PM


Current GMT-time: 01:48 (Tuesday, 02-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat