Fedora Linux Support Community & Resources Center
  #1  
Old 8th September 2006, 11:58 PM
jyap Offline
Registered User
 
Join Date: Sep 2006
Location: Honolulu, HI
Posts: 1
beagled runs at high 100% cpu usage constantly on FC5?

Running FC5 with the latest Beagle package from the default repositories.

$ uname -a
Linux primerib 2.6.17-1.2174_FC5smp #1 SMP Tue Aug 8 16:00:39 EDT 2006 i686 i686 i386 GNU/Linux
$ cat /etc/redhat-release
Fedora Core release 5 (Bordeaux)
$ rpm -q beagle
beagle-0.2.6-1.fc5.1

CPU usage is constantly at around 100%.

Any clues? Beagle's pretty handy except for this problem.
Reply With Quote
  #2  
Old 10th November 2006, 04:57 AM
Dumbledore Offline
Registered User
 
Join Date: Jan 2006
Location: Austin, Texas (The red state's got a blue heart!)
Age: 22
Posts: 96
Run the command "gnome-system-monitor" as root. Go to the "View" tab and check "All processes". A program called "beagle-build-index" should be taking up a fairly high percentage of the CPU. Kill it. You should have no more problems for that session. Haven't figured out a long-term solution yet, sorry.
__________________
If life gives you lemons, reprogram it so it takes money from Microsoft and deposites it in your bank account! :cool:
Reply With Quote
  #3  
Old 5th December 2006, 10:46 PM
rhasselbaum Offline
Registered User
 
Join Date: May 2006
Posts: 19
Same problem here using FC6. The process I see taking 100% CPU is called "beagled" not "beagle-build-index". I can kill it, but would rather fix the problem.

Assuming the Beagle index is corrupt, is there a way to reset it?
Reply With Quote
  #4  
Old 6th December 2006, 01:13 AM
u-noneinc-s Offline
Registered User
 
Join Date: Jul 2005
Location: Wine Country, California
Posts: 2,850
Does it interfere with operation of the system? Is the system unresponsive because of this? Does the system still run fine ie, no delays in keystrokes or mouse clicks or even pointer motion?
I killed beagled on my FC5 because of this and the system was unresponsive, but I read that it is not a problem on fc6 as it is supposed to take advantage of "idle time", and release the CPU when needed by other apps.
__________________
Mark N.

Perpetual Newbie
--
I wanted to proclaim myself "The Typo King" but there's way too much competion. :p

411874 Get Counted
Reply With Quote
  #5  
Old 6th December 2006, 01:29 AM
jtang613 Offline
Registered User
 
Join Date: Apr 2004
Location: Ottawa, Canada
Posts: 1,931
Quote:
Originally Posted by u-noneinc-s
Does it interfere with operation of the system? Is the system unresponsive because of this? Does the system still run fine ie, no delays in keystrokes or mouse clicks or even pointer motion?
I killed beagled on my FC5 because of this and the system was unresponsive, but I read that it is not a problem on fc6 as it is supposed to take advantage of "idle time", and release the CPU when needed by other apps.
I removed beagled because it constantly abused CPU idle time. Whenever I left my PC for more than a few minutes, beagled would take over, spinning both CPU and disk, and never completing whatever it was doing. It would run all night, and still not finish its task.

However, beagled would switch itself idle, when I began using my system - but that's not really my concern. No periodic deamon (such as beagled) should spin both CPU and disk 24/7 without interruption. It's unnecessary, it's annoying, and it smacks of a big bug.

m2c,
Jason
__________________
There is no 'CTRL' button on Chuck Norris's computer. Chuck Norris is always in control.
Reply With Quote
  #6  
Old 6th December 2006, 01:40 AM
u-noneinc-s Offline
Registered User
 
Join Date: Jul 2005
Location: Wine Country, California
Posts: 2,850
For me, locate is good enough. If I can't remember a filename (or even part of a filename) then I probably won't remember any relevant text string to search either. (Must be that CRS syndrome)
I believe beagle is "supposed' to be very thorough in searches though finding any word (or search string) in any and all files on your system. (?)
__________________
Mark N.

Perpetual Newbie
--
I wanted to proclaim myself "The Typo King" but there's way too much competion. :p

411874 Get Counted
Reply With Quote
  #7  
Old 6th December 2006, 02:47 PM
rhasselbaum Offline
Registered User
 
Join Date: May 2006
Posts: 19
Quote:
Originally Posted by u-noneinc-s
Does it interfere with operation of the system? Is the system unresponsive because of this? Does the system still run fine ie, no delays in keystrokes or mouse clicks or even pointer motion?
My FC6 system is still responsive. But I agree with Jason that this is beside the point. I can't think of a legit reason it should be running constantly. Plus, i sometimes run long build processes in the background with "nice" that will presumably compete with Beagle now. What's it doing?
Reply With Quote
  #8  
Old 6th December 2006, 02:56 PM
u-noneinc-s Offline
Registered User
 
Join Date: Jul 2005
Location: Wine Country, California
Posts: 2,850
I killed it before it ever completed because my sys was unresponsive so I never got the chance to use it, but I believe it is cataloging every file and quite possibly every word IN every file.
__________________
Mark N.

Perpetual Newbie
--
I wanted to proclaim myself "The Typo King" but there's way too much competion. :p

411874 Get Counted
Reply With Quote
  #9  
Old 8th December 2006, 04:15 PM
rhasselbaum Offline
Registered User
 
Join Date: May 2006
Posts: 19
There is extensive talk about this on Launchpad (Ubuntu):

https://launchpad.net/distros/ubuntu...gle/+bug/64326

Bottom line is that later versions of Beagle (>0.2.12) solve at least some problems related to high CPU usage. If there isn't a Fedora bug filed about this already, I'll enter one. Hopefully, Fedora repos can be updated sooner rather than later. :-/
Reply With Quote
  #10  
Old 10th December 2006, 04:06 AM
andyschlei Offline
Registered User
 
Join Date: Apr 2006
Posts: 20
How do you stop it from running? It doesn't show up as a service and it is not in /etc/rc.d/init.d/
Reply With Quote
  #11  
Old 10th December 2006, 04:14 AM
u-noneinc-s Offline
Registered User
 
Join Date: Jul 2005
Location: Wine Country, California
Posts: 2,850
I'm not sure anymore since I removed it, but I think it should be in the service manager
Code:
system-config-services
__________________
Mark N.

Perpetual Newbie
--
I wanted to proclaim myself "The Typo King" but there's way too much competion. :p

411874 Get Counted
Reply With Quote
  #12  
Old 10th December 2006, 04:20 AM
andyschlei Offline
Registered User
 
Join Date: Apr 2006
Posts: 20
No, it is not there. I did find a daily cron job that must get picked up when the system catches up.

I just uninstalled it ('yum remove beagle'). I don't want a "total index" of my workspace. 'locate' works fine for me.
Reply With Quote
  #13  
Old 25th December 2006, 10:06 PM
Trek1701 Offline
Registered User
 
Join Date: Jul 2005
Location: Vulcan
Posts: 284
Quote:
Originally Posted by andyschlei
No, it is not there. I did find a daily cron job that must get picked up when the system catches up.

I just uninstalled it ('yum remove beagle'). I don't want a "total index" of my workspace. 'locate' works fine for me.
Try this:

System > Preferences > More Preferences > Sessions

Go to tab "Start Programs", select "beagled --autostarted" and click disable.

On next boot beagled will not load for this user.

Trek1701
__________________
P.S. Never take candy from strangers... money is ok, but not candy.

FC 12 - 64 bits

Dell Vostro 1710 | Intel Core 2 Duo T9500 @ 2.60GHz | DDR 2GB | nVidia GeForce 8600M GS 512MB | WLAN Broadcom BCM4328 802.11a/b/g/n | Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller | Dell Wireless 360 Bluetooth | Seagate 5400rpm 160GB | Western Digital 5400rpm 320GB

Maemo 5

Nokia N900 | ARM Cortex A8 600 MHz | PowerVR SGX graphics | 32GB | Designed in Finland
Reply With Quote
  #14  
Old 27th December 2006, 09:36 PM
andyschlei Offline
Registered User
 
Join Date: Apr 2006
Posts: 20
Trek1701,

Thanks, this is very helpful. I didn't even know that dialog existed!
Reply With Quote
  #15  
Old 27th December 2006, 11:50 PM
RupertPupkin Offline
Registered User
 
Join Date: Nov 2006
Location: Detroit
Posts: 5,687
Quote:
Originally Posted by jtang613
I removed beagled because it constantly abused CPU idle time. Whenever I left my PC for more than a few minutes, beagled would take over, spinning both CPU and disk, and never completing whatever it was doing. It would run all night, and still not finish its task.

However, beagled would switch itself idle, when I began using my system - but that's not really my concern. No periodic deamon (such as beagled) should spin both CPU and disk 24/7 without interruption. It's unnecessary, it's annoying, and it smacks of a big bug.
Wait, you mean that an application (Beagle) that uses a Microsoft-created API (C#/.NET) was thrashing your system? I am shocked, shocked I say.
Reply With Quote
Reply

Tags
100%, beagled, constantly, cpu, fc5, high, runs, usage

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Cpu Usage. mrbones Using Fedora 11 14th September 2010 09:49 PM
F11 X Cpu usage too high Toeside Hardware & Laptops 4 22nd June 2009 10:13 PM
Acer TravelMate 4602WLMi fan runs almost constantly bravoelf Hardware & Laptops 2 1st March 2008 02:12 PM


Current GMT-time: 14:26 (Thursday, 30-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Clichy - Sidi Bouzid Instagram Photos - Malpe Photos on Instagram