Fedora Linux Support Community & Resources Center
  #1  
Old 20th November 2006, 07:18 PM
chocobanana Offline
Registered User
 
Join Date: Jun 2005
Posts: 125
Disable Gnome keyring manager

Hi there

Does anyone knows how to disable Gnome keyring manager?

Whenever I try to connect to a wireless network with networkmanager it always asks for the keyring password and this is really annoying...

Thanks!
  #2  
Old 21st November 2006, 12:34 AM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
Nope, but there is a way to automate it so it doesn't ask for the password......

http://forums.fedoraforum.org/forum/...hlight=keyring
  #3  
Old 21st November 2006, 01:31 AM
ZeusZon Offline
Registered User
 
Join Date: Oct 2006
Location: Scotland
Age: 29
Posts: 281
This is what I did according to the instructions. But fails.

Superuser:
gedit /etc/pam.d/gdm

#%PAM-1.0
auth required pam_env.so
auth optional pam_keyring.so try_first_pass
auth optional pam_ssh.so try_first_pass
auth include system-auth
account required pam_nologin.so
account include system-auth
password include system-auth
session optional pam_keyinit.so force revoke
session include system-auth
session required pam_loginuid.so
session optional pam_console.so
session optional pam_keyring.so
session optional pam_ssh.so

ensured a space at end
-------------------------------------------------
yum install pam_keyring

^FC6 version
---------------------------------------
Read that FC5 version works.
Uninstalled fc6 version

Downloaded FC5 version and installed:
http://www.hekanetworks.com/opensour...1.fc5.i386.rpm

Firewall and SElinux is off.

Still asks for password and account password and keyring password is the same.

Any ideas?
  #4  
Old 21st November 2006, 02:11 AM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
Did you use the utility to set the default keyring password to the same as the user login?? Works fine here....on FC6

Run this if you need to change the default keyring password to the same as your log-in password.

/usr/libexec/pam-keyring-tool -c

Last edited by Iron_Mike; 21st November 2006 at 02:25 AM.
  #5  
Old 21st November 2006, 08:46 PM
ZeusZon Offline
Registered User
 
Join Date: Oct 2006
Location: Scotland
Age: 29
Posts: 281
Thanks for the terminal code.

I can't figure out how to use what you have suggested. Any pointers?

Code:
[neil@M30 ~]$ /usr/libexec/pam-keyring-tool -c
pam-keyring-tool: only one keyring action my be specified on the commandline
[neil@M30 ~]$ /usr/libexec/pam-keyring-tool -c password
pam-keyring-tool: only one keyring action my be specified on the commandline
[neil@M30 ~]$ /usr/libexec/pam-keyring-tool -?
Usage:
  pam-keyring-tool [OPTION...] 

Help Options:
  -?, --help            Show help options

Application Options:
  -u, --unlock          Unlock Keyring
  -g, --get-default     Get Default Keyring
  -s, --use-stdin       Use stdin for Password Prompt
  --keyring=name        Name of Keyring

[neil@M30 ~]$
Edit: They are the same already. But through I would try and reset.
  #6  
Old 21st November 2006, 09:20 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
If you can't get it to work, you can download the gnome-keyring-manager package from the same sit and use the gui interface
  #7  
Old 21st November 2006, 11:37 PM
admun Offline
Registered User
 
Join Date: May 2005
Location: Ottawa, Canada
Posts: 40
Hi,

I am able to get to work on FC6, here's the steps I did:

1) install keyring manager
2) delete all keys
3) change /etc/pam.d/gdm to the following

#%PAM-1.0
auth required pam_env.so
auth optional pam_keyring.so try_first_pass
auth include system-auth
account required pam_nologin.so
account include system-auth
password include system-auth
session include system-auth
session required pam_loginuid.so
session optional pam_console.so
session optional pam_keyring.so

4) reboot
5) login, besure to enter the same default key as your login's password

Hope this help.

cheers,

Last edited by admun; 21st November 2006 at 11:48 PM.
  #8  
Old 22nd November 2006, 01:27 AM
ZeusZon Offline
Registered User
 
Join Date: Oct 2006
Location: Scotland
Age: 29
Posts: 281
Thanks for your replies.

I switched to just the wpa_supplicant service without networkmanager service since I wasn't getting anywhere with keyring.

Working ok without nag screen of networkmanager/keyring.

But out of interest I tried the gdm file text information that you supplied admun.

And it works! I'm too tired to compare Iron_mikes post link of: http://forums.fedoraforum.org/forum/...hlight=keyring

Maybe I have used the same code before? but it didn't work. Maybe a little parsing error with using copy+paste.

It's a shame gnome's auto-login doesn't work with this.

Need to head off.
Many thanks
  #9  
Old 22nd November 2006, 05:44 AM
admun Offline
Registered User
 
Join Date: May 2005
Location: Ottawa, Canada
Posts: 40
Quote:
Originally Posted by ZeusZon
Thanks for your replies.

I switched to just the wpa_supplicant service without networkmanager service since I wasn't getting anywhere with keyring.

Working ok without nag screen of networkmanager/keyring.

But out of interest I tried the gdm file text information that you supplied admun.

And it works! I'm too tired to compare Iron_mikes post link of: http://forums.fedoraforum.org/forum/...hlight=keyring

Maybe I have used the same code before? but it didn't work. Maybe a little parsing error with using copy+paste.

It's a shame gnome's auto-login doesn't work with this.

Need to head off.
Many thanks
Good to know it works now. I think it's something to do with order of the lines.....
  #10  
Old 5th December 2006, 12:48 AM
hondaman Offline
Registered User
 
Join Date: Apr 2004
Posts: 48
Just wanted to chime in and say thanks for the info. Fixed it for me on fc6. It wasnt working until I installed pam_keyring, logged in manually, rebooting, and it worked.

Thanks again.

:EDIT:

haha, I guess I spoke too soon. This works when you manually login. However, if you set to auto login, it doesnt work for me. I get the keyring password prompt.

Is there a way to make it promptless? No logins, no password nag screens, just boots and connects to the wireless seamlessly?

Last edited by hondaman; 5th December 2006 at 12:58 AM.
  #11  
Old 5th December 2006, 02:30 PM
admun Offline
Registered User
 
Join Date: May 2005
Location: Ottawa, Canada
Posts: 40
Quote:
Originally Posted by hondaman
Just wanted to chime in and say thanks for the info. Fixed it for me on fc6. It wasnt working until I installed pam_keyring, logged in manually, rebooting, and it worked.

Thanks again.

:EDIT:

haha, I guess I spoke too soon. This works when you manually login. However, if you set to auto login, it doesnt work for me. I get the keyring password prompt.

Is there a way to make it promptless? No logins, no password nag screens, just boots and connects to the wireless seamlessly?
I don't think so... I think what pam_keyring does is to remember your last used password and use it when its authenicate again... that's why you need to set the default passwd as your login password... so you need to login for pam_keyring to "remember" a password to use.

Last edited by admun; 5th December 2006 at 07:36 PM.
  #12  
Old 5th December 2006, 03:44 PM
chocobanana Offline
Registered User
 
Join Date: Jun 2005
Posts: 125
how about if you have auto-login enabled, does it work?
  #13  
Old 5th December 2006, 07:35 PM
admun Offline
Registered User
 
Join Date: May 2005
Location: Ottawa, Canada
Posts: 40
Quote:
Originally Posted by chocobanana
how about if you have auto-login enabled, does it work?
Not sure... but my guess is it may not. Since no manual login happen previously, the pam_keyring is not trigger to save the "last" password (for later use)? I guess that it comes to maybe the autologin function didn't shared the password with pam_keyring???? I am no expert on this, pure guess here.
  #14  
Old 5th December 2006, 10:49 PM
chocobanana Offline
Registered User
 
Join Date: Jun 2005
Posts: 125
Despite the way it works, the gnome keyring manager should be just like KDE's wallet - you choose to use it or not. It's that simple! No workarounds, no confused minds, no fuss at all!
  #15  
Old 6th December 2006, 03:48 AM
linux4kix Offline
Registered User
 
Join Date: Dec 2003
Posts: 19
What is really going on

Sorry guys I have been a little lax on my forum browsing. I am the current maintainer of pam_keyring and here is what it does/doesn't do.

gnome_keyring_daemon stores secrets in an encrypted keyring file. When you create the file you must provide a passphrase which is used as the key for the encryption algorithm. Without that key you can't unencrypt the keyring file and gnome apps that have stored secrets can't get access to them.

pam_keyring works in the pam stack to take the password you provide to gdm and use that password to unlock the keyring specified, or the default keyring if no keyring is specified. Because this happens before the gnome-session is started a few things have to happen. Pam_keyring launches gnome-keyring-daemon with the same UID as the user authenticating in pam. It then sets up the GNOME_KEYRING_SOCKET environment variable for that user. Finally it runs pam-keyring-tool as the user trying to unlock the default keyring with the password used to login to gdm.

If all goes well a user is logged in and doesn't need to provide a password for gnome-keyring.

This doesn't work for autologin because a password is never supplied to the pam stack. Autologin works because gdm runs as root and can launch a session as another uid without needing a password. Since no password is provided to the pam stack pam_keyring has no password to provide to gnome-keyring-daemon to use to unencrypt the keyring.

Hope that clears some things up.

Jon
Closed Thread

Tags
disable, gnome, keyring, manager

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome keyring manager axet Alpha, Beta & Snapshots Discussions (Fedora 11 Only) 2 30th May 2009 02:47 PM
Keyring Manager - Options to disable for openvpn tonypmartin Using Fedora 3 27th June 2008 06:28 AM
Gnome Keyring Manager FunkyRes Using Fedora 8 5th December 2007 12:47 AM
gnome-keyring-manager... thushanthan Using Fedora 0 21st May 2007 08:12 AM
XFCE with gnome-keyring-manager and NetworkManager PlateSpinner Using Fedora 5 18th August 2006 05:42 PM


Current GMT-time: 14:27 (Wednesday, 23-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat