Fedora Linux Support Community & Resources Center
  #1  
Old 26th November 2006, 08:34 PM
NorLin Offline
Registered User
 
Join Date: Jul 2004
Posts: 8
FC6 automount and ldap problem

Hi,
After I upgraded to FC6 the automount deamon wil not start.

In /var/log/messages I get the following messages:
Nov 26 21:22:54 tiger automount[11314]: Starting automounter version 5.0.1-0.rc2.22, master map auto.master
Nov 26 21:22:54 tiger automount[11314]: using kernel protocol version 5.00
Nov 26 21:22:54 tiger automount[11314]: lookup_init: lookup(ldap): failed to get query dn
Nov 26 21:22:54 tiger automount[11314]: mount_autofs_indirect: failed to read map for /dl
Nov 26 21:22:54 tiger automount[11314]: handle_mounts: mount of /dl failed!
Nov 26 21:22:54 tiger automount[11314]: master_do_mount: failed to startup mount
Nov 26 21:22:54 tiger automount[11314]: master_read_master: no mounts in table

My OpenLdap setup for automount is as follows:
# auto.master, net.home
dn: ou=auto.master,dc=net,dc=home
ou: auto.master
objectClass: top
objectClass: automountMap

# /dl, auto.master, net.home
dn: cn=/dl,ou=auto.master,dc=net,dc=home
cn: /dl
automountInformation: ldap:ou=auto.local,dc=net,dc=home --timeout 60
objectClass: automount

# auto.local, net.home
dn: ou=auto.local,dc=net,dc=home
ou: auto.local
objectClass: top
objectClass: organizationalUnit

# software, auto.local, net.home
dn: cn=software,ou=auto.local,dc=net,dc=home
objectClass: top
objectClass: automount
cn: software
automountInformation: -rw,intr,nosuid,rsize=8192,wsize=8192 nazgul:/dl/software

My /etc/sysconfig/autofs currently looks as follows:
#
# Define default options for autofs.
#
# DEFAULT_MASTER_MAP_NAME - default map name for the master map.
#
#DEFAULT_MASTER_MAP_NAME="auto.master"
#
# DEFAULT_TIMEOUT - set the default mount timeout (default 600).
#
DEFAULT_TIMEOUT=300
#
# DEFAULT_BROWSE_MODE - maps are browsable by default.
#
DEFAULT_BROWSE_MODE="no"
#
# DEFAULT_LOGGING - set default log level "none", "verbose" or "debug"
#
#DEFAULT_LOGGING="none"
DEFAULT_LOGGING="debug"
#
# Define the default LDAP schema to use for lookups
#
# System default
#
#DEFAULT_MAP_OBJECT_CLASS="nisMap"
#DEFAULT_ENTRY_OBJECT_CLASS="nisObject"
#DEFAULT_MAP_ATTRIBUTE="nisMapName"
#DEFAULT_ENTRY_ATTRIBUTE="cn"
#DEFAULT_VALUE_ATTRIBUTE="nisMapEntry"
#
# Other common LDAP nameing
#
DEFAULT_MAP_OBJECT_CLASS="automountMap"
DEFAULT_ENTRY_OBJECT_CLASS="automount"
DEFAULT_MAP_ATTRIBUTE="ou"
DEFAULT_ENTRY_ATTRIBUTE="cn"
DEFAULT_VALUE_ATTRIBUTE="automountInformation"
#
#DEFAULT_MAP_OBJECT_CLASS="automountMap"
#DEFAULT_ENTRY_OBJECT_CLASS="automount"
#DEFAULT_MAP_ATTRIBUTE="automountMapName"
#DEFAULT_ENTRY_ATTRIBUTE="automountKey"
#DEFAULT_VALUE_ATTRIBUTE="automountInformation"
#
# DEFAULT_AUTH_CONF_FILE - set the default location for the SASL
# authentication configuration file.
#
DEFAULT_AUTH_CONF_FILE="/etc/autofs_ldap_auth.conf"
#
# General global options
#
OPTIONS="-d -v"
#

The OpenLdap server runs on a FC5 macine but stopped working on the first client I upgraded to FC6
This setup has been working for years.

Any ideas?
Reply With Quote
  #2  
Old 7th December 2006, 02:18 AM
coec Offline
Registered User
 
Join Date: Jul 2005
Posts: 14
Hi, did you end up finding a fix? I've got exactly the same problem.

CC
Reply With Quote
  #3  
Old 22nd January 2007, 03:23 PM
myutopia Offline
Registered User
 
Join Date: Jan 2007
Posts: 3
I had the same problem

I commented out everything and just put this in /etc/sysconfig/autofs nothing alse and now it works

DEFAULT_LOGGING="debug"
DEFAULT_MAP_OBJECT_CLASS="automountMap"
DEFAULT_ENTRY_OBJECT_CLASS="automount"
DEFAULT_MAP_ATTRIBUTE="ou"
DEFAULT_ENTRY_ATTRIBUTE="cn"
DEFAULT_VALUE_ATTRIBUTE="automountInformation"
Reply With Quote
  #4  
Old 22nd January 2007, 03:26 PM
myutopia Offline
Registered User
 
Join Date: Jan 2007
Posts: 3
PS.

Aso I did try updateing autofs first and restarted the autofs daemon, but this didn't work, so if this doesn't fix the problem then try doing both incase it was a combination of things.
Reply With Quote
  #5  
Old 28th March 2007, 09:22 PM
obarrero Offline
Registered User
 
Join Date: Mar 2007
Posts: 4
Hi guys,

I have the same problem, I've already tried out changing the autofs as you suggested it above, but I still have the same problem when I try to start autofs,

mount_autofs_indirect: failed to read map for /red
Mar 28 15:07:41 ad12 automount[25463]: handle_mounts: mount of /red failed!
Mar 28 15:07:41 ad12 automount[25463]: master_do_mount: failed to startup mount
Mar 28 15:07:41 ad12 automount[25463]: mount_autofs_indirect: failed to read map for /users
Mar 28 15:07:41 ad12 automount[25463]: handle_mounts: mount of /users failed!
Mar 28 15:07:41 ad12 automount[25463]: master_do_mount: failed to startup mount
Mar 28 15:07:41 ad12 automount[25463]: mount_autofs_indirect: failed to read map for /red_sala
Mar 28 15:07:41 ad12 automount[25463]: handle_mounts: mount of /red_sala failed!
Mar 28 15:07:41 ad12 automount[25463]: master_do_mount: failed to startup mount
Mar 28 15:07:41 ad12 automount[25463]: master_read_master: no mounts in table

I use the same configuration with other machine with fc5 without any problem, but when I updated one machine to fc6 and leaving the nis server with fc5 I got this problem.

Can somebody give me a hand with this?

Thanks.
Reply With Quote
  #6  
Old 30th March 2007, 08:41 PM
myutopia Offline
Registered User
 
Join Date: Jan 2007
Posts: 3
Can you post the output from your /etc/sysconfig/autofs
Also did you try updating autofs and restarting the daemon.
Reply With Quote
  #7  
Old 9th April 2007, 03:20 PM
obarrero Offline
Registered User
 
Join Date: Mar 2007
Posts: 4
Hi Myutopia,

Thanks a lot for your help. Here the output from etc/sysconfig/autofs of the workstation which is fc6, anyhow I've tried the configurations proposed above, but the do not work. The version of autofs it has is autofs-5.0.1-0.rc3.26.


# Define default options for autofs.
#
# DEFAULT_MASTER_MAP_NAME - default map name for the master map.
#
#DEFAULT_MASTER_MAP_NAME="auto.master"
#
# DEFAULT_TIMEOUT - set the default mount timeout (default 600).
#
DEFAULT_TIMEOUT=300
#
# DEFAULT_BROWSE_MODE - maps are browsable by default.
#
#DEFAULT_BROWSE_MODE="no"
#
# DEFAULT_LOGGING - set default log level "none", "verbose" or "debug"
#
#DEFAULT_LOGGING="none"
#
# Define the default LDAP schema to use for lookups
#
# System default
#

DEFAULT_MAP_OBJECT_CLASS="nisMap"
DEFAULT_ENTRY_OBJECT_CLASS="nisObject"
DEFAULT_MAP_ATTRIBUTE="nisMapName"
DEFAULT_ENTRY_ATTRIBUTE="cn"
DEFAULT_VALUE_ATTRIBUTE="nisMapEntry"
#
# Other common LDAP nameing
#
#DEFAULT_MAP_OBJECT_CLASS="automountMap"
#DEFAULT_ENTRY_OBJECT_CLASS="automount"
#DEFAULT_MAP_ATTRIBUTE="ou"
#DEFAULT_ENTRY_ATTRIBUTE="cn"
#DEFAULT_VALUE_ATTRIBUTE="automountInformation"
#
#DEFAULT_MAP_OBJECT_CLASS="automountMap"
#DEFAULT_ENTRY_OBJECT_CLASS="automount"
#DEFAULT_MAP_ATTRIBUTE="automountMapName"
#DEFAULT_ENTRY_ATTRIBUTE="automountKey"
#DEFAULT_VALUE_ATTRIBUTE="automountInformation"
#
# DEFAULT_AUTH_CONF_FILE - set the default location for the SASL
# authentication configuration file.
#
#DEFAULT_AUTH_CONF_FILE="/etc/autofs_ldap_auth.conf"
#
# General global options
#
#OPTIONS=""
#

In the server (fc5) this are the maps

auto.master

#
# $Id: auto.master,v 1.4 2005/01/04 14:36:54 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).

#/misc /etc/auto.misc --timeout=60
#/smb /etc/auto.smb
#/misc /etc/auto.misc
#/net /etc/auto.net
/users /etc/auto.users
/red /etc/auto.red
/red_sala /etc/auto.red_sala

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
auto.users

* -fstype=nfs,soft,intr,rsize=8192,wsize=8192,nosuid, tcp laplace:/users:&

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
auto.red

software -nosuid,intr laplace:/red/&
cxoffice -nosuid,intr laplace:/red/&
bodega -nosuid,intr laplace:/red/&

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

programas -nosuid,intr ibague:/software_red/&

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

I looking forward to your reply

thanks,
Reply With Quote
  #8  
Old 14th April 2007, 06:03 AM
wesmoc Offline
Registered User
 
Join Date: Jun 2006
Location: USA
Posts: 9
I see a lot of "same problem here" messages, but no solutions. Did everyone else give up?

I just upgraded an FC5 box to FC6, and I am seeing the exact same problem. I had to create the file /etc/ldap, which contains "HOST ldap.mydomain.com", as that got me past the error where it wouldn't start the indirect mount for /home. But, then, I get the problem where I can't get to anything on the /home mount.

----- syslog messages -----
Apr 14 00:52:13 srv automount[12016]: Starting automounter version 5.0.1-0.rc3.26, master map auto.master
Apr 14 00:52:13 srvautomount[12016]: using kernel protocol version 5.00
Apr 14 00:52:13 srv automount[12016]: mounted indirect mount on /misc with timeout 300, freq 75 seconds
Apr 14 00:52:13 srv automount[12016]: ghosting enabled
Apr 14 00:52:13 srv automount[12016]: mounted indirect mount on /net with timeout 300, freq 75 seconds
Apr 14 00:52:13 srv automount[12016]: ghosting enabled
Apr 14 00:52:13 srv automount[12016]: mounted indirect mount on /home with timeout 300, freq 75 seconds
Apr 14 00:52:13 srv automount[12016]: ghosting enabled
Apr 14 00:52:32 srv automount[12016]: attempting to mount entry /home/testuser
Apr 14 00:52:32 srv automount[12016]: lookup_init: lookup(ldap): failed to get query dn
-----

----- /etc/sysconfig/autofs -----
DEFAULT_MASTER_MAP_NAME="auto.master"
DEFAULT_TIMEOUT=300
DEFAULT_LOGGING="debug"
DEFAULT_MAP_OBJECT_CLASS="automountMap"
DEFAULT_ENTRY_OBJECT_CLASS="automount"
DEFAULT_MAP_ATTRIBUTE="ou"
DEFAULT_ENTRY_ATTRIBUTE="cn"
DEFAULT_VALUE_ATTRIBUTE="automountInformation"
-----

Grr.. now why did they have to go and muck around with a good thing.. it worked very well and very reliably under FC5 with just a minor tweak to the init.d file. Now, I can't even get it to do much other than occupy ram.

Any ideas?

(yes, ldap is responding. getent and such return correct user data, and all other hosts (FC5) have no problem getting the ldap mounts)
Reply With Quote
  #9  
Old 14th April 2007, 09:52 AM
sideways Offline
Retired User
 
Join Date: Oct 2004
Location: London, UK
Posts: 4,999
Well, I don't know if this will help, but in fc6 /etc/auto.master has this line at the end
Code:
+auto.master
I once copied across an auto.master file from an old machine, forgot to add this line and automount wouldn't work.
Reply With Quote
  #10  
Old 14th April 2007, 05:59 PM
wesmoc Offline
Registered User
 
Join Date: Jun 2006
Location: USA
Posts: 9
Interestingly enough, autofs5 is getting the auto.master from LDAP... My auto.master file already had +auto.master in it, and it is detecting the /home mount information from the LDAP entry.

However, it's not getting any further...

In other words, in LDAP, I've got ou=auto.master,dc=mydomain,dc=com. In that ou, I've got cn=/home with the automountInformation entry:
[code]ldap ldap.mydomain.com:ou=auto.home,dc=mydomain,dc=com[/cpde]

My existing auto.master just has +auto.master in it. I even went so far as to try updating /etc/sysconfig/autofs's DEFAULT_MASTER_MAP_NAME to be "ldap:ou=auto.master,dc=mydomain,dc=com". When autofs starts up, I see logged:
Code:
Apr 14 12:56:30 neuron automount[14044]: Starting automounter version 5.0.1-0.rc3.26, master map ldap:ou=auto.master,dc=mydomain,dc=com
Apr 14 12:56:30 myhost automount[14044]: using kernel protocol version 5.00
Apr 14 12:56:31 myhost automount[14044]: mounted indirect mount on /home with timeout 300, freq 75 seconds
Apr 14 12:56:31 myhost automount[14044]: ghosting enabled
So, it looks as if it starts the /home automount point, but any access to the /home mount point comes back as "No such file or directory" with a correspoding entry in /var/log/messages:
Code:
Apr 14 12:57:49 myhost automount[14044]: attempting to mount entry /home/testuser
Apr 14 12:57:49 myhost automount[14044]: lookup_init: lookup(ldap): failed to get query dn
Apr 14 12:57:49 myhost automount[14044]: failed to mount /home/testuser
I'm not entirely sure what the error "failed to get query dn" means, though.. and I am sure that is the key to the issue I am seeing..
Reply With Quote
  #11  
Old 15th April 2007, 12:13 AM
wesmoc Offline
Registered User
 
Join Date: Jun 2006
Location: USA
Posts: 9
Unhappy

Hrmm.. I am beginning to wonder if autofs5 is just completely broken when it comes to LDAP maps, especially under Fedora. There certainly isn't a lot of documentation, help files, or even valuable debugging information to be found.

For one, the undocumented /etc/ldap file (no, not the /etc/ldap.conf file). If that file does not exist at all, I can't get automounter to even start. I found one reference to placing a HOST line in it, which seemed to help, but, man, my brain hurts from burning hours on this and getting no where.

I then came across http://www.redhat.com/docs//manuals/...ig-autofs.html, which references rfc2307bis schema. I don't have that schema present on my system.

Argh.. too little information combined with conflicting information.. Gotta love when "upgrading" sets you back this far.

Is it too much to ask for a working automounter under FC6 with an LDAP backend?
Reply With Quote
  #12  
Old 15th April 2007, 03:45 AM
wesmoc Offline
Registered User
 
Join Date: Jun 2006
Location: USA
Posts: 9
I loaded up a test machine and did some tinkering and I was able to get it to work. yeah!

In auto.master, I commented out the +auto.master and added the entry:
Code:
/home ldap:ldap.mydomain.com:ou=auto.home,dc=mydomain,dc=com
I restarted autofs, and everything worked fine. So, it looks like autofs5 was having problems getting the auto.master map from ldap.. or, at the very least, it was getting it, but something was wrong with the entry.

I looked at the existing LDAP entry for /home:
Code:
ldap ldap.mydomain.com:ou=auto.home,dc=mydomain,dc=com
The first thing I saw was the space between the protocol "ldap" and the host name "ldap.mydomain.com", and the fact that the entry I put in the auto.master had a colon there. I replaced the space with a colon, restarted autofs (with the +auto.master uncommented and my new entry removed from the auto.master file), and everything worked.

Of course, I now need to make sure that change doesn't negatively impact any of the other hosts...

Last edited by wesmoc; 1st September 2007 at 06:26 PM.
Reply With Quote
  #13  
Old 24th April 2007, 02:58 PM
obarrero Offline
Registered User
 
Join Date: Mar 2007
Posts: 4
Hi guys,

any other ideas, I have configured a NIS server, and I've tried everything suggested above but it does not work.

thanks.....
Reply With Quote
  #14  
Old 24th April 2007, 04:22 PM
ibbo Offline
Registered User
 
Join Date: Jun 2005
Location: Leeds
Posts: 1,264
I have had issue with automount via ldap for since i put FC6 on my machine too (wey back when) I posted a few threads but no joy came of it.

I have pretty much left out the ldap part now and used automount as you would with NIS for my hair was receding and going too grey to be getting this working when it would not work at all.

Pain in the rear end but workaroundable even though via LDAP would be the preffered method.

Perhaps FC7 will have addressed it.

ibbo
__________________
A Hangover Lasts A Day, But Our Drunken Memories Last A Lifetime
--
Linux user #349545
(GNU/Linux)iD8DBQBAzWjX+MZAIjBWXGURAmflAKCntuBbuKCWenpm XoA7LNydllVQOwCfdjyzXscddzQvlhBedAcD7qfKmHo==zx0H
Reply With Quote
Reply

Tags
automount, fc6, ldap, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Automount Problem shreedara Servers & Networking 0 11th October 2007 08:04 AM
NFS,LDAP,AUTOMOUNT,AUTOFS Server (security question) gimli Servers & Networking 8 16th January 2007 09:42 PM


Current GMT-time: 10:27 (Thursday, 02-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat